Keyboard sound is too intermittent and laggy to be useful

Bug #1289372 reported by Matthew Paul Thomas on 2014-03-07
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-keyboard (Ubuntu)
High
Michael Sheldon

Bug Description

Ubuntu Trusty r188, Samsung Galaxy Nexus

1. In System Settings > "Language & Text", turn on "Keyboard sound" if it is not on already.
2. Go to an app where you can type something, and type a sentence.

What happens: The keyboard sound plays less than half the time, and delayed by a second or more, such that it does not give useful confirmation of typing. For example, I just typed "Hello are you there", and the sound played eight times.

What should happen: The sound plays within about 200 ms of every keypress. And if it ever lags, it catches up rather than just dropping plays.

Related branches

Bill Filler (bfiller) on 2014-03-07
Changed in ubuntu-keyboard (Ubuntu):
status: New → Confirmed
importance: Undecided → High
Bill Filler (bfiller) on 2014-03-28
Changed in ubuntu-keyboard (Ubuntu):
assignee: nobody → Łukasz Zemczak (sil2100)
Łukasz Zemczak (sil2100) wrote :

On a Nexus 4 the difference is far less noticeable. When typing really fast I can see that some key presses can not be heard, but it doesn't seem to be problematic - have to check how this looks like on Android. But the delay of key press sound should be anyway fixed indeed.

Bill Filler (bfiller) on 2014-04-03
Changed in ubuntu-keyboard (Ubuntu):
assignee: Łukasz Zemczak (sil2100) → Michael Sheldon (michael-sheldon)
Changed in ubuntu-keyboard (Ubuntu):
status: Confirmed → In Progress

I've proposed a branch that should improve this, however I only have a Nexus 4 to test with so it'd be useful if someone with a Galaxy Nexus could also test to confirm whether the improvements are adequate.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-keyboard - 0.99.trunk.phablet2+14.04.20140407.1-0ubuntu1

---------------
ubuntu-keyboard (0.99.trunk.phablet2+14.04.20140407.1-0ubuntu1) trusty; urgency=low

  [ Michael Sheldon ]
  * Gradually decreases the interval between word deletion when
    backspace is held down, allowing for fast deletion of large blocks
    of text (fixes bug #1289374). (LP: #1289374)
  * Reduce latency for key press sounds by switching to a SoundEffect
    element (lower latency and better at simultaneous sounds than Audio)
    and triggering the sound on key press rather than on release. (LP:
    #1289372)
 -- Ubuntu daily release <email address hidden> Mon, 07 Apr 2014 15:02:24 +0000

Changed in ubuntu-keyboard (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers