With MIR enabled, pressing power key when a text field is selected inserts a * character

Bug #1232122 reported by Richard Huddie
24
This bug affects 3 people
Affects Status Importance Assigned to Milestone
qtubuntu (Ubuntu)
Undecided
Unassigned
ubuntu-keyboard (Ubuntu)
High
Thomas Moenicke
unity-mir (Ubuntu)
High
Unassigned
unity8 (Ubuntu)
Undecided
Unassigned

Bug Description

20130927

TEST CASE:
1. Ensure MIR is enabled on the device:
     adb shell touch /home/phablet/.display-mir
     adb reboot
1. Load messaging app and create a new message. Make sure the message text field is selcted with the OSK showing
2. Press the power key (device will go into standby mode)
3. Press power key again to power device back up, and go back to the messaging app.

EXPECTED RESULT:
The message text should be as it was before the power key was pressed

ACTUAL RESULT:
A * character has been inserted into the message.

This can be reproduced anywhere when the OSK is displayed. e.g. Notes, creating a contact etc.

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: ubuntu-keyboard 0.99.trunk.phablet2+13.10.20130926-0ubuntu1
Uname: Linux 3.4.0-3-mako armv7l
ApportVersion: 2.12.4-0ubuntu1
Architecture: armhf
Date: Fri Sep 27 16:19:05 2013
InstallationDate: Installed on 2013-09-27 (0 days ago)
InstallationMedia: Ubuntu Saucy Salamander (development branch) - armhf (20130927)
MarkForUpload: True
ProcEnviron:
 TERM=linux
 PATH=(custom, no user)
SourcePackage: ubuntu-keyboard
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Revision history for this message
Richard Huddie (rhuddie) wrote :
Bill Filler (bfiller)
Changed in ubuntu-keyboard (Ubuntu):
status: New → Triaged
importance: Undecided → Critical
importance: Critical → High
assignee: nobody → Thomas Moenicke (thomas-moenicke)
tags: added: rls-s-incoming
Bill Filler (bfiller)
Changed in unity-mir (Ubuntu):
assignee: nobody → Ricardo Mendoza (ricmm)
importance: Undecided → High
status: New → Confirmed
Revision history for this message
Olivier Tilloy (osomon) wrote :

See also a similar issue here: bug #1238098.

kevin gunn (kgunn72)
Changed in unity8 (Ubuntu):
status: New → Opinion
Revision history for this message
Michał Sawicz (saviq) wrote :

I very much doubt this is anything in unity8, unity-mir or ubuntu-keyboard. This is most probably just a * character delivered instead of PowerKey due to missing/incorrect mapping in qtubuntu.

no longer affects: ubuntu-keyboard
Changed in unity8 (Ubuntu):
status: Opinion → Invalid
Changed in unity-mir (Ubuntu):
assignee: Ricardo Mendoza (ricmm) → nobody
status: Confirmed → Invalid
Revision history for this message
Bill Filler (bfiller) wrote :

definitely not an osk bug

Changed in ubuntu-keyboard (Ubuntu):
status: Triaged → Invalid
kevin gunn (kgunn72)
Changed in unity-mir (Ubuntu):
status: Invalid → In Progress
Changed in unity8 (Ubuntu):
status: Invalid → Opinion
Changed in ubuntu-keyboard (Ubuntu):
status: Invalid → Opinion
Changed in qtubuntu:
status: New → Opinion
Changed in unity8 (Ubuntu):
status: Opinion → In Progress
Michał Sawicz (saviq)
Changed in ubuntu-keyboard (Ubuntu):
status: Opinion → Invalid
Changed in unity8 (Ubuntu):
status: In Progress → Invalid
Changed in qtubuntu:
status: Opinion → In Progress
assignee: nobody → Michał Sawicz (saviq)
Changed in unity-mir (Ubuntu):
status: In Progress → Invalid
Revision history for this message
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:qtubuntu at revision 189, scheduled for release in qtubuntu, milestone ubuntu-13.05

Changed in qtubuntu:
status: In Progress → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qtubuntu - 0.52+13.10.20131016-0ubuntu1

---------------
qtubuntu (0.52+13.10.20131016-0ubuntu1) saucy; urgency=low

  [ Michał Sawicz ]
  * Map PowerDown and PowerOff keys and fix indentation. (LP: #1232122)

  [ Alexandros Frantzis ]
  * Abort if we can't get an ubuntu application instance. (LP: #1233988)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 189
 -- Ubuntu daily release <email address hidden> Wed, 16 Oct 2013 02:33:02 +0000

Changed in qtubuntu (Ubuntu):
status: New → Fix Released
Michał Sawicz (saviq)
Changed in qtubuntu:
assignee: Michał Sawicz (saviq) → nobody
status: Fix Committed → Fix Released
Michał Sawicz (saviq)
no longer affects: qtubuntu
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers