Keyboard not entering caps/shifted state when first brought up or after punctuation

Bug #1214695 reported by Christopher Lee on 2013-08-21
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ubuntu-keyboard (Ubuntu)
Wishlist
Günter Schwann
Saucy
Wishlist
Günter Schwann

Bug Description

For instance typing in the Notes app; Tapping on a new note the keyboard appears but is in lowercase mode. Also typing abc. doesn't shift the keyboard into uppercase mode.

Related branches

Bill Filler (bfiller) wrote :

basically this is autocapitilzation which needs to be made to work. Note it does work correctly if predictive text turned on but we want it on regardless.

tags: added: autopilot
Changed in ubuntu-keyboard (Ubuntu):
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Thomas Moenicke (thomas-moenicke)

The autocaps feature requires the word engine to be on in order to make decisions about if it should capitalize the first character or not. The current settings naming scheme seems misleading. We should have:
- prediction on/off
- spell checking on/off
- autocorrection on/off
- autocaps on/off

Bill Filler (bfiller) wrote :

technically this is not a bug, it's a feature which has not yet been implemented. And it will be controlled by a System Setting called "Auto capitalization". We should disable the autopilot tests that are checking for this as it's not currently implemented. We can turn back on when the feature is complete.

Changed in ubuntu-keyboard (Ubuntu Saucy):
importance: High → Wishlist
Bill Filler (bfiller) wrote :

This is what we need to do for this bug
1
) figure out what is done when word engine/predictive text is on, as auto caps works in this case. You can see it work by typing a sentence and then a period. The next word gets capatialize automatically.
2) decouple the auto-caps from the word engine/predictive text such that it can be enabled/disabled on it's own via setting (autocaps)
3) honor the input hints Qt.ImhNoAutoUppercase, Qt.ImhPreferUppercase and Qt.ImhPreferLowercase to control whether a field wants to change the behavior of auto-caps. (see http://qt-project.org/doc/qt-5.0/qtquick/qml-qtquick2-textinput.html#inputMethodHints-prop)
4) set the appropriate hints for our applications. webbrowser for example should use Qt.ImhNoAutoUppercase

Changed in ubuntu-keyboard (Ubuntu Saucy):
assignee: Thomas Moenicke (thomas-moenicke) → Günter Schwann (schwann)
Günter Schwann (schwann) wrote :

Fix for starting in notes-app with upper case and point 3 from comment #4 is in
https://code.launchpad.net/~schwann/ubuntu-keyboard/keyboard-autocaps2

Point 4 from comment #4 is not neeeded as it is handled by the content type

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-keyboard - 0.99.trunk.phablet2+14.04.20131025-0ubuntu1

---------------
ubuntu-keyboard (0.99.trunk.phablet2+14.04.20131025-0ubuntu1) trusty; urgency=low

  [ Daniel d'Andrada ]
  * ubuntu-keyboard-info socket now reports the keyboard's scene
    geometry That's enough to cover keyboard rotations and animations.
    (LP: #1236489)

  [ Thomas Moenicke ]
  * adding key to change language.

  [ Leo Arias ]
  * Prepare for the release of autopilot 1.4 adding the dependency on an
    earlier release.

  [ Christopher Lee ]
  * Minor update/fixes for the autopilot emulators.

  [ Guenter Schwann ]
  * Keep url and @ key unchanged in shiftet state. (LP: #1240603)
  * Keep removing text when keeping the backspace key pressed.
  * Disable auto capitalization for any other content type than
    FreeTextContentType Wieth auto capitalizatin start with a capital on
    empty text fields.
  * After holding the backspace for a while, remove whole words. (LP:
    #1201988)
  * Reorganize tests let "make check" pass.
  * Decouple autocaps from predictive text fixes LP: #1214695. (LP:
    #1234685, #1214695)
  * Revert last 2 commit because of language issues.
  * Decouple autocaps from predictive text fixes LP: #1214695. (LP:
    #1214695)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 91
 -- Ubuntu daily release <email address hidden> Fri, 25 Oct 2013 11:04:48 +0000

Changed in ubuntu-keyboard (Ubuntu):
status: Confirmed → Fix Released
Changed in ubuntu-keyboard (Ubuntu Saucy):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers