Keyboard sometimes not showing up on first boot after flashing on Nexus 10

Bug #1157508 reported by Robbie Williamson on 2013-03-20
58
This bug affects 12 people
Affects Status Importance Assigned to Milestone
ubuntu-keyboard (Ubuntu)
High
Thomas Moenicke

Bug Description

With today's image, I am not presented with a keyboard when trying to enter my wifi password.

==================================
cat /system/quantal-ubuntu_stamp
HARDWARE=manta
JENKINS_BUILD=37
UBUNTU=manhattan-quantal-armhf-20130319-1
ubuntu/platform-api=:43
ubuntu/hybris=:123

Android repo head list:
abi/cpp : eb789ea : Fix for issue 28721.
android : 76c770f : default.xml: changing default -j from 4 to 1
bionic : a45cbac : Bionic/libm: Fix the mismatch ENTRY/END in e_pow.S
bootable/diskinstaller : 60d078a : Merge "Fix $(INSTALLED_ANDROID_IMAGE_DATA_TARGET) dependency"
bootable/recovery : c055b99 : Adding some Ubuntu specific customizations to recovery
build : 9a969c9 : envsetup.sh: disabling roomservice call from breakfast
development : 32d202f : Some changes added to compile and run with Java 6 and Java 7.
device/asus/grouper : 5362a5f : init.grouper.rc: changing default permission for sys/brightness
device/common : 201208b : libbt: Add support for board-specific configuration
device/generic/armv7-a : 700aab1 : disable lockscreen by default
device/generic/armv7-a-neon : 8a52ffa : disable lockscreen by default
device/generic/common : 11c092a : Add support for per device bluetooth configuration.
device/generic/goldfish : f0397b6 : copy files from development/data/etc to device/generic/goldfish/data/etc
device/generic/mips : 764fe78 : change mini_mips ARCH_VARIANT to mips32-fp instead of default mips32r2-fp
device/generic/x86 : ae8e76c : disable lockscreen by default
device/lge/mako : b8682ab : thermald-mako: don't control lcd brightness by default
device/sample : 7e69d92 : [sample] change apns-full-conf.xml
device/samsung/maguro : d0e55a3 : Update dependencies for CM-10.1
device/samsung/manta : 0b10e4a : init.manta.rc: changing default permission for sys/brightness
device/samsung/tuna : c596216 : init.tuna.rc: changing default permission for sys/brightness
device/ti/panda : 232b56a : remove bluetooth quick switch resource from overlay config file
external/aac : b2511c6 : Merge branch 'jb-mr1-release' of https://android.googlesource.com/platform/external/aac into mr1-staging
external/bouncycastle : 779b3b1 : bouncycastle: disabling java libs which requires target support
external/bsdiff : 23e322a : Merge "host modules don't need LOCAL_MODULE_TAGS"
external/busybox : 04f05b8 : Fix building under 4.2
external/bzip2 : 8a81a41 : Retire LOCAL_NDK_VERSION.
external/e2fsprogs : 4ecbd86 : Fix dev time initialization for cache age caculation
external/expat : bb9f3f7 : am 7174719f: Merge "Upgrade to expat 2.1.0."
external/flac : 686d6ff : Compile FLAC encoder in libFLAC
external/freetype : bad440f : Revert "freetype: Add Infinality patches"
external/gcc-demangle : d6f7018 : Build libgccdemangle for the host too.
external/genext2fs : 2e672fa : Move mkuserimg.sh to make_ext4fs
external/giflib : b027dc0 : Remove obsolete ThirdPartyProject.prop file.
external/gtest : 344e5f3 : Use $EXTERNAL_STORAGE instead of /sdcard.
external/harfbuzz : 6842c62 : Fix to make space width consistent in bidi
external/htop : e1a8535 : Fix the build on CM
external/icu4c : 12ffd01 : Merge branch 'jb-mr1-release' of https://android.googlesource.com/platform/external/icu4c into mr1-staging
external/jhead : 0feb6b7 : Remove exif jni
external/jpeg : ccfc460 : Merge branch 'jb-mr1-release' of https://android.googlesource.com/platform/external/jpeg into mr1-staging
external/kernel-headers : 4af6a3c : merge in jb-mr1-release history after reset to jb-mr1-dev
external/liblzf : 6946aa5 : Add NOTICE file for BSD license
external/libncurses : 565e8f2 : Compiliation fixes
external/libnl-headers : 6ccf734 : Move libnl headers to their own project
external/libogg : ec0b24f : Add make file for libogg library.
external/libpng : 9eec0a5 : Revert "Switch back to LOCAL_CLANG with -std=gnu89."
external/libvpx : b9c4e67 : Merge "[MIPS] VP8 optimizations for MIPS"
external/linux-tools-perf : 48630d7 : am 3043b188: Merge "Fix build for x86_64"
external/mksh : 93bd42c : Track libnativehelper move for PDK.
external/openssl : ba352ab : Remove references to obsolete ThirdPartyProject.prop
external/protobuf : f3e2240 : Disabling build for java libraries
external/qemu : a546c70 : Merge branch 'jb-mr1-release' of https://android.googlesource.com/platform/external/qemu into mr1-staging
external/qemu-pc-bios : 20349da : Merge "Change the MP table to support >16 IRQ number"
external/safe-iop : aa0725f : Remove obsolete ThirdPartyProject.prop file.
external/skia : cb5701e : Several skia tunings for JB_2.5
external/sonivox : 4a21314 : am 274d0571: Merge "Added support for parsing XMF versions 1.00 and 1.01 headers"
external/speex : fb7db58 : Remove obsolete ThirdPartyProject.prop file.
external/sqlite : a683f4e : Merge branch 'jb-mr1-release' of https://android.googlesource.com/platform/external/sqlite into mr1-staging
external/stlport : 30865cb : Revert "Unbundle libstlport with NDK r4."
external/strace : 7d2d23f : Merge "[MIPS] Add MIPS Support"
external/tinyalsa : ff2e542 : pcm: fix default capture start threshold
external/tremolo : 3eec179 : Merge "hardening: eliminate text relocations"
external/webp : 5a50414 : DO NOT MERGE Sync libwebp ver 0.2.0
external/webrtc : cf20dbf : Merge "Add the necessary macros to build webrtc for MIPS."
external/wpa_supplicant_6 : 0ff75d6 : Merge branch 'jb-mr1-release' of https://android.googlesource.com/platform/external/wpa_supplicant_6 into mr1-staging
external/wpa_supplicant_8 : ee1a2bc : Fix regression in LEAP
external/wpa_supplicant_8_ti : 161f26d : Add WFD dev info in device found event
external/yaffs2 : f58e662 : Remove superfluous eng tag on host binary. This fixes the build warning spam.
external/zlib : b481bdc : Remove usage of LOCAL_NDK_VERSION etc
frameworks/av : 5269ee2 : Make an exception for MR0_AUDIO_BLOB in loadHwModule_l
frameworks/base : 8fbb50d : [2/3] mediaeditor: Allow custom DOMX source instead of Google DOMX default
frameworks/native : a3986b9 : sensorservice: adding sleep to avoid race condition during start
frameworks/opt/emoji : 0805d75 : Rename (IF_)LOGE(_IF) to (IF_)ALOGE(_IF) DO NOT MERGE
hardware/broadcom/wlan : 7ada57e : Merge branch 'jb-mr1-release' of https://android.googlesource.com/platform/hardware/broadcom/wlan into HEAD
hardware/cm : 08c587e : audio: Update for JB compatibility
hardware/invensense : 33ce91b : MotionApps 5.1.1 release, with MA 5.1.0 for further merge review.
hardware/libhardware : af11587 : Merge tag 'android-4.2.2_r1' of https://android.googlesource.com/platform/hardware/libhardware into 1.1
hardware/libhardware_legacy : 3967e45 : Setting current stream volume as max by default
hardware/msm7k : e2d92ef : Merge branch 'jb-mr1-release' of https://android.googlesource.com/platform/hardware/msm7k into HEAD
hardware/qcom/audio : 2e6191c : setMasterVolume: return error to allow software mixer
hardware/qcom/audio-caf : 71a433c : Enhance ALSA for USB Dock Audio support
hardware/qcom/bt : ad7eab0 : libbt-vendor: implementation for Qualcomm chipsets
hardware/qcom/camera : b19a908 : Camera: add TARGET_PROVIDES_CAMERA_HAL
hardware/qcom/display : 2d4f8c2 : Fixing signed x unsigned comparison for gcc 4.7
hardware/qcom/display-caf : 679ec6d : gralloc: Add TARGET_USES_QCOM_BSP flag for non-AOSP features
hardware/qcom/gps : 09ce8ac : Split API 50000 support
hardware/qcom/keymaster : 3816bf0 : Initial empty repository
hardware/qcom/media : 333d0e4 : media: allow msm8660 into repo
hardware/qcom/msm8960 : 1527a7f : Initial empty repository
hardware/qcom/power : 53cc747 : qcom_power: add TARGET_PROVIDES_POWERHAL
hardware/qcom/sensors : 07c5bcd : Initial empty repository
hardware/qcom/wlan : 59d7a95 : wpa_supplicant_8_lib: reinstate wpa_driver_set_ap_wps_p2p_ie
hardware/ril : 25abac7 : Remove credential check for rild
hardware/samsung_slsi/exynos5 : 7219980 : merge in jb-mr1-release history after reset to jb-mr1-dev
hardware/ti/omap3 : f3af114 : Fix another misspelling of a symbol name (same exact symbol, different vendor)
hardware/ti/omap4xxx : d5d4715 : Disabling tf_daemon and CameraHal for proper phablet build
hardware/ti/wlan : 6db38e2 : Merge branch 'jb-mr1-release' of https://android.googlesource.com/platform/hardware/ti/wlan into HEAD
hardware/ti/wpan : 1f24d25 : Disabling builds for extras and not needed tools
kernel/asus/grouper : 06b7e9c : Expose virtual PID from child namespace in /proc/PID/status.
kernel/lge/mako : 010b7ed : Expose virtual PID from child namespace in /proc/PID/status.
kernel/samsung/manta : e005e78 : Expose virtual PID from child namespace in /proc/PID/status.
kernel/samsung/tuna : c2deee2 : Expose virtual PID from child namespace in /proc/PID/status.
libnativehelper : 73d3c2e : Make libnativehelper stand-alone.
packages/wallpapers/LivePicker : fd3290c : Merge tag 'android-4.2.2_r1' of https://android.googlesource.com/platform/packages/wallpapers/LivePicker into 1.1
prebuilt : 8cd7b1d : Remove everything that isn't a build tool
prebuilts/clang/darwin-x86/3.1 : 4262334 : Initial empty repository
prebuilts/clang/darwin-x86/3.2 : af856d7 : Initial empty repository
prebuilts/clang/linux-x86/3.1 : e95b4ce : Clang version 3.1.
prebuilts/clang/linux-x86/3.2 : 471afab : Initial empty repository
prebuilts/gcc/darwin-x86/arm/arm-eabi-4.6 : 21b2cba : Commit 64bit darwin hosted arm-eabi toolchain for kernel use.
prebuilts/gcc/darwin-x86/arm/arm-linux-androideabi-4.6 : cd1d69c : Check in 64-bit Darwin prebuilts for objcopy and strip.
prebuilts/gcc/darwin-x86/mips/mipsel-linux-android-4.6 : 837cdd9 : Merge "Update mips toolchain mipsel-linux-android-4.6 (darwin-x86)"
prebuilts/gcc/darwin-x86/x86/i686-linux-android-4.6 : 042d613 : Merge "Update x86 toolchain i686-linux-android-4.6 (darwin-x86)"
prebuilts/gcc/linux-x86/arm/arm-eabi-4.6 : d73a051 : Upgrade to host 64bit arm-eabi toolchain.
prebuilts/gcc/linux-x86/arm/arm-linux-androideabi-4.6 : 1aa5822 : Check in 64-bit Linux prebuilts for objcopy and strip.
prebuilts/gcc/linux-x86/arm/linaro-4.7.2 : a67a0d1 : Importing Linaro Cross Toolchain (GCC 4.7.2)
prebuilts/gcc/linux-x86/host/i686-linux-glibc2.7-4.4.3 : 10191e2 : Point to new location for source files
prebuilts/gcc/linux-x86/host/i686-linux-glibc2.7-4.6 : 9e754ea : Added missing defines and headers
prebuilts/gcc/linux-x86/host/x86_64-linux-glibc2.7-4.6 : 4b88bc4 : Added missing defines and headers (x86_64)
prebuilts/gcc/linux-x86/mips/mipsel-linux-android-4.6 : 90fc0bd : Merge "Update mips toolchain mipsel-linux-android-4.6"
prebuilts/gcc/linux-x86/x86/i686-linux-android-4.6 : b9ebba0 : Merge "Update x86 toolchain i686-linux-android-4.6"
prebuilts/misc : f32b66a : am e63e2c84: Manually update tradefed prebuilt from jb.
prebuilts/ndk : 9e04eb2 : merge in jb-mr1-release history after reset to jb-mr1-dev
prebuilts/qemu-kernel : f1b132a : arm: update kernel for iptables
prebuilts/sdk : de5b622 : merge in jb-mr1.1-release history after reset to jb-mr1.1-dev
prebuilts/tools : bbf7c25 : Merge "Add EasyMock 3.1, Objenesis 1.2 and cglib 2.2.3"
system/bluetooth : 098826f : Merge branch 'jb-mr1-release' of https://android.googlesource.com/platform/system/bluetooth into mr1
system/core : 1fa9dcf : Updating init.rc to include our needed services
system/extras : b15858a : Porting Android's log path to /dev/alog to avoid conflicts with syslogd
system/media : 139237f : Merge tag 'android-4.2.2_r1' of https://android.googlesource.com/platform/system/media into 1.1
system/security : ccba88f : Fixing narrowing errors
system/su : 52c188c : su: Setting root access to "ADB only" doesn't work
system/vold : 3ffe02b : Merge tag 'android-4.2.2_r1' of https://android.googlesource.com/platform/system/vold into 1.1
tools/build : 7eff274 : Merge "Remove the default java tasks and fix packaging java res"
ubuntu/assets : 3651fe6 : Renaming ubuntu_stamp to quantal-ubuntu_stamp
ubuntu/uchroot : ee46af2 : Add logic to uchroot to poweroff the phone automatically if the container dies.
vendor/cm : d1db8e5 : Fixing typo...

======================================

$ adb shell getprop ro.cm.device
manta

Ricardo Salveti (rsalveti) wrote :

I'm able to reproduce at least every time I flash the device. After a reboot (second boot), it works just fine.

Changed in touch-preview-images:
status: New → Confirmed
importance: Undecided → High
Robbie Williamson (robbiew) wrote :

Agreed. After I rebooted, the keyboard worked.

Robbie Williamson (robbiew) wrote :

Seems to come and go randomly between reboots.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1157508

tags: added: iso-testing
Michał Sawicz (saviq) wrote :

Can anyone please confirm with a recent image, please? Can't reproduce here.

Changed in touch-preview-images:
status: Confirmed → Incomplete
Michał Sawicz (saviq) wrote :

OK I got it now after a fresh flash.

Changed in touch-preview-images:
assignee: nobody → Michael Zanetti (mzanetti)
status: Incomplete → Confirmed
Michał Sawicz (saviq) wrote :

This is very difficult to reproduce - only happens to me on first boot after a fresh flash.

My gut says the keyboard takes a little longer to initialize on first boot and when the shell starts the OSK isn't there yet and it never tries to reconnect again.

Michał Sawicz (saviq) wrote :

OK, confirmed - if maliit-server isn't running when an app is launched, it will never try and reconnect.

Temporary solution - increase the qml-phone-shell timeout in /etc/*services.

Permanent solution - it should try to reconnect periodically or monitor for the OSK interface and reconnect when it becomes available.

Changed in touch-preview-images:
assignee: Michael Zanetti (mzanetti) → Thomas Moenicke (thomas-moenicke)
summary: - Keyboard not showing up for wifi password entry on Nexus 10
+ Keyboard sometimes not showing up on first boot after flashing on Nexus
+ 10
Paweł Stołowski (stolowski) wrote :

I'm affected by this issue and it doesn't seem to be connected with first reboot after flash (I do flash 'phablet-flash', no additional args). I don't have OSK at all when prompted for WIFI password, and I rebooted multimple times. Tested with rev 154 and 158, Galaxy Nexus. I tried to increase qml-phone-shell timeout (put values in range 8 - 30 there) and this didn't help.

Paweł Stołowski (stolowski) wrote :

It seems my issue was a different one as I lost OSK completly in all apps... Probably cause by an old qtubuntu / hybris / platform-api, 'phablet-flash -b' fixed it. So, please disregard my last comment, problem fixed for now.

pjharper (pjharper) wrote :

I just installed today. I have rebooted several times and still no on screen keyboard on Nexus 7 for setting up wireless. The image is in phablet-12 if that is any help.

I'll do another 'phablet-flash b' tonight.

affects: touch-preview-images → ubuntu-keyboard (Ubuntu)
tags: added: touch-preview-images
Futur (fusionneur) wrote :

Still bugged in Vivi Vervet

Andrew Gryaznov (realgrandrew) wrote :

this happened to me on OTA11 on meizu pro 5 - after installation keyboard failed to kick in several times including in browser and while adding accounts. Reboot helped to make it appear. In the browser it appeared okay in the address bar but not in the text or password fields

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers