Ubuntu GNOME community wallpapers

Bug #1294891 reported by Tim Lunn on 2014-03-19
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-gnome-wallpapers (Ubuntu)
High
Unassigned

Bug Description

This is a new package with the winning wallpapers from the Ubuntu GNOME community wallpaper contest for Trusty Cycle

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1294891/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
Daniel Holbach (dholbach) wrote :

A few small things need to be fixed:

 - the build fails:

intltool-update -p -g ubuntu-gnome-wallpapers

mismatched tag at line 33, column 4, byte 1100 at /usr/lib/perl5/XML/Parser.pm line 187.
xgettext: error while opening "../ug-trusty-wallpapers.xml.in.h" for reading: No such file or directory
ERROR: xgettext failed to generate PO template file. Please consult
       error message above if there is any.
error: command 'intltool-update' failed with exit status 1
dh_auto_build: python setup.py build --force returned exit code 1
make: *** [build] Error 1
dpkg-buildpackage: error: debian/rules build gave error exit status 2
E: Failed autobuilding of package

 - debian/copyright does not mention the files which are cc-by-nc nor is the license text included
 - debian/changelog could mention LP: #1294891 and the version number would probably better be 14.04.1 (there is no .orig tarball, right?)

Changed in ubuntu:
status: New → Incomplete

On Thursday, 20 March 2014 at 7:52 pm, Daniel Holbach wrote:

> A few small things need to be fixed:
>
> - the build fails:
>
> intltool-update -p -g ubuntu-gnome-wallpapers
>
> mismatched tag at line 33, column 4, byte 1100 at /usr/lib/perl5/XML/Parser.pm line 187.
> xgettext: error while opening "../ug-trusty-wallpapers.xml.in.h" for reading: No such file or directory
> ERROR: xgettext failed to generate PO template file. Please consult
> error message above if there is any.
> error: command 'intltool-update' failed with exit status 1
> dh_auto_build: python setup.py build --force returned exit code 1
> make: *** [build] Error 1
> dpkg-buildpackage: error: debian/rules build gave error exit status 2
> E: Failed autobuilding of package
>
>
Oops, I already fixed that, mustn't have pushed changes to branch, will update.
>
> - debian/copyright does not mention the files which are cc-by-nc nor is the license text included
>
>

we have explicit permission from the authors to release work under cc-by-sa 3.0, for all images that were cc-by-nc or all rights reserved on Flickr
> - debian/changelog could mention LP: #1294891 and the version number would probably better be 14.04.1 (there is no .orig tarball, right?)
>
>

will fix, and right should be upstream branch

>
> ** Changed in: ubuntu
> Status: New => Incomplete
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1294891
>
> Title:
> Ubuntu GNOME community wallpapers
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+bug/1294891/+subscriptions
>
>

Tim Lunn (darkxst) wrote :

updated branch with missing build fix, and changed version. I will assume the copyright stuff it ok, but let me know if not..

Daniel Holbach (dholbach) wrote :

I replied on IRC as well:
<dholbach> darkxst, if the content is all cc-by-sa - all the files should say so

Tim Lunn (darkxst) wrote :

updated AUTHORS file with correct license info

Changed in ubuntu:
status: Incomplete → New
Changed in ubuntu:
importance: Undecided → High
status: New → Triaged
Iain Lane (laney) wrote :

Ack for FFe

Daniel Holbach (dholbach) wrote :

Small things to consider in one of the next uploads:
I: ubuntu-gnome-wallpapers: capitalization-error-in-description meta-package metapackage
I: ubuntu-gnome-wallpapers-trusty: extended-description-is-probably-too-short
I: ubuntu-gnome-wallpapers source: missing-debian-source-format

More importantly:
 - please make COPYING contain the full text of the license
 - there are still mentions of CC-BY-SA-2.0 and CC-BY-SA-3.0 in debian/copyright
   can the two license be included verbatim in debian/copyright and as part of a COPYING (or some other license) file?

Dmitry Shachnev (mitya57) wrote :

Marking Incomplete per Daniel's review.

Changed in ubuntu:
status: Triaged → Incomplete
Tim Lunn (darkxst) wrote :

Branch has been updated to address Daniel's comments

Changed in ubuntu:
status: Incomplete → Confirmed
Iain Lane (laney) wrote :

Cheers, I uploaded it & pushed some minor changes to lp:~laney/+junk/ubuntu-gnome-wallpapers for you to merge to the Vcs-Bzr

Changed in ubuntu:
status: Confirmed → Fix Committed
Martin Pitt (pitti) wrote :

Closing, it got uploaded and is waiting in binNEW.

affects: ubuntu → ubuntu-gnome-wallpapers (Ubuntu)
Changed in ubuntu-gnome-wallpapers (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers