Imagemagick shouldn't show in default Ubuntu GNOME Activities Overview

Bug #1615435 reported by Jeremy Bicha on 2016-08-21
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-gnome-default-settings (Ubuntu)
Low
Unassigned
Xenial
Low
Unassigned

Bug Description

Impact
======
The ImageMagick app is ugly and has an unusual UI. Even worse, for some reason, clicking on the app in GNOME Shell's Activities Overview doesn't appear to do anything. Unfortunately, it is included in Debian's imagemagick package by default. The package is useful for its command-line scripts so we can't just not install the package.

Even stranger, there are now 2 of these ImageMagick apps with the same name that does the same thing.

This bug is a regression from Ubuntu GNOME 14.04 LTS where the ImageMagick app was successfully hidden. The .desktop changed its name (display.im6.desktop > display-im6.desktop) and added a second .desktop.

Triaging as "low" because it's a cosmetic issue (although it could be ranked higher because of the non-working app launchers)

Test Case
=========
- Install the update to ubuntu-gnome-default-settings.
- In GNOME Shell, open the Activities Overview. Click the Show Applications icon at the bottom left.
- Look for ImageMagick in the list. If it's not listed, this bug is fixed.

Regression Potential
===================
If anyone actually uses the app, they can still launch it from Alt-F2 or the command line (just run 'display').

If it wasn't for the fact that the .desktop's don't seem to work in GNOME Shell, a person could also override the override by copying /usr/share/applications/display.im6.desktop to ~/.local/share/application

Jeremy Bicha (jbicha) on 2016-08-21
Changed in ubuntu-gnome-default-settings (Ubuntu Xenial):
status: New → In Progress
importance: Undecided → Low
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-gnome-default-settings - 16.10.2

---------------
ubuntu-gnome-default-settings (16.10.2) yakkety; urgency=medium

  * Adapt to new ImageMagick .desktop filenames to properly hide them from
    the Activities Overview (LP: #1615435)
  * Drop ubufox overrides. Since ubufox is distributed as a Mozilla-signed
    packed xpi, we can't override the Firefox homepage like we used to.
  * Drop debian/ubuntu-gnome-default-settings.maintscript:
    - These migrations were completed in Ubuntu 14.04 LTS
  * Drop debian/bzr-builddeb.conf: No need to tell bzr-builddeb to use
    native mode because it does this automatically
  * Bump dh compat to 10
  * Bump Standards-Version to 3.9.8

 -- Jeremy Bicha <email address hidden> Sun, 21 Aug 2016 18:04:27 -0400

Changed in ubuntu-gnome-default-settings (Ubuntu):
status: Fix Committed → Fix Released

Hello Jeremy, or anyone else affected,

Accepted ubuntu-gnome-default-settings into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ubuntu-gnome-default-settings/16.04.5 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in ubuntu-gnome-default-settings (Ubuntu Xenial):
status: In Progress → Fix Committed
tags: added: verification-needed
Jeremy Bicha (jbicha) wrote :

I installed the proposed update on Ubuntu GNOME 16.04 and I confirmed that the imagemagick icons disappeared from the Activities Overview as expected.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-gnome-default-settings - 16.04.5

---------------
ubuntu-gnome-default-settings (16.04.5) xenial; urgency=medium

  * Adapt to new ImageMagick .desktop filenames to properly hide them from
    the Activities Overview (LP: #1615435)

 -- Jeremy Bicha <email address hidden> Sun, 21 Aug 2016 18:04:27 -0400

Changed in ubuntu-gnome-default-settings (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for ubuntu-gnome-default-settings has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers