plymouthd crashed with SIGSEGV in script_obj_deref_direct() -> Parser error : Error opening file /lib/plymouth/themes/ubuntu-gnome-logo/ubuntu-gnome-logo.script

Bug #1536771 reported by Bruce Pieterse on 2016-01-21
158
This bug affects 32 people
Affects Status Importance Assigned to Milestone
Ubuntu GNOME
High
Unassigned
ubuntu-gnome-default-settings (Ubuntu)
High
Unassigned

Bug Description

Normal boot. No plymouth splash screen. There is an error in the Plymouth debug log regarding a script file.

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: plymouth 0.9.2-3ubuntu9
ProcVersionSignature: Ubuntu 4.3.0-6.17-generic 4.3.3
Uname: Linux 4.3.0-6-generic x86_64
ApportVersion: 2.19.3-0ubuntu3
Architecture: amd64
CurrentDesktop: GNOME
Date: Thu Jan 21 22:08:16 2016
DefaultPlymouth: /usr/share/plymouth/themes/ubuntu-gnome-logo/ubuntu-gnome-logo.plymouth
InstallationDate: Installed on 2015-11-16 (66 days ago)
InstallationMedia: Ubuntu-GNOME 16.04 LTS "Xenial Xerus" - Alpha amd64 (20151114)
MachineType: MSI MS-7924
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.3.0-6-generic.efi.signed root=UUID=e074b920-0c02-406e-80ae-813a4617513e ro quiet splash plymouth.debug vt.handoff=7
ProcFB: 0 radeondrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.3.0-6-generic.efi.signed root=UUID=e074b920-0c02-406e-80ae-813a4617513e ro quiet splash plymouth.debug vt.handoff=7
SourcePackage: plymouth
TextPlymouth: /usr/share/plymouth/themes/ubuntu-gnome-text/ubuntu-gnome-text.plymouth
UdevLog: Error: [Errno 2] No such file or directory: '/var/log/udev'
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 07/28/2015
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: V2.10
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: H97M-G43(MS-7924)
dmi.board.vendor: MSI
dmi.board.version: 1.0
dmi.chassis.asset.tag: To be filled by O.E.M.
dmi.chassis.type: 3
dmi.chassis.vendor: MSI
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrV2.10:bd07/28/2015:svnMSI:pnMS-7924:pvr1.0:rvnMSI:rnH97M-G43(MS-7924):rvr1.0:cvnMSI:ct3:cvr1.0:
dmi.product.name: MS-7924
dmi.product.version: 1.0
dmi.sys.vendor: MSI

Bruce Pieterse (octoquad) wrote :
Bruce Pieterse (octoquad) wrote :

Bug #927636 is for wily and also has a debug log for the older version of Plymouth.

Changed in ubuntu-gnome:
milestone: none → xenial
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in plymouth (Ubuntu):
status: New → Confirmed
Changed in ubuntu-gnome-default-settings (Ubuntu):
status: New → Confirmed
Changed in plymouth (Ubuntu):
importance: Undecided → High
Changed in ubuntu-gnome-default-settings (Ubuntu):
importance: Undecided → High
Bruce Pieterse (octoquad) wrote :

I still get this crash after every boot. So if you need any more info, let me know.

Bruce Pieterse (octoquad) wrote :

For this particular problem, this has been fixed in ubuntu-gnome-default-settings.

ubuntu-gnome-default-settings:
  Installed: 16.04.3
  Candidate: 16.04.3
  Version table:
 *** 16.04.3 500
        500 http://za.archive.ubuntu.com/ubuntu xenial/universe amd64 Packages
        500 http://za.archive.ubuntu.com/ubuntu xenial/universe i386 Packages
        100 /var/lib/dpkg/status

I no longer get a SIGSEGV in script_obj_deref_direct() due to this fix.

no longer affects: plymouth (Ubuntu)
Changed in ubuntu-gnome-default-settings (Ubuntu):
status: Confirmed → Fix Released
Changed in ubuntu-gnome:
status: New → Fix Released
importance: Undecided → High
summary: - plymouthd crashed with SIGSEGV in script_obj_deref_direct()
+ plymouthd crashed with SIGSEGV in script_obj_deref_direct() -> Parser
+ error : Error opening file /lib/plymouth/themes/ubuntu-gnome-logo
+ /ubuntu-gnome-logo.script
Tim Lawrence (alkaliv2) wrote :

I'm still receiving this error after doing do-release-upgrade from 15.10 to 16.04. The package variant of ubuntu-gnome-default-settings for my computer is 16.04.4 and the crash is the same as above complaining about SIGSERV(). I submitted it automatically when the error occurred but I wanted to mention this was still an issue for me.

lorenzo.chianura (zuloch) wrote :

I'm still receiving this error in a clean ubuntu GNOME 16.04 install, as dpkg -l says:

ii ubuntu-gnome-default-settings 16.04.4

Boris Hollas (borish) wrote :

Me too, plymouthd crashes after each login.

ii ubuntu-gnome-default-settings 16.04.4

Bruce Pieterse (octoquad) wrote :

Tim, Lorenzo and Boris, can you confirm if you get a black screen when booting or if you have the Ubuntu GNOME splash screen before getting to the login screen?

lorenzo.chianura (zuloch) wrote :

I can confirm the Ubuntu GNOME

lorenzo.chianura (zuloch) wrote :

(sorry for the half comment)
I can confirm the Ubuntu GNOME splash screen before the login.

Bruce Pieterse (octoquad) wrote :

Thanks Lorenzo. This bug was when we didn't have a splash screen (was just black) before the login screen. It's pretty interesting though, I did encounter this problem yesterday after an upgrade from 15.10 to 16.04, but never got it again. I do suspect that this is a different issue though.

If you are affected by this please can you do the following in a terminal:

$ sudo gedit /etc/default/grub

On the GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" line, add "plymouth:debug" to that value so it becomes:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash plymouth:debug"

Save the file and then run:

$ sudo update-grub

Reboot when convenient.

This will log some debugging information out to /var/log/plymouth-debug.log which you can then attach to this report. The above instructions are flexible enough in case it occurs every second or third time and not on every reboot (much like this original bug report).

For more information on debugging plymouth you can view the docs here: https://wiki.ubuntu.com/Plymouth#Debugging.

Bruce Pieterse (octoquad) wrote :

If any of you do have a new bug number which was generated by apport on 16.04, please could you share it here. Thanks

ZCoyote (drillmast3r) wrote :

Hello!

I have same problem. I attache the plymouth-debug.log file.

John (jsalatas) wrote :

I'm evaluating ubuntu gnome 16.04 under virtualbox and I'm getting the same error.

attached you can find the plymouth-debug.log

John (jsalatas) wrote :

Just a quick update to my previous comment:

disabling 3D acceleration in the virtual machine settings, seems to fix the issue.

Dani (damufo) wrote :

Same problem an fresh install 16.04.

nano /etc/default/grub
-----
GRUB_DEFAULT=0
#GRUB_HIDDEN_TIMEOUT=10
#GRUB_HIDDEN_TIMEOUT_QUIET=false
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""
...
-----

akuma-kun (akuma-kun) wrote :

Hi,

As of 12-Jul-2016 i keep getting plymouthd crashes.

Here's below the beginning of the crash file report.

ProblemType: Crash
Architecture: amd64
CrashCounter: 1
Date: Tue Jul 12 22:00:21 2016
DistroRelease: Ubuntu 16.04
ExecutablePath: /sbin/plymouthd
ExecutableTimestamp: 1462902977
ProcCmdline: @sbin/plymouthd --mode=boot --pid-file=/run/plymouth/pid --attach-to-session

I installed Ubuntu Gnome from ISO on 03-Jul-2016 and all worked.

After few days the plymouthd crashes started to come up at nearly every start up.

Could anybody look into this?

Thanks.

Erick Brunzell (lbsolost) wrote :

I'm getting this after upgrading Trusty -> Xenial but apport never actually completes the bug filing process. It's there in /var/crash:

lance@lance-desktop:~$ ls /var/crash
_sbin_plymouthd.0.crash

Launchpad won't let me attach it.

vmware-gos-Yuhua (yhzou) wrote :

I encounter this issue in ubuntu-gnome-16.10-beta1-desktop-amd64.iso when the system boot up after installation.

raj (graja-19) wrote :

this issue was resolved when I ran sudo chown -R username:username /var/lib/plymouth/

Jojo (jojod) wrote :

I still have this issue on Ubuntu 16.04, even after "chown -R username:username /var/lib/plymouth/" which isn't a clean solution anyway.

mervyn thomas (mervyn-thomas) wrote :

Hi

I also have this problem on a clean Ubuntu Gnome 64 bit 16.04, running on a Lenovo Yoga 3.

I have tried chown -R username:username on /var/lib/plymouth, it made no difference.

many thanks for all your work.

Petr Prikryl (nich) wrote :

I fixed it using:

chown -R <user>:<user> /var/lib/plymouth

Pascal Mueller (lnpm) wrote :

I've fixed the below message with the path of /sbin/playmouthd as the same solution as abouve.

ProblemType: Crash
Architecture: amd64
CrashCounter: 1
Date: Tue Jul 12 22:00:21 2016
DistroRelease: Ubuntu 16.04
ExecutablePath: /sbin/plymouthd
ExecutableTimestamp: 1462902977
ProcCmdline: @sbin/plymouthd --mode=boot --pid-file=/run/plymouth/pid --attach-to-session

Fix:
chown -R <user>:<user> /sbin/playmouthd

Tero Gusto (tero-gusto) wrote :

I just had Plymouth crash on me after logging in, even after chowning with:
sudo chown -R <user>:<user> /sbin/plymouthd
Using Ubuntu Gnome 16.04

RavanH (ravanhagen) wrote :

Why does this say "Fix released" since March while this is still happening on 16.04.5 in December?

David-provost (david-provost) wrote :

Hello, I have the very same problem after fresh, clean install of Ubuntu 16.10 (after first boot). Every seems to work fine, though.
I already had the problem since 16.04.

JayBofMA (jayburrill) wrote :

I am seeing this nearly every boot in a recent, fresh install of Ubuntu GNOME:

ii ubuntu-gnome-default-settings 16.04.5

I will edit grub and see if anything interesting is logged.

Christian Ego (c.ego) wrote :

I experience the same bug. Had this since a few versions not on different machines.
Please finally fix this annoying issue. Or tell us how to get rid of plymouthd.

David Gregg (davegregg) wrote :

I'm getting this in Yakkety Yak.

Dan Allen (h-dan) wrote :

I am also receiving this error on a fresh install of Ubuntu Gnome 17.04.

Benedikt Kaiser (bndkt) wrote :

I receive this bug since over half a year now on every startup in my 16.04 Gnome

I used the chow solutions mentioned above but they only worked worked for a short time (until the next dist-upgrade I guess) - it's super annoying - probably will switch distro at one point even if I'm very happy with mine apart from this bug.

JayBofMA (jayburrill) wrote :

Wee over 15 months later, and all of the noted fixes have not been added to 16.04 LTS? I see this plymouthd crash every session, and dutifully report it each time. What is the meaning of LTS, anyway? You will see me checking the ignore box, from now on.

JayBofMA (jayburrill) wrote :

FWIW, here is my plymouth-debug.log. Hope it has some meaning to you.

Laurenz (laurenz0908) wrote :

Ubuntu Gnome 16.04, receive the same error. It says in the status Fix released but how come me and others still get the error? Or do I have to install a fix manually?

Thx for help

brett c neidecker (brettn1) wrote :

sudo dpkg-reconfigure Plymouth

fixed this problem for me...

David Graham (prograhammer) wrote :

First I tried: `sudo chown -R /sbin/plymouthd` but it didn't help. Then I tried `sudo dpkg-reconfigure Plymouth` (reported above from brett) and that worked!

"sudo dpkg-reconfigure Plymouth" worked for me :D

Dmitry (killroy192) wrote :

for me the bug was fixed by used command "sudo dpkg-reconfigure Plymouth" too.

Tero Gusto (tero-gusto) wrote :

Plymouthd started crashing again for me a few days ago, on Ubuntu Gnome 16.04, after getting fixed with a reconfigure ... I have now run it again, and it seemed to have fixed it. The error hasn't returned:
$ sudo dpkg-reconfigure Plymouth
update-initramfs: deferring update (trigger activated)
update-rc.d: warning: start and stop actions are no longer supported; falling back to defaults
update-rc.d: warning: start and stop actions are no longer supported; falling back to defaults
Processing triggers for initramfs-tools (0.122ubuntu8.8) ...
update-initramfs: Generating /boot/initrd.img-4.4.0-96-generic

Tero Gusto (tero-gusto) wrote :

Nope, it just crashed again ...

sudo dpkg-reconfigure Plymouth

fixed this problem for me @ xubuntu 16.04.3 LTS...

Pablo Nieloud (pnieloud) wrote :

"sudo dpkg-reconfigure Plymouth" solved the problem on xubuntu 16.04.1

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers