Ship Ubuntu Mono as default monospace font in Ubuntu 11.10

Bug #865013 reported by Paul Sladen
20
This bug affects 1 person
Affects Status Importance Assigned to Milestone
fontconfig (Ubuntu)
Won't Fix
Undecided
Unassigned
ubuntu-artwork (Ubuntu)
Fix Released
Wishlist
Unassigned
ubuntu-font-family-sources (Ubuntu)
Invalid
Undecided
Unassigned

Bug Description

Counterpart to bug #861334 ("Ship Ubuntu Mono .psf as default console font in Ubuntu 11.10"), but easier to implement.

Mark Shuttleworth has requested that Ubuntu Mono Regular be used as the default monospace font for terminal use in Ubuntu 11.10.

Hard Freeze was 72 hours ago. This would require:

  1. Upstream release of Ubuntu Font Family 0.80. DONE.
  2. Distro upload of Ubutu Font Family 0.80 minus Medium for oneiric. DONE.
  3a. Bumping "Ubuntu Mono" to first preference in 'fontconfig-config' package.
or:
  3b. Setting GNOME 'monospace-font-name' preference via gsettings in 'ubuntu-artwork'.

This can be done for 'fontconfig-config' in the files:

  /etc/fonts/conf.d/60-latin.conf

although Droid Sans has another interesting approach in:

     /etc/fonts/conf.d/60-ttf-droid-sans-mono-fonts.conf

which could be tested. Or for Ubuntu Artwork via a gsettings schema override (providing a default value for a key if no explicit value is otherwise set). For 'ubuntu-artwork' this would be done by setting 'monospace-font-name=' in the same place that 'font-name=' is set.

I have run the change of default monospace font past a member of the Ubuntu Doc team, who are happy with it, noting that none of the documentation screenshots cover monospace fonts. If there is a case, to the untrained eye one monospace is much like another and textual descriptions would be unaffected.

The only potentional outcome that could do with further investigation is how to increase the default font size by ~12% to compensate for Ubuntu Mono following Inconsolata's metrics, rather than DejaVu Sans Mono's metric (the present default) and investigation into potential integration side-effects/regressions.

Revision history for this message
Scott Kitterman (kitterman) wrote : Re: [Bug 865013] [NEW] Ship Ubuntu Mono as default monospace font in Ubuntu 11.10

Sigh.

One of the reasons given for the Ubuntu Mono FFe being low risk was that it is
not the default. So I feel a bit deceived over the last one.

Revision history for this message
Scott Kitterman (kitterman) wrote :

NACK from me. This doesn't address any final freeze worthy issues.

Revision history for this message
Jeremy Bicha (jbicha) wrote :

Scott, do you have any specific reasons against this request except for its lateness? It of course won't be the Kubuntu 11.10 default monospace font.

Revision history for this message
Scott Kitterman (kitterman) wrote : Re: [Bug 865013] Re: Ship Ubuntu Mono as default monospace font in Ubuntu 11.10

We have standards for what's appropriate after final freeze. This is not
consistent with those standards. If Mark wants to SABDFL it in then he is, of
course, welcome to do so, but in the standard process this is not appropriate
for this late in the game.

Revision history for this message
Iain Lane (laney) wrote :

FWIW, I'm with Scott here.

And even if there were good reasons to want this, the font is still a bit buggy around missing unicode characters so I'd be inclined to NACK for that too. (ref. https://bugs.launchpad.net/ubuntu-font-family/+bug/862401/comments/1)

Revision history for this message
Martin Pitt (pitti) wrote :

 >Scott, do you have any specific reasons against this request except for its lateness? It of course won't be the Kubuntu 11.10 default monospace font.

 * fontconfig is being used by all derivatives, so how does the proposed fontconfig change limit itself to Ubuntu?

 * How does it interact with Kubuntu/Xubuntu/Lubuntu/Ubuntu Studio, etc?

 * Has it been tested in CJK, Thai, Russian, and other non-latin locales?

Changed in ubuntu-font-family-sources (Ubuntu):
status: New → Invalid
Revision history for this message
Martin Pitt (pitti) wrote :

Closing font task, as Paul said that the change needs to happen in fontconfig. Setting fontconfig task to "Wontfix" as it was declined by two release team members. If Mark overrides this, please answer my questions in the previous comments for the regression assessment.

Thanks!

Changed in fontconfig (Ubuntu):
status: New → Won't Fix
Revision history for this message
Paul Sladen (sladen) wrote :

Thank you Pitti, yes:

  (1) Doing it via fontconfig-fonts, would not limit it to just Ubuntu/Unity. For purely GNOME theming, the following key could be set:

    $ gsettings get org.gnome.desktop.interface monospace-font-name
    'Monospace 11'

    $ gsettings set org.gnome.desktop.interface monospace-font-name 'Ubuntu Mono 12'

    $ gsettings get org.gnome.desktop.interface monospace-font-name
    'Ubuntu Mono 12'

  (2) fontconfig-fonts affects all. The platform-wide interactions have not received real integration testing. Those (large) numbers of people testing have been configuring the fonts in an environment to themselves and focusing on the typeface itself.

  (3) Ubuntu Mono does not include coverage for CJK or Thai.

    (3a) As presently occurs with DejaVu Sans Mono, those glyphs would continue to be substituted from other fonts.

    (3b) For CJK this actually works slightly better because CJK are generally drawn 1000x1000 and Ubuntu Mono is 500x1000. As a result a double-width character lays better then substituting into 2* 600x1000 (1200x1000) as with DejaVu Sans Mono.

    (3c) The Ubuntu Mono Cyrillic and Greek have not received the same level of testing as the Latin. The Cyrillic has collected a number of comments during feedback, particularly about the Cyrillic g ('Г', bug #784549 + five dups), Serbian soft n ('њ', bug #654192) and variations of the Serbian Cyrillic T ('Ђ, Ћ, ђ, ћ', bug #784585). The ghe in particular tends to caught the attention of a number of Russian outlets. Some from the last couple of days since the 0.80 release:

  http://www.blog-linux.ru/ubuntu-font-family-obnovili-do-0-80/
  "русская буквой «Г» в Ubuntu Mono явно отдыхали…"

  http://www.opennet.ru/openforum/vsluhforumID3/80543.html#1
  "Заглавная 'Г' оригинально выглядит"
  "Я бы даже сказал, что она выглядит как Г..."
  "Г — г…"

Paul Sladen (sladen)
Changed in ubuntu-artwork (Ubuntu):
importance: Undecided → Wishlist
Revision history for this message
Paul Sladen (sladen) wrote :

Minimal diff for 'ubuntu-artwork' simply setting the 'monospace-font-name' key.

(This is here for reference, not because I believe that it the concept should, or should not be applied).

Revision history for this message
Paul Sladen (sladen) wrote :

(Nigelb picked up the default size again today. Owing to the respective 72/96 DPI rounding maths (involved rounding up and rounding down); "Ubuntu Mono 13" is a much better match to "DejaVu Sans Mono 11" in the default configuration.

Both give a cell size of 9x18 pixels.

Revision history for this message
Paul Sladen (sladen) wrote :
Revision history for this message
Mark Shuttleworth (sabdfl) wrote :

Ack ScottK's concerns about the impact on derivatives.

I think it would be safe to transition the GNOME monospace default to the Ubuntu Mono. Paul's answered questions on glyph and language coverage, the gsettings approach would be specific to Ubuntu rather than *buntu, and the doc team are happy that there is no material impact on them. Fallback would be as per existing fonts so no glyphs would be lost or harmed in the production of this movie.

So, would ask the release team to consider the change in gsettings for Gnome apps only.

Paul Sladen (sladen)
description: updated
description: updated
description: updated
Revision history for this message
Martin Pitt (pitti) wrote :

https://launchpadlibrarian.net/81826898/monospace-font-name-ubuntu-mono-13.diff looks ok to me, please upload. This will at least limit the impact to gnome-terminal and friends and leave the derivatives unaffected.

Revision history for this message
Mark Shuttleworth (sabdfl) wrote :

Thanks Martin!

Revision history for this message
Paul Sladen (sladen) wrote :

Before.

Revision history for this message
Paul Sladen (sladen) wrote :

After.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-artwork - 54

---------------
ubuntu-artwork (54) oneiric; urgency=low

  * debian/ubuntu-artwork.gschema.override:
    - monospace-font-name='Ubuntu Mono 13' (LP: #865013)
 -- Paul Sladen <email address hidden> Tue, 04 Oct 2011 10:00:00 +0100

Changed in ubuntu-artwork (Ubuntu):
status: New → Fix Released
Revision history for this message
Paul Sladen (sladen) wrote :

Diff/upload per Martin's request in comment #14, should it be required.

This change should only affect the rendering of those (GNOME-based) application that source the value of 'monospace-font-name' via GSettings. The change will only affect those sessions where the user has never overridden the defaults. Those who have previously tested a variety of fonts would be manually responsible for unsetting/resetting the value:

  $ gsettings reset org.gnome.desktop.interface monospace-font-name

Given the extremely late nature of this change, I would feel more comfortable and be appreciative if other people could repeat the testing on the offered 'ubuntu-artwork=54' package and confirm getting similar Before/After results as above before it is considered for acceptance. The intent is that the perceived visual sizes in terms number of pixels per cell is roughly equal.

Note that a logout/login is required—normally gsettings is dynamic—as for some reason the reload trigger against:

  /usr/share/gconf/schemas/

denoted in in:

  /var/lib/dpkg/info/gconf2.triggers

is not immediately picking up the fresh installation from the 'ubuntu-artwork' package of a newer:

  /usr/share/glib-2.0/schemas/ubuntu-artwork.gschema.override

As a side-answer; GNOME 3 Control Center (on which the default Ubuntu configuration experience is based) removed the setting of fonts as a default user option. The 'gnome-tweak-tool' now provides this functionality, and can be found in the Ubuntu Software Centre:

  http://apt.ubuntu.com/p/gnome-tweak-tool

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers