SRU: The NVIDIA X server Settings is blank when under Intel mode

Bug #1931514 reported by Bin Li
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OEM Priority Project
Critical
Bin Li
ubuntu-drivers-common (Ubuntu)
Critical
Alberto Milone
Bionic
High
Alberto Milone
Focal
High
Alberto Milone
Groovy
Undecided
Unassigned
Hirsute
High
Alberto Milone

Bug Description

SRU Request

[Impact]

* The NVIDIA X server Settings does not show anything when the intel mode(Power Saving Mode) is working, so that it cannot switch back to Nvidia mode(Performance Mode) in the settings.

[Fix]

* Looking for the nvidia modules in the linux-restricted-modules path will solve the problem.

[Test Case]

* Boot up the system and login.

* Open the NVIDIA X Server Settings. If it shows the NVIDIA display card is working, switch it to intel display card and reboot.
* Open the NVIDIA X Server Settings again.

* Check that the panel is not blank.

[Regression Risk]
Medium, since it changes the code which finds the kernel modules.
_________________________________________________________________________
[Summary]
The VIIDA X server Settings does not show anything when the intel mode(Power Saving Mode) is working, so that it cannot switch back to Nvidia mode(Performance Mode) in the settings.

[Steps to reproduce]
1. Boot up the system and login.
2. Open the NVIDIA X Server Settings. If it shows the NVIDIA display card is working, switch it to intel display card and reboot.
3. Open the NVIDIA X Server Settings again. It does not show anything, and just a blank dialog.
mode
[Expected result]
The NVIDIA X Server Settings should show all configurations, and users can switch them in it.

[Actual result]
The dialog is blank.

[Failure rate]
100%

[Additional information]
ubuntu: 20.04.2
kernel-version: 5.10.0-1029-oem

Revision history for this message
Bin Li (binli) wrote :

The root cause is that the nvidia_loaded is false cause in Power Saving Mode, and nvidia_kmod_available is also false cause couldn't find nvidia.ko correctly, so it wont' do set_offloading() which cause nvidia-settings is blank.
Now we used the linux-modules-nvidia-5.10.0-xxx-oem package to support secure boot, and it will install the nvidia.ko in /lib/modules/5.10.0-xxx-oem/kernel/nvidia-460/, so we need fix the source code to detect the nvidia modules correctly.

            else if ((intel_loaded || amdgpu_loaded) && !nouveau_loaded &&
                                 (nvidia_loaded || nvidia_kmod_available)) {
                fprintf(log_handle, "NVIDIA hybrid system\n");

                /* Try to enable prime */
                if (enable_prime(prime_settings,
                             &discrete_device, current_devices, cards_n)) {

                    /* Write permanent settings about offloading */
                    set_offloading();
                }

tags: added: oem-priority originate-from-1931328 sutton
Alex Tu (alextu)
Changed in oem-priority:
importance: Undecided → Critical
Revision history for this message
Bin Li (binli) wrote :
Bin Li (binli)
tags: added: fossa-edge-staging
Alex Tu (alextu)
Changed in oem-priority:
assignee: nobody → Bin Li (binli)
Revision history for this message
Alberto Milone (albertomilone) wrote :

I have integrated, modified, and uploaded the changes to this PPA:
https://launchpad.net/~albertomilone/+archive/ubuntu/u-d-c-release

Please give it a try and see if it solves the problem. If it does, I will proceed with the SRU.

Changed in ubuntu-drivers-common (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)
status: New → In Progress
importance: Undecided → Critical
Revision history for this message
Bin Li (binli) wrote (last edit ):

@alberto,

I installed the 1:0.9.0~0.20.04.1 of dh-modaliases and ubuntu-drivers-common from #3, this issue is fixed. Thanks!

And please help to proceed the SRU for focal/20.04.

Bin Li (binli)
Changed in oem-priority:
status: New → Triaged
Changed in ubuntu-drivers-common (Ubuntu Bionic):
status: New → In Progress
Changed in ubuntu-drivers-common (Ubuntu Focal):
status: New → In Progress
Changed in ubuntu-drivers-common (Ubuntu Hirsute):
status: New → In Progress
Changed in ubuntu-drivers-common (Ubuntu Bionic):
importance: Undecided → High
Changed in ubuntu-drivers-common (Ubuntu Focal):
importance: Undecided → High
Changed in ubuntu-drivers-common (Ubuntu Hirsute):
importance: Undecided → High
Changed in ubuntu-drivers-common (Ubuntu Bionic):
assignee: nobody → Alberto Milone (albertomilone)
Changed in ubuntu-drivers-common (Ubuntu Focal):
assignee: nobody → Alberto Milone (albertomilone)
Changed in ubuntu-drivers-common (Ubuntu Hirsute):
assignee: nobody → Alberto Milone (albertomilone)
summary: - The NVIDIA X server Settings is blank when under Intel mode
+ SRU: The NVIDIA X server Settings is blank when under Intel mode
description: updated
Revision history for this message
Alberto Milone (albertomilone) wrote :

SRU team, please accept ubuntu-drivers-common 0.9.0~0.21.04.1, 0.9.0~0.20.10.1, 0.9.0~0.20.04.1, and 0.9.0~0.18.04.1 into -proposed.

Revision history for this message
Timo Aaltonen (tjaalton) wrote : Please test proposed package

Hello Bin, or anyone else affected,

Accepted ubuntu-drivers-common into hirsute-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ubuntu-drivers-common/1:0.9.0~0.21.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-hirsute to verification-done-hirsute. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-hirsute. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in ubuntu-drivers-common (Ubuntu Hirsute):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-hirsute
Revision history for this message
Timo Aaltonen (tjaalton) wrote :

Hello Bin, or anyone else affected,

Accepted ubuntu-drivers-common into groovy-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ubuntu-drivers-common/1:0.9.0~0.20.10.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-groovy to verification-done-groovy. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-groovy. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in ubuntu-drivers-common (Ubuntu Groovy):
status: New → Fix Committed
tags: added: verification-needed-groovy
Changed in ubuntu-drivers-common (Ubuntu Focal):
status: In Progress → Fix Committed
tags: added: verification-needed-focal
Revision history for this message
Timo Aaltonen (tjaalton) wrote :

Hello Bin, or anyone else affected,

Accepted ubuntu-drivers-common into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ubuntu-drivers-common/1:0.9.0~0.20.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Revision history for this message
Timo Aaltonen (tjaalton) wrote :

Hello Bin, or anyone else affected,

Accepted ubuntu-drivers-common into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ubuntu-drivers-common/1:0.9.0~0.18.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in ubuntu-drivers-common (Ubuntu Bionic):
status: In Progress → Fix Committed
tags: added: verification-needed-bionic
Revision history for this message
Bin Li (binli) wrote :

Upgraded the ubuntu-drivers-common from 1:0.8.6.5 to 1:0.9.0 from focal on ThinkPad P15v, this issue is fixed.

tags: added: verification-done-focal
removed: verification-needed-focal
Revision history for this message
Bin Li (binli) wrote :

Installed the 21.04 on P15v, upgraded the ubuntu-drivers-common from 1:0.8.7 to 1:0.9.0 from hirsute on ThinkPad P15v, this issue is fixed.

tags: added: verification-done-hirsute
removed: verification-needed-hirsute
Revision history for this message
Shengyao Xue (xueshengyao) wrote :

tested on groovy, this issue was fixed.

tags: added: verification-done-groovy
removed: verification-needed-groovy
Revision history for this message
Shengyao Xue (xueshengyao) wrote (last edit ):

tried testing on Bionic(Ubuntu 18.04), but I cannot update to the target version of ubuntu-drivers common. it seems there are some build failed here:
https://launchpad.net/ubuntu/+source/ubuntu-drivers-common/1:0.9.0~0.18.04.1

@Timo or @alberto, could you pls help on this? thanks.

jeremyszu (os369510)
tags: added: originate-from-1934872 stella
Revision history for this message
Alberto Milone (albertomilone) wrote :

I uploaded ubuntu-drivers-common_0.9.0~0.18.04.2 where I reverted the change that was causing the build failure (since we don't have the list-oem feature in bionic).

Revision history for this message
Andy Whitcroft (apw) wrote :

Hello Bin, or anyone else affected,

Accepted ubuntu-drivers-common into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ubuntu-drivers-common/1:0.9.0~0.18.04.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Revision history for this message
Andy Whitcroft (apw) wrote : Update Released

The verification of the Stable Release Update for ubuntu-drivers-common has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-drivers-common - 1:0.9.0~0.20.04.1

---------------
ubuntu-drivers-common (1:0.9.0~0.20.04.1) focal; urgency=medium

  [ Alberto Milone ]
  * gpu-manager.c:
    - Make sure to also search the signed modules (LP: #1931514).
      Credit goes to Bin Li for the first version of this patch.
  * debian/tests/control:
    - Add dependency on alsa-utils, since the autopkgtest requires it
      for the sl-modem detection plugin.
  * ubuntu-drivers:
    - Do not install recommended dependencies when calling
      "install --gpgpu" (LP: #1898601). The whole point of
      having --gpgpu was to reduce the amount of the
      installed dependencies.

  [ Michael Hudson-Doyle ]
  * debian/control:
    - Drop dependency on alsa-utils as we want to start using ubuntu-drivers in
      the server installer but do not want alsa-utils there. The code using
      aplay to detect certain kinds of modem will fail to detect them if aplay
      is not installed but will not crash. As alsa-utils is in the
      desktop-common seed there should be no loss of functionality anywhere
      ubuntu-drivers is used today.

 -- Alberto Milone <email address hidden> Thu, 24 Jun 2021 16:22:54 +0200

Changed in ubuntu-drivers-common (Ubuntu Focal):
status: Fix Committed → Fix Released
Bin Li (binli)
Changed in oem-priority:
status: Triaged → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-drivers-common - 1:0.9.1.2

---------------
ubuntu-drivers-common (1:0.9.1.2) impish; urgency=medium

  * tests/test_ubuntu_drivers.py:
    - Fix pycodestyle E265 block comment should start with "# ".

 -- Alberto Milone <email address hidden> Mon, 19 Jul 2021 20:33:07 +0200

Changed in ubuntu-drivers-common (Ubuntu):
status: In Progress → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-drivers-common - 1:0.9.0~0.21.04.1

---------------
ubuntu-drivers-common (1:0.9.0~0.21.04.1) hirsute; urgency=medium

  * gpu-manager.c:
    - Make sure to also search the signed modules (LP: #1931514).
      Credit goes to Bin Li for the first version of this patch.

 -- Alberto Milone <email address hidden> Fri, 18 Jun 2021 16:55:54 +0200

Changed in ubuntu-drivers-common (Ubuntu Hirsute):
status: Fix Committed → Fix Released
jeremyszu (os369510)
tags: added: originate-from-1934702
Revision history for this message
Łukasz Zemczak (sil2100) wrote : Proposed package removed from archive

The version of ubuntu-drivers-common in the proposed pocket of Bionic that was purported to fix this bug report has been removed because the bugs that were to be fixed by the upload were not verified in a timely (105 days) fashion.

tags: removed: verification-needed-bionic
Changed in ubuntu-drivers-common (Ubuntu Bionic):
status: Fix Committed → Won't Fix
tags: removed: verification-needed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers