Add support for installing gpgpu drivers

Bug #1819729 reported by Alberto Milone on 2019-03-12
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-drivers-common (Ubuntu)
Wishlist
Alberto Milone
Bionic
Wishlist
Alberto Milone

Bug Description

SRU Request:

[Impact]
We need the ubuntu-drivers tool to be able to install gpgpu driver meta-packages (without pulling in the kernel modules).

An additional "--gpgpu" parameter, paired with the "install" parameter will provide this feature.

Note: in this first implementation - already available in Ubuntu 19.04 - only the NVIDIA driver packages are supported.

[Test Case]
1) Enable the -proposed repository, and install the new ubuntu-drivers-common (1:0.5.2.3).

2) Make sure to have compatible NVIDIA hardware

3) Install the gpgpu driver:
ubuntu-drivers install --gpgpu

4) Make sure that the new driver is installed.

[Test Case - desktop regression test]
1) On a machine which has nvidia GPU hardware and has not had the gpgpu enabled as above, enable the -proposed repository and install the new ubuntu-drivers-common (1:0.5.2.3).
2) Run "Software & Updates" (software-properties-gtk)
3) Switch to the Additional Drivers tab
4) Confirm that information is display detailing the nvidia graphics drivers being available
5) Install the drivers from the UI by selecting the correct radio button and clicking Apply
6) After install has finished, reboot the system and check the drivers are loaded by opening Software & Updates again.

[Regression Potential]
Low. The changes do not affect the currently supported features.

description: updated
Changed in ubuntu-drivers-common (Ubuntu Bionic):
status: New → In Progress
importance: Undecided → Wishlist
Changed in ubuntu-drivers-common (Ubuntu):
status: In Progress → Confirmed
status: Confirmed → Fix Released
Changed in ubuntu-drivers-common (Ubuntu Bionic):
assignee: nobody → Alberto Milone (albertomilone)
Steve Langasek (vorlon) wrote :

This SRU all LGTM and as expected, but please include in the test case an explicit regression to test to ensure that the previous functionality still works as intended (i.e., a test of installing the nvidia X stack on a desktop through the GUI).

Changed in ubuntu-drivers-common (Ubuntu Bionic):
status: In Progress → Incomplete
Will Cooke (willcooke) on 2019-03-22
description: updated
Steve Langasek (vorlon) on 2019-03-22
description: updated
Steve Langasek (vorlon) on 2019-03-22
Changed in ubuntu-drivers-common (Ubuntu Bionic):
status: Incomplete → Triaged

Hello Alberto, or anyone else affected,

Accepted ubuntu-drivers-common into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ubuntu-drivers-common/1:0.5.2.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in ubuntu-drivers-common (Ubuntu Bionic):
status: Triaged → Fix Committed
tags: added: verification-needed verification-needed-bionic
Alberto Milone (albertomilone) wrote :
description: updated
description: updated
Alberto Milone (albertomilone) wrote :

Screenshot after instaling the 390 NVIDIA driver, and rebooting. The driver works correctly.

:~$ apt-cache policy ubuntu-drivers-common
ubuntu-drivers-common:
  Installed: 1:0.5.2.3
  Candidate: 1:0.5.2.3
  Version table:
 *** 1:0.5.2.3 400
        400 http://archive.ubuntu.com/ubuntu bionic-proposed/main amd64 Packages
        100 /var/lib/dpkg/status
     1:0.5.2.2 500
        500 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 Packages
     1:0.5.2 500
        500 http://archive.ubuntu.com/ubuntu bionic/main amd64 Packages

Alberto Milone (albertomilone) wrote :

*installing

Alberto Milone (albertomilone) wrote :

I uninstalled the driver, restarted the system, and tested the new --gpgpu parameter.

You can see the results in the attached log.

tags: added: verification-done verification-done-bionic
removed: verification-needed verification-needed-bionic
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-drivers-common - 1:0.5.2.3

---------------
ubuntu-drivers-common (1:0.5.2.3) bionic; urgency=medium

  * tests/ubuntu_drivers.py,
    UbuntuDrivers/detect.py,
    ubuntu-drivers:
    - Deprecate the "autoinstall" parameter in favour of
      "install". While "autoinstall" will still work,
      we recommend the latter.
    - Add support to for the --gpgpu parameter (LP: #1819729).

 -- Alberto Milone <email address hidden> Tue, 12 Mar 2019 16:31:04 +0100

Changed in ubuntu-drivers-common (Ubuntu Bionic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for ubuntu-drivers-common has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers