/etc/modprobe.d is not a file

Bug #1768637 reported by Seth Arnold on 2018-05-02
28
This bug affects 6 people
Affects Status Importance Assigned to Milestone
ubuntu-drivers-common (Ubuntu)
Low
Alberto Milone

Bug Description

Hello, I noticed the following entries in my journal after upgrading to 18.04 LTS from 16.04 LTS:

May 02 12:06:31 hunt gpu-manager[1112]: /etc/modprobe.d is not a file
May 02 12:06:31 hunt gpu-manager[1112]: /etc/modprobe.d is not a file
May 02 12:06:31 hunt gpu-manager[1112]: /etc/modprobe.d is not a file
May 02 12:06:31 hunt gpu-manager[1112]: /etc/modprobe.d is not a file
May 02 12:06:31 hunt gpu-manager[1112]: Error: can't open /lib/modules/4.15.0-20-generic/updates/dkms
May 02 12:06:31 hunt audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=gpu-manager comm="systemd" exe="/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
May 02 12:06:31 hunt audit[1]: SERVICE_STOP pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=gpu-manager comm="systemd" exe="/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
May 02 12:06:32 hunt gpu-manager[1170]: /etc/modprobe.d is not a file
May 02 12:06:32 hunt gpu-manager[1170]: /etc/modprobe.d is not a file
May 02 12:06:32 hunt gpu-manager[1170]: /etc/modprobe.d is not a file
May 02 12:06:32 hunt gpu-manager[1170]: /etc/modprobe.d is not a file
May 02 12:06:32 hunt gpu-manager[1170]: Error: can't open /lib/modules/4.15.0-20-generic/updates/dkms
May 02 12:06:32 hunt audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=gpu-manager comm="systemd" exe="/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
May 02 12:06:32 hunt audit[1]: SERVICE_STOP pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=gpu-manager comm="systemd" exe="/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
May 02 12:06:32 hunt gpu-manager[1254]: /etc/modprobe.d is not a file
May 02 12:06:32 hunt gpu-manager[1254]: /etc/modprobe.d is not a file
May 02 12:06:32 hunt gpu-manager[1254]: /etc/modprobe.d is not a file
May 02 12:06:32 hunt gpu-manager[1254]: /etc/modprobe.d is not a file
May 02 12:06:32 hunt gpu-manager[1254]: Error: can't open /lib/modules/4.15.0-20-generic/updates/dkms
May 02 12:06:32 hunt audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=gpu-manager comm="systemd" exe="/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
May 02 12:06:32 hunt audit[1]: SERVICE_STOP pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=gpu-manager comm="systemd" exe="/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
May 02 12:06:32 hunt gpu-manager[1316]: /etc/modprobe.d is not a file
May 02 12:06:32 hunt gpu-manager[1316]: /etc/modprobe.d is not a file
May 02 12:06:32 hunt gpu-manager[1316]: /etc/modprobe.d is not a file
May 02 12:06:32 hunt gpu-manager[1316]: /etc/modprobe.d is not a file
May 02 12:06:32 hunt gpu-manager[1316]: Error: can't open /lib/modules/4.15.0-20-generic/updates/dkms
May 02 12:06:33 hunt audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=gpu-manager comm="systemd" exe="/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
May 02 12:06:33 hunt audit[1]: SERVICE_STOP pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=gpu-manager comm="systemd" exe="/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
May 02 12:06:33 hunt systemd[1]: gpu-manager.service: Start request repeated too quickly.
May 02 12:06:33 hunt systemd[1]: gpu-manager.service: Failed with result 'start-limit-hit'.

The referenced dkms path does not exist:

sarnold@hunt:~$ ls -l /lib/modules/4.15.0-20-generic/updates/dkms
ls: cannot access '/lib/modules/4.15.0-20-generic/updates/dkms': No such file or directory
sarnold@hunt:~$ ls -l /lib/modules/4.15.0-20-generic/updates/
ls: cannot access '/lib/modules/4.15.0-20-generic/updates/': No such file or directory
sarnold@hunt:~$ ls -l /lib/modules/4.15.0-20-generic/
total 5292
lrwxrwxrwx 1 root root 40 Apr 23 21:56 build -> /usr/src/linux-headers-4.15.0-20-generic
drwxr-xr-x 2 root root 4096 Apr 23 21:56 initrd
drwxr-xr-x 15 root root 4096 May 1 18:23 kernel
-rw-r--r-- 1 root root 1253762 May 1 18:36 modules.alias
-rw-r--r-- 1 root root 1235639 May 1 18:36 modules.alias.bin
-rw-r--r-- 1 root root 7594 Apr 23 21:56 modules.builtin
-rw-r--r-- 1 root root 9600 May 1 18:36 modules.builtin.bin
-rw-r--r-- 1 root root 552117 May 1 18:36 modules.dep
-rw-r--r-- 1 root root 780401 May 1 18:36 modules.dep.bin
-rw-r--r-- 1 root root 317 May 1 18:36 modules.devname
-rw-r--r-- 1 root root 206162 Apr 23 21:56 modules.order
-rw-r--r-- 1 root root 515 May 1 18:36 modules.softdep
-rw-r--r-- 1 root root 589679 May 1 18:36 modules.symbols
-rw-r--r-- 1 root root 719498 May 1 18:36 modules.symbols.bin
drwxr-xr-x 3 root root 4096 May 1 18:23 vdso
sarnold@hunt:~$ find /lib/modules/4.15.0-20-generic/ -name dkms
sarnold@hunt:~$

Thanks

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: ubuntu-drivers-common 1:0.5.2
ProcVersionSignature: Ubuntu 4.15.0-20.21-generic 4.15.17
Uname: Linux 4.15.0-20-generic x86_64
NonfreeKernelModules: zfs zunicode zavl icp zcommon znvpair
ApportVersion: 2.20.9-0ubuntu7
Architecture: amd64
Date: Wed May 2 12:27:40 2018
InstallationDate: Installed on 2012-10-18 (2022 days ago)
InstallationMedia: Ubuntu 12.04.1 LTS "Precise Pangolin" - Release amd64 (20120823.1)
ProcEnviron:
 TERM=rxvt-unicode-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: ubuntu-drivers-common
UpgradeStatus: Upgraded to bionic on 2018-05-02 (0 days ago)

Seth Arnold (seth-arnold) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-drivers-common (Ubuntu):
status: New → Confirmed
Dimitri Pappas (fragtion) wrote :

Same thing here..wtf.

May 3 22:31:40 camview-pxe systemd[1]: Stopped Light Display Manager.
May 3 22:31:40 camview-pxe systemd[1]: Starting Detect the available GPUs and deal with any system changes...
May 3 22:31:40 camview-pxe gpu-manager[599]: /etc/modprobe.d is not a file
May 3 22:31:40 camview-pxe systemd[1]: Starting Set console scheme...
May 3 22:31:40 camview-pxe gpu-manager[599]: /etc/modprobe.d is not a file
May 3 22:31:40 camview-pxe NetworkManager[406]: <info> [1525379500.4101] manager: startup complete
May 3 22:31:40 camview-pxe systemd[1]: Started Set console scheme.
May 3 22:31:40 camview-pxe gpu-manager[599]: /etc/modprobe.d is not a file
May 3 22:31:40 camview-pxe systemd[1]: Created slice system-getty.slice.
May 3 22:31:40 camview-pxe gpu-manager[599]: /etc/modprobe.d is not a file
May 3 22:31:40 camview-pxe systemd[1]: Started Getty on tty1.
May 3 22:31:40 camview-pxe gpu-manager[599]: Error: can't open /lib/modules/4.13.0-39-generic/updates/dkms
May 3 22:31:40 camview-pxe gpu-manager[599]: Error: can't open /lib/modules/4.13.0-39-generic/updates/dkms
May 3 22:31:40 camview-pxe systemd[1]: Reached target Login Prompts.
May 3 22:31:40 camview-pxe systemd[1]: Started Detect the available GPUs and deal with any system changes.
May 3 22:31:40 camview-pxe systemd[1]: Starting Light Display Manager...

Harry Coin (hcoin) wrote :

This has been broken for years, and not understood or even looked at yet. Here's the start of it:
Bug #1369216 reported by dino99 on 2014-09-14

Harry Coin (hcoin) wrote :

FWIW I started seeing it after I installed a USB displaylink video adapter using kernel module evdi.ko in /lib/modules/4.15.0-34-generic/updates/dkms/

tags: added: rls-dd-incoming
Will Cooke (willcooke) wrote :

Not a release bug, so marking as notfixing. This can still be worked on and fixed though, only that it's not considered a release blocker.

tags: added: rls-dd-notfixing
removed: rls-dd-incoming
Changed in ubuntu-drivers-common (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)
Changed in ubuntu-drivers-common (Ubuntu):
importance: Undecided → Low
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-drivers-common - 1:0.5.7

---------------
ubuntu-drivers-common (1:0.5.7) disco; urgency=medium

  * share/hybrid/gpu-manager.service:
    - Do not let the output through journald (LP: #1768637).

 -- Alberto Milone <email address hidden> Wed, 09 Jan 2019 17:10:36 +0100

Changed in ubuntu-drivers-common (Ubuntu):
status: In Progress → Fix Released
Kalle Tuulos (kalle-tuulos) wrote :

This problem still exists in Ubuntu 16.04 LTS, as for it, the ubuntu-drivers-common version is 1:0.4.17.7.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers