SRU: Add support for keeping the dGPU on in power saving mode

Bug #1728547 reported by Alberto Milone on 2017-10-30
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
HWE Next
Undecided
Unassigned
OEM Priority Project
Undecided
Unassigned
ubuntu-drivers-common (Ubuntu)
High
Alberto Milone
Xenial
High
Alberto Milone
Zesty
High
Alberto Milone
Artful
High
Alberto Milone

Bug Description

SRU Request:

[Impact]
Some systems don't play well when the dGPU is disabled. It should still be possible to use the Intel iGPU without disabling the dGPU.

[Test Case]
1) Enable the -proposed repository, and install the new "ubuntu-drivers-common"

2) Make sure the nvidia packages are installed, and enable power saving mode:
sudo prime-select intel

3) Restart your computer and attach your /var/log/gpu-manager.log. see if the system boots correctly. If unsure, please attach your /var/log/gpu-manager.log and /var/log/Xorg.0.log

4) Install the mesa-utils package:
sudo apt install mesa-utils

5) Check the output of the following command (which should mention Intel):
glxinfo | grep OpenGL

[Regression Potential]
Low, as the feature is disabled by default. This is only for hardware specific workarounds.

Changed in ubuntu-drivers-common (Ubuntu Xenial):
status: New → In Progress
Changed in ubuntu-drivers-common (Ubuntu Zesty):
status: New → In Progress
Changed in ubuntu-drivers-common (Ubuntu Xenial):
importance: Undecided → High
Changed in ubuntu-drivers-common (Ubuntu Zesty):
importance: Undecided → High
Changed in ubuntu-drivers-common (Ubuntu Xenial):
assignee: nobody → Alberto Milone (albertomilone)
Changed in ubuntu-drivers-common (Ubuntu Zesty):
assignee: nobody → Alberto Milone (albertomilone)
tags: added: originate-from-1720950 somerville
description: updated
summary: - Add support for keeping the dGPU on in power saving mode
+ SRU: Add support for keeping the dGPU on in power saving mode
Alberto Milone (albertomilone) wrote :

Please approve the new ubuntu-drivers-common in xenial-proposed and in zesty-proposed.

Alberto Milone (albertomilone) wrote :

I forgot to mention the package in artful-proposed.

Changed in ubuntu-drivers-common (Ubuntu Artful):
status: New → In Progress
importance: Undecided → High
assignee: nobody → Alberto Milone (albertomilone)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-drivers-common - 1:0.4.24

---------------
ubuntu-drivers-common (1:0.4.24) bionic; urgency=medium

  * gpu-manager.{c|py}:
    - Add support for forcing the dGPU on on hybrid systems.
      Creating an empty file named "force-dgpu-on"
      in the /usr/share/gpu-manager.d directory will force the dGPU
      on in power saving mode (LP: #1728547).

 -- Alberto Milone <email address hidden> Mon, 30 Oct 2017 10:25:02 +0100

Changed in ubuntu-drivers-common (Ubuntu):
status: In Progress → Fix Released

Hello Alberto, or anyone else affected,

Accepted ubuntu-drivers-common into artful-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ubuntu-drivers-common/1:0.4.23.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-artful to verification-done-artful. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-artful. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in ubuntu-drivers-common (Ubuntu Artful):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-artful
Alex Tu (alextu) wrote :

verified 1:0.4.23.1 with xenial on MST-EVT-C2 , it looks good.

Alex Tu (alextu) wrote :

verified 1:0.4.23.1 with artful on FIR5K-PILOT-C1 , it looks good.

tags: added: verification-done-artful verification-done-xenial
removed: verification-needed-artful
Alex Tu (alextu) wrote :

@Alberto
it's verified done by #5 #6.
how's the status of further SRU process?

Alberto Milone (albertomilone) wrote :

I have re-uploaded the sources for xenial and zesty, this time mentioning LP: #1731873, so that the upload is not rejected again.

Brian Murray (brian-murray) wrote :

Hello Alberto, or anyone else affected,

Accepted ubuntu-drivers-common into zesty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ubuntu-drivers-common/1:0.4.22.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-zesty to verification-done-zesty. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-zesty. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in ubuntu-drivers-common (Ubuntu Zesty):
status: In Progress → Fix Committed
tags: added: verification-needed-zesty
Changed in ubuntu-drivers-common (Ubuntu Xenial):
status: In Progress → Fix Committed
tags: added: verification-needed-xenial
removed: verification-done-xenial
Brian Murray (brian-murray) wrote :

Hello Alberto, or anyone else affected,

Accepted ubuntu-drivers-common into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ubuntu-drivers-common/1:0.4.17.4 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Alex Tu (alextu) wrote :

verified on MST-EVT-C2, it works well.

tags: added: verification-done-xenial
removed: verification-needed-xenial
Alex Tu (alextu) wrote :

verified on FIR5K-PILOT-C1 for zesty , it works as well.

tags: added: verification-done-zesty
removed: verification-needed-zesty
Timo Aaltonen (tjaalton) on 2017-12-08
tags: removed: verification-needed
Yuan-Chen Cheng (ycheng-twn) wrote :

what's the reason we can't land this one on xenial ?

Anthony Wong (anthonywong) wrote :

Bug 1731873 is also awaiting verification, that is another bug for ubuntu-drivers-common SRU.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers