In a live session installing binary drivers, stops them from installing on the system

Bug #1508063 reported by Dave Morley on 2015-10-20
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Release Notes for Ubuntu
Undecided
Unassigned
ubuntu-drivers-common (Ubuntu)
Medium
Unassigned

Bug Description

STEPS:
1. Have a laptop that requires binary drivers
2. Boot from dvd/pen driver
3. Select try Ubuntu
4. In the live desktop select system settings
5. Select Software and Updates
6. Select Additional Drivers Tab
7. Select the binary drivers and install them
8. Double click on Install Ubuntu <version>
9. Select 3rd party drivers during the install process
10. See if the driver is installed on the completed system

EXPECTED:
I expect the see the drivers for (Wifi in my case) the hardware to be installed

ACTUAL:
The wifi driver in my case is missing meaning I can not connect to the internet.

TEMPORARY WORKAROUND:
Reboot the live session and just run an install, this will then include the binary driver.

OR

Insert the boot medium, in Software and Updates select boot cd as a medium for install, refresh the package list and then install from the cd the missing drivers.

Adam Conrad (adconrad) wrote :

So, the reason this happens is that the way we determine what to install is to actually install the drivers with "ubuntu-drivers autoinstall --package-list $1, which saves the list of INSTALLED packages into $1. Obviously, that doesn't work so well if you've already installed the packages manually, as "autoinstall" then installs nothing, and tells you as much.

So, we probably want to futz with this code a bit to actually sort out what *is* installed after an autoinstall, not only what we *just* installed.

Dave Morley (davmor2) on 2015-10-20
tags: added: qa-manual-testing
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1508063

tags: added: iso-testing
Changed in ubuntu-release-notes:
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-drivers-common (Ubuntu):
status: New → Confirmed
Changed in ubuntu-drivers-common (Ubuntu):
importance: Undecided → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers