DELL XPS 13: bcmwl-kernel-source not installed when 3rd party drivers is selected so no wifi and no ethernet port either

Bug #1481018 reported by Dave Morley on 2015-08-03
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-drivers-common (Ubuntu)
Undecided
Unassigned
Trusty
High
Adam Conrad

Bug Description

[ SRU Justification ]
WIRELESS NO WORKIE, HALP

[ Test Case ]
Boot into a live 14.04.3 system, hit a shell, upgrade to ubuntu-drivers-common from -proposed with dpkg -i, and a USB stick sneakernet, because your network doesn't work, and you don't want to perturb the bug by manually making it work, then run ubiquity and see if wireless bits install magically when "third party drivers" is selected.

[ Regression Potential ]
This same revert exists in utopic -> wily, and is working fine, and I also tested it by hand on an affected trusty machine, where it did the trick, so I don't think there's much chance for the 1-line code change to break. There's a slim chance that the fragile testsuite will explode, but that seemed to work fine here.

[ Original Report ]
STEPS:
1. Download the latest daily image of trusty from http://cdimages.ubuntu.com/trusty/daily-live/current
2. Copy this to a usb pendrive using the Disks app
3. Boot from this
4. Select install
5. Select Install 3rd party drivers
6. System reboots after install
7. Reboot to the live desktop
8. Do mkdir tmp
9. sudo mount /dev/sda1 tmp/
10. sudo mkdir tmp/EFI/boot
11. sudo touch tmp/EFI/boot/bootx64.efi
12. May need to hit F2 and up a new uefi point it to shim.efi on /EFI/ubuntu/
13. Boot and login
14. Try and connect to wifi

EXPECTED:
I expect to always be able to get online.

ACTUAL:
bcmwl-kernel-source is not installed, because there is no cd you can't install the driver from there and there is no ethernet port on this device so you can't install from there either.

WORKAROUND:
Insert the install usb stick, open a terminal, type:
sudo mkdir /media/cdrom
sudo mount /dev/sdb1 /media/cdrom
Open system settings
Select Software and Updates
On the Ubuntu Software tab check the box next to the CDrom
Close this to update the cache
Reopen tap on Additional Drivers tab and click on install the Broadcom 802.11......driver
Reboot

Dave Morley (davmor2) on 2015-08-03
tags: added: qa-manual-testing
Adam Conrad (adconrad) wrote :

This regression was introduced in an attempt to make the free driver the default, but it never really worked out as planned, and was later reverted in utopic. Reverting the same two commits in trusty will solve the issue. See:

https://github.com/tseliot/ubuntu-drivers-common/commit/628bd821864966ed3c4b8ae2da1cfb13d006f37f
https://github.com/tseliot/ubuntu-drivers-common/commit/30c092f6e6dcce06e014f34c379785ce8d849668

I'm going to SRU this as soon as I can get a clear answer on whether we can verify bug #1410801 in time, or if I should revert that SRU to upload mine.

affects: ubiquity (Ubuntu) → ubuntu-drivers-common (Ubuntu)
Changed in ubuntu-drivers-common (Ubuntu):
status: New → Fix Released
Changed in ubuntu-drivers-common (Ubuntu Trusty):
importance: Undecided → High
milestone: none → ubuntu-14.04.3
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1481018

tags: added: iso-testing
Adam Conrad (adconrad) on 2015-08-04
description: updated
Changed in ubuntu-drivers-common (Ubuntu Trusty):
assignee: nobody → Adam Conrad (adconrad)

Hello Dave, or anyone else affected,

Accepted ubuntu-drivers-common into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ubuntu-drivers-common/1:0.2.91.11 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in ubuntu-drivers-common (Ubuntu Trusty):
status: New → Fix Committed
tags: added: verification-needed
Dave Morley (davmor2) wrote :

I have tested the fix and I now have wifi on the xps 13. The way I tested was to start a live session install the .deb package in the live session then trigger the install. The installed version then had the ability to connect to the web.

On checking the installed system I can confirm that bcmwl-kernel-source is installed.

Adam Conrad (adconrad) on 2015-08-04
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-drivers-common - 1:0.2.91.11

---------------
ubuntu-drivers-common (1:0.2.91.11) trusty; urgency=medium

  * Backport from utopic version 1:0.2.98.4: debian/tests/system,
    tests/ubuntu_drivers.py, UbuntuDrivers/detect.py:
    - Revert the previous changes that made us switch from bcmwl to
      the open driver, as the latter (in order to be a full replacement)
      seems to require firmware that we cannot include in the Ubuntu
      image because of licensing issues (LP: #1481018).

 -- Adam Conrad <email address hidden> Tue, 04 Aug 2015 11:08:21 -0600

Changed in ubuntu-drivers-common (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for ubuntu-drivers-common has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers