Unable to install VirtualBox Guest Service in 15.04

Bug #1434579 reported by Martin Wimpress on 2015-03-20
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Andy Whitcroft
ubuntu-drivers-common (Ubuntu)
High
Unassigned
virtualbox (Ubuntu)
High
Adam Conrad

Bug Description

It is not longer possible to select VirtualBox Guest Service in 15.04. The only options available are:

  * Continue using a manually install driver
  * Do not use the device

The option 'Using x86 virtualisation solution - guest addition module' is no longer selectable. See the attached screen shot. This is from a fresh install of Ubuntu MATE 15.04 daily (20th March) and no drivers have been manually installed.

In light of the Virtualbox issue where new installs on Virtualbox have a resolution of 640x480 (https://bugs.launchpad.net/ubuntu/+source/virtualbox/+bug/1368784/) this is going to be a frustration for many users.

Martin Wimpress (flexiondotorg) wrote :
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1434579

tags: added: iso-testing
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in software-properties (Ubuntu):
status: New → Confirmed
Changed in software-properties (Ubuntu):
importance: Undecided → High
tags: added: vivid
Brian Murray (brian-murray) wrote :

Do you have the multiverse repository enabled? That is where the virtualbox-guest-x11 package is located.

Changed in software-properties (Ubuntu):
status: Confirmed → Incomplete
Martin Wimpress (flexiondotorg) wrote :

Yes, the multiverse enabled.

I've just installed the Ubuntu MATE daily in a clean VM and confirm that multiverse is enabled by default.

Changed in software-properties (Ubuntu):
status: Incomplete → Confirmed
Adam Conrad (adconrad) wrote :

This isn't a bug in software-properties. What I can't decide is if it's a bug in virtualbox-guest* or ubuntu-drivers-common. Basically, here's what's happening:

1) The virtualbox-guest* packages have a modalias for the "guest services", but not the VGA controller.
2) We pulled the DKMS drivers into the kernel.
3) The above situation confuses ubuntu-drivers-common, which really wants to install vbox-dkms, but we have it builtin.
4) Nothing wants to install vbox-x11, which we actually want.

So, the lack of modaliases on vbox-x11 is definitely a vbox bug, and the dependencies are also a bit strong between vbox packages (we should drop some recommends to suggests, to stop trying to forcefully install compilers to get an X driver).

That said, we might also want to quirk the ubuntu-drivers-common detection a bit to either hide vbox-dkms altogether, or actually let us use it if it's a potential upgrade. Currently, neither of these options is in play, and we see it, but it's greyed out, which is amazingly confusing.

affects: software-properties (Ubuntu) → ubuntu-drivers-common (Ubuntu)
Changed in ubuntu-drivers-common (Ubuntu):
status: Confirmed → Incomplete
Changed in virtualbox (Ubuntu):
importance: Undecided → High
Changed in ubuntu-drivers-common (Ubuntu):
status: Incomplete → Confirmed
Changed in virtualbox (Ubuntu):
status: New → Confirmed

Hi Adam, I'm the virtualbox maintainer, thanks for the useful report, can you please share a patch too?

I'll be happy to review and apply it also in debian if needed (I would like to avoid maintaining two different packages if possible)

thanks

Andy Whitcroft (apw) on 2015-04-02
Changed in linux (Ubuntu):
status: New → In Progress
importance: Undecided → High
assignee: nobody → Andy Whitcroft (apw)
Adam Conrad (adconrad) on 2015-04-02
Changed in linux (Ubuntu):
status: In Progress → Confirmed
Andy Whitcroft (apw) on 2015-04-02
Changed in linux (Ubuntu):
milestone: none → ubuntu-15.04
Adam Conrad (adconrad) wrote :

We're also going to add a "Provides: virtualbox-guest-modules" to both linux-image and virtualbox-guest-dkms, so that x11/utils can depend on that, and only force dkms installation if the driver isn't builtin.

Andy Whitcroft (apw) on 2015-04-03
Changed in linux (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (6.8 KiB)

This bug was fixed in the package linux - 3.19.0-12.12

---------------
linux (3.19.0-12.12) vivid; urgency=low

  [ Andy Whitcroft ]

  * [Packaging] do_common_tools should always be on
  * [Packaging] Provides: virtualbox-guest-modules when appropriate
    - LP: #1434579

  [ Chris J Arges ]

  * Revert "SAUCE: ext4: disable ext4_punch_hole for indirect filesystems"
    - LP: #1292234

  [ Leann Ogasawara ]

  * Release Tracking Bug
    - LP: #1439803

  [ Timo Aaltonen ]

  * SAUCE: i915_bpo: Provide a backport driver for Skylake & Cherryview
    graphics
    - LP: #1420774
  * SAUCE: i915_bpo: Update intel_ips.h file location
    - LP: #1420774
  * SAUCE: i915_bpo: Only support Skylake and Cherryview with the backport
    driver
    - LP: #1420774
  * SAUCE: i915_bpo: Rename the backport driver to i915_bpo
    - LP: #1420774
  * i915_bpo: [Config] Enable CONFIG_DRM_I915_BPO=m
    - LP: #1420774
  * SAUCE: i915_bpo: Add i915_bpo_*() calls for ubuntu/i915
    - LP: #1420774
  * SAUCE: i915_bpo: Revert "drm/i915: remove unused
    power_well/get_cdclk_freq api"
    - LP: #1420774
  * SAUCE: i915_bpo: Add i915_bpo specific power well calls
    - LP: #1420774
  * SAUCE: Backport I915_PARAM_MMAP_VERSION and I915_MMAP_WC
    - LP: #1420774
  * SAUCE: Partial backport of drm/i915: Add ioctl to set per-context
    parameters
    - LP: #1420774
  * SAUCE: drm/i915: Specify bsd rings through exec flag
    - LP: #1420774
  * SAUCE: drm/i915: add I915_PARAM_HAS_BSD2 to i915_getparam
    - LP: #1420774
  * SAUCE: drm/i915: add component support
    - LP: #1420774
  * SAUCE: drm/i915: Add tiled framebuffer modifiers
    - LP: #1420774
  * SAUCE: Backport new displayable tiling formats
    - LP: #1420774
  * SAUCE: Backport drm_crtc_vblank_reset() helper
    - LP: #1420774
  * SAUCE: drm/i915: Add I915_PARAM_REVISION
    - LP: #1420774
  * SAUCE: drm/i915: Export total subslice and EU counts
    - LP: #1420774
  * SAUCE: i915_bpo: Revert drm/mm: Support 4 GiB and larger ranges
    - LP: #1420774

  [ Upstream Kernel Changes ]

  * drm/i915/skl: Split the SKL PCI ids by GT
    - LP: #1420774
  * drm: Reorganize probed mode validation
    - LP: #1420774
  * drm: Perform basic sanity checks on probed modes
    - LP: #1420774
  * drm: Do basic sanity checks for user modes
    - LP: #1420774
  * drm/atomic-helper: Export both plane and modeset check helpers
    - LP: #1420774
  * drm/atomic-helper: Again check modeset *before* plane states
    - LP: #1420774
  * drm/atomic: Introduce state->obj backpointers
    - LP: #1420774
  * drm: allow property validation for refcnted props
    - LP: #1420774
  * drm: store property instead of id in obj attachment
    - LP: #1420774
  * drm: get rid of direct property value access
    - LP: #1420774
  * drm: add atomic_set_property wrappers
    - LP: #1420774
  * drm: tweak getconnector locking
    - LP: #1420774
  * drm: add atomic_get_property
    - LP: #1420774
  * drm: Remove unneeded braces for single statement blocks
    - LP: #1420774
  * drm: refactor getproperties/getconnector
    - LP: #1420774
  * drm: add atomic properties
    - LP: #1420774
  * drm/atomic: atomic_check functions
    - LP: #1420774
  * drm: s...

Read more...

Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
tags: added: rls-v-incoming
Adam Conrad (adconrad) on 2015-04-22
Changed in virtualbox (Ubuntu):
assignee: nobody → Adam Conrad (adconrad)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package virtualbox - 4.3.26-dfsg-2ubuntu1

---------------
virtualbox (4.3.26-dfsg-2ubuntu1) vivid; urgency=medium

  * Re-work the packaging to account for the kernel modules being shipped in
    the master kernel packages, removing the need for dkms (LP: #1434579):
    - Make the dkms package provide a virtual package matching what the
      kernel packages provide to indicate that they ship the dkms modules.
    - Add an alternate dep from the utils package to the virtual driver.
    - Make the x11 driver package associate with the VGA controller PCI ID.
 -- Adam Conrad <email address hidden> Wed, 22 Apr 2015 10:01:25 +0100

Changed in virtualbox (Ubuntu):
status: Confirmed → Fix Released
Brad Figg (brad-figg) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-wily' to 'verification-done-wily'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-wily
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers