nvidia-detector error breaks Nvidia drivers install on Quantal, Precise

Bug #1070795 reported by Louis Bouchard on 2012-10-24
268
This bug affects 33 people
Affects Status Importance Assigned to Milestone
nvidia-common (Ubuntu)
Undecided
Alberto Milone
Nominated for Precise by Timo Jyrinki
Quantal
Undecided
Unassigned
ubuntu-drivers-common (Ubuntu)
High
Alberto Milone
Nominated for Precise by Timo Jyrinki
Quantal
Undecided
Unassigned

Bug Description

[Impact]
Causes the Hardware Drivers dialog to lockup and be unusable for all users on quantal due to it being unable to parse the driver names for experimental drivers.

precise: a similar error in nvidia-common, as indicated via errors.ubuntu.com although it claims jockey as culprit?

[Fix]
Make the code skip over experimental drivers for considering which kernel drivers to list. These drivers are then listed with the X drivers instead.

[Test Case]
1. On quantal enable -proposed so that all experimental nvidia drivers become visible
2. apt-get update
3. Run jockey (the Additional Hardware Drivers dialog)

Expected behavior: Jockey lists experimental drivers
Actual behavior: Jockey locks up

[Regression Potential]
None really, it's just a one line change to exclude some strings.

Validation testing should be fairly simple on a quantal system with NVIDIA graphics. Reproduce the original flaw, then install the package from -proposed and verify behavior is fixed. A single validation report should be sufficient to prove this safe; there's not really any chance this could cause larger misbehaviors beyond the bug in question.

[Original Report]
After installing the proprietary Nvidia drivers through "Software Source" tab and rebooting, the GUI becomes totally unusable (no Dash, no top bar with indicators, unable to start applications).

When dropping to a virtual console and running 'nvidia-detector', I got the following stack trace :

Traceback (most recent call last):
  File "/usr/bin/nvidia-detector", line 8, in <module>
    a = NvidiaDetection(printonly=True, verbose=False)
  File "/usr/lib/python3/dist-packages/NvidiaDetector/nvidiadetector.py", line 68, in __init__
    self.getData()
  File "/usr/lib/python3/dist-packages/NvidiaDetector/nvidiadetector.py", line 149, in getData
    driver_version = self.__get_value_from_name(stripped_package_name)
  File "/usr/lib/python3/dist-packages/NvidiaDetector/nvidiadetector.py", line 87, in __get_value_from_name
    v = int(name)
ValueError: invalid literal for int() with base 10: 'experimental-304'

Trying again after installing jockey-common, here is the list of available drivers :

kmod:nvidia_experimental_304 - Experimental NVIDIA binary Xorg driver, kernel module and VDPAU library (Proprietary, Disabled, Not in use)
kmod:nvidia_current - NVIDIA binary Xorg driver, kernel module and VDPAU library (Proprietary, Disabled, Not in use)
kmod:nvidia_current_updates - NVIDIA binary Xorg driver, kernel module and VDPAU library (Proprietary, Disabled, Not in use)

I was unable to enable any of those using jockey-text -e

Removing the nvidia-current and nvidia-experimental-304 fixed the problem by re-enabling the nouveau driver.

no longer affects: nvidia-common (Ubuntu)
Alberto Milone (albertomilone) wrote :

SRU request:

Please accept ubuntu-drivers-common_0.2.71.1 in quantal-proposed. It only introduces a one-line change which is already available in nvidia-common in precise in the same file.

Changed in ubuntu-drivers-common (Ubuntu):
status: New → Fix Committed
importance: Undecided → High
assignee: nobody → Alberto Milone (albertomilone)
milestone: none → quantal-updates
Louis Bouchard (louis) wrote :

Any chance of having this accepted in -proposed soon ? this bug makes installing the Nvidia proprietary drivers impossible and I'm stucked with a Compiz process eating ~40% of my CPU since it has no access to hardware acceleration

Alberto Milone (albertomilone) wrote :

in the meantime you can find the git branch here: https://github.com/tseliot/ubuntu-drivers-common

Bryce Harrington (bryce) on 2012-10-31
description: updated

Hello Louis, or anyone else affected,

Accepted ubuntu-drivers-common into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/ubuntu-drivers-common/1:0.2.71.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed

Hello, I'm on the Steam for Linux team. We need this fix in precise-main. I notice it is fixed in precise-proposed. Is it possible to promote the fix to precise-main really soon? Thanks.

Louis Bouchard (louis) wrote :

@scott

woudln't it be quantal- instead of precise- ? ubuntu-drivers-common is _not_ in precise afaik

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-drivers-common - 1:0.2.72

---------------
ubuntu-drivers-common (1:0.2.72) raring; urgency=low

  [ Matthias Klose ]
  * Build-depend on python3-all.

  [ Dmitrijs Ledkovs ]
  * Use /usr/bin/python3 shebang.

  [ Martin Pitt ]
  * debian/tests/system: Fix duplicate output of error message for test
    failures.
  * tests/ubuntu_drivers.py, test_devices_detect_plugins(): Fix failure if
    special.py occurs first in the output. This bug was triggered by Python
    3.3's new hash randomization behaviour. (LP: #1071997)
  * UbuntuDrivers/detect.py: Fix UnicodeDecodeError crash when encountering a
    package with invalid UTF-8 encoding. Just skip those packages instead. Add
    test to tests/ubuntu_drivers.py.
 -- Martin Pitt <email address hidden> Wed, 07 Nov 2012 15:47:19 +0100

Changed in ubuntu-drivers-common (Ubuntu):
status: Fix Committed → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

This bug was fixed in the package ubuntu-drivers-common - 1:0.2.71.1

---------------
ubuntu-drivers-common (1:0.2.71.1) quantal-proposed; urgency=low

  * NvidiaDetector/nvidiadetector.py:
    - Make sure to never recommend experimental drivers (LP: #1070795).
 -- Alberto Milone <email address hidden> Wed, 24 Oct 2012 16:42:19 +0200

Changed in ubuntu-drivers-common (Ubuntu Quantal):
status: New → Fix Released
Timo Jyrinki (timo-jyrinki) wrote :

A duplicate of this bug - bug #828196 - shows as affecting 12.04 as well and being the #2 crasher at errors.ubuntu.com.

Timo Jyrinki (timo-jyrinki) wrote :

It's against jockey itself though, and as said ubuntu-drivers-common doesn't exist in precise so it probably needs unduplicating from this one?

summary: - nvidia-detector error breaks Nvidia drivers install on Quantal
+ nvidia-detector error breaks Nvidia drivers install on Quantal, Precise
Changed in nvidia-common (Ubuntu Quantal):
status: New → Invalid
description: updated
Timo Jyrinki (timo-jyrinki) wrote :

This is probably to be fixed in tandem with bug #1054458 regarding precise, in nvidia-common that was the predecessor to ubuntu-drivers-common.

Alberto Milone (albertomilone) wrote :

This was fixed in precise in nvidia-common in version 1:0.2.44.2. If you can still reproduce it with this package, feel free to reopen this bug report.

Changed in nvidia-common (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)
status: New → Fix Released
To post a comment you must log in.