ubuntu-drivers-common ftbfs in quantal

Bug #1061748 reported by Matthias Klose on 2012-10-04
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-drivers-common (Ubuntu)
High
Martin Pitt
Quantal
High
Martin Pitt

Bug Description

[re-filing the issue, because of the original issue is a conjoined master with mismatched state]

see bug #1058056

see http://people.ubuntuwire.org/~wgrant/rebuild-ftbfs-test/test-rebuild-20120922-quantal.html

======================================================================
ERROR: test_hardware_driver (ubuntu_drivers.PackageKitTest)
what-provides HARDWARE_DRIVER
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/build/buildd/ubuntu-drivers-common-0.2.69/tests/ubuntu_drivers.py", line 238, in test_hardware_driver
    ['drivers_for_attached_hardware']),
  File "/build/buildd/ubuntu-drivers-common-0.2.69/tests/ubuntu_drivers.py", line 279, in _call
    None, lambda p, t, d: True, None)
  File "/usr/lib/python3/dist-packages/gi/types.py", line 47, in function
    return info.invoke(*args, **kwargs)
gi._glib.GError: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.PackageKit was not provided by any .service files

----------------------------------------------------------------------
Ran 36 tests in 541.765s

FAILED (errors=1)
make[1]: *** [override_dh_auto_test] Error 1
make[1]: Leaving directory `/build/buildd/ubuntu-drivers-common-0.2.69'
make: *** [build-arch] Error 2
dpkg-buildpackage: error: debian/rules build-arch gave error exit status 2

pitti:
This is due to the utterly slow and swap-to-death arm builders. Just retry the build, it'll work after a few attempts. I really don't want to disable this test, as it's working fine everywhere else and I want to know whether functionality works on arm platforms as well.

doko:
re-opening. closing as won't fix won't help anything for the release, until the package can be built.

now retried some times, and it always fails in the same place.

Matthias Klose (doko) on 2012-10-04
Changed in ubuntu-drivers-common (Ubuntu Quantal):
importance: Undecided → High
Martin Pitt (pitti) on 2012-10-05
Changed in ubuntu-drivers-common (Ubuntu Quantal):
status: Confirmed → In Progress
assignee: nobody → Martin Pitt (pitti)
Martin Pitt (pitti) wrote :

I can reproduce this when adding a "sleep 1" to /usr/bin/aptd's main, to simulate the arm builder slowness.

Martin Pitt (pitti) wrote :

I uploaded 0.2.71 to quantal's unapproved which will fix this.

Changed in ubuntu-drivers-common (Ubuntu Quantal):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-drivers-common - 1:0.2.71

---------------
ubuntu-drivers-common (1:0.2.71) quantal; urgency=low

  * tests/ubuntu_drivers.py: When calling PackageKit, retry up to 5 seconds on
    o.f.d.Error.ServiceUnknown, so that this also works reliably on our slow
    ARM builders. (LP: #1061748)
 -- Martin Pitt <email address hidden> Fri, 05 Oct 2012 08:25:30 +0200

Changed in ubuntu-drivers-common (Ubuntu Quantal):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers