Download of click package update does not start.

Bug #1425861 reported by Jean-Baptiste Lallement on 2015-02-26
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Canonical System Image
Undecided
Canonical Phone Foundations
ubuntu-download-manager (Ubuntu)
Undecided
Canonical Phone Foundations

Bug Description

current build number: 122
device name: krillin
channel: ubuntu-touch/devel-proposed
alias: ubuntu-touch/vivid-proposed
last update: 2015-02-25 15:06:29
version version: 122
version ubuntu: 20150225
version device: 20150210-95b6a9f
version custom: 20150225

On vivid-proposed/krillin I downgraded the camera to 3.0.0.484 to test an upgrade of a click package.
In system-settings/updates there was a new image and several updates for various click packages available. The image downloaded successsfully but I didn't install, I selected to only update the camera-app but the download never started. I tried pause/resume several times with no luck.

ProblemType: Bug
DistroRelease: Ubuntu 15.04
Package: ubuntu-download-manager 0.9+15.04.20150203-0ubuntu1
Uname: Linux 3.4.67 armv7l
ApportVersion: 2.16.1-0ubuntu2
Architecture: armhf
Date: Thu Feb 26 10:09:56 2015
InstallationDate: Installed on 2015-02-25 (1 days ago)
InstallationMedia: Ubuntu Vivid Vervet (development branch) - armhf (20150225-020204)
SourcePackage: ubuntu-download-manager
UpgradeStatus: No upgrade log present (probably fresh install)

Jean-Baptiste Lallement (jibel) wrote :
Jean-Baptiste Lallement (jibel) wrote :

output of ~/.cache/upstart/application-legacy-ubuntu-system-settings-.log after a start/pause/resume cycle

2015-02-26 10:02:06,530 - WARNING - START: com.ubuntu.camera
2015-02-26 10:03:26,895 - WARNING - QObject::startTimer: Timers cannot be started from another thread
2015-02-26 10:04:47,175 - WARNING - UbuntuClipboard - Got invalid serialized mime data. Ignoring it.
2015-02-26 10:05:57,094 - WARNING - PAUSE: com.ubuntu.camera
2015-02-26 10:06:30,597 - WARNING - RESUME: com.ubuntu.camera
2015-02-26 10:07:30,932 - WARNING - QObject::killTimer: Timers cannot be stopped from another thread
2015-02-26 10:07:30,932 - WARNING - QObject::startTimer: Timers cannot be started from another thread
2015-02-26 10:09:38,133 - WARNING - UbuntuClipboard - Got invalid serialized mime data. Ignoring it.
2015-02-26 10:11:37,238 - WARNING - QObject::killTimer: Timers cannot be stopped from another thread
2015-02-26 10:11:37,239 - WARNING - QObject::startTimer: Timers cannot be started from another thread

Jean-Baptiste Lallement (jibel) wrote :

u-d-l log

Jean-Baptiste Lallement (jibel) wrote :

After a reboot it worked fine.

summary: - Download of click package update do not start.
+ Download of click package update does not start.
Pat McGowan (pat-mcgowan) wrote :

Is this bug still active?

Changed in ubuntu-download-manager (Ubuntu):
assignee: nobody → Canonical Phone Foundations (canonical-phonedations-team)
Jean-Baptiste Lallement (jibel) wrote :

It happens randomly and not really frequently. I don't know if it's due to transient network issues or something else. Setting to incomplete until I find how to reproduce it.

Changed in ubuntu-download-manager (Ubuntu):
status: New → Incomplete
Changed in canonical-devices-system-image:
assignee: nobody → Canonical Phone Foundations (canonical-phonedations-team)
milestone: none → ww13-2015
status: New → Incomplete
femke98 (femke98) wrote :

I have the same here, see https://bugs.launchpad.net/canonical-devices-system-image/+bug/1446232

but i do not understand where i can see the things were they talk about here.
I am a normal user and so i reboot serveral times, but non off the 6 programs wil update.

Jean-Baptiste Lallement (jibel) wrote :

I'm closing this report. I didn't happen on recent images.

Changed in canonical-devices-system-image:
status: Incomplete → Fix Released
Changed in ubuntu-download-manager (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers