Missing links

Bug #987788 reported by Gunnar Hjalmarsson on 2012-04-24
20
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ubuntu-docs (Ubuntu)
Low
Gunnar Hjalmarsson
Precise
Low
Gunnar Hjalmarsson

Bug Description

[Impact]
As regards why I propose an SRU of 12.04, please note that it's a regression bug in the first place. The link to the guest session tutorial is there in 11.04 and 11.10, then it was removed for some to me unknown reason in 12.04 and now I propose it to be reinserted in 12.10. In the absence of built-in customization possibilities in both gdm-guest-session and lightdm, the tutorial has proved to be - and still is - useful, and it makes no sense to not link to it from the LTS docs.

[Development Fix]
See the lp:ubuntu-docs MP.

[Stable Fix]
See the lp:ubuntu/precise-proposed/ubuntu-docs MP.

[Test Case]
Not applicable, is it?

[Regression Potential]
Zero, since it's just a docs change.

[Original Report]
The Language Support tool and the Guest Session feature are two areas where ubuntu-docs should point the users to app specific docs. More specifically I'm thinking of "Language Support Help" and the tutorial on customizing guest sessions at ubuntuforums.org.

Given that 12.04 is about to be released, the proposed changes are for both the Q development circle and for SRUing Precise. They are pure docs changes, with no regression potential as regards functionality.

Changed in ubuntu-docs (Ubuntu):
assignee: nobody → Gunnar Hjalmarsson (gunnarhj)
status: New → In Progress

Hello Gunnar, or anyone else affected,

Accepted ubuntu-docs into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in ubuntu-docs (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Jeremy Bicha (jbicha) on 2012-05-09
Changed in ubuntu-docs (Ubuntu):
status: In Progress → Fix Released
Bryce Harrington (bryce) on 2012-05-17
description: updated
Sebastien Bacher (seb128) wrote :

The linked merge request didn't seems like it made it in this upload?

Changed in ubuntu-docs (Ubuntu Precise):
importance: Undecided → Low
Changed in ubuntu-docs (Ubuntu):
importance: Undecided → Low
tags: added: verification-failed
removed: verification-needed
Jeremy Bicha (jbicha) wrote :

Seb, I couldn't directly merge the proposal as it's filed against a branch I don't have commit rights to (ubuntu-docs isn't in the ubuntu-desktop set).

Also, he merge proposal contained two parts: tweaks to the guest session page and restoring the link to Language Support help. The Language Support link can be verified by looking for the yellow note at the bottom of the page when opening

yelp help:ubuntu-help/session-language
yelp help:ubuntu-help/session-formats

I didn't think the guest session changes were worth breaking translations for, and I requested that a separate merge proposal/bug be used for that proposal.

Sebastien Bacher (seb128) wrote :

@Jeremy: thanks for the details, it's a bit confusing that the changelog lists that bug if the issue are only partially adressed, it's better to not list the bug in those cases (or made clear in the changelog that only part of the bug is supposed to be fixed).

Do you have the bug number for the guest session changes? When we have one we can retitle that bug to be about the language support link and mark it verification-done and move the guest session changes to the other ticket

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-docs - 12.04.5

---------------
ubuntu-docs (12.04.5) precise-proposed; urgency=low

  [ Gunnar Hjalmarsson ]
  * session-language.page and session-formats.page:
    - Reinsert links to "Language Support Help" (LP: #987788)

  [ James Plate ]
  * Fix broken links to non-existant shell terminology page (LP: #981745)
  * Remove the extra > from the addremove pages (LP: #977260)
  * shell-windows-maximizing.page:
    - Use the correct Ctrl+Super+Up/Down keyboard shortcut (LP: #975890)
  * shell-windows-switching.page:
    - Alt+Tab by default shows app icons, not window previews (LP: #975899)

  [ Jeremy Bicha ]
  * Removed note about dragging screenshots to other apps since this doesn't
    work as described (LP: #978793)
  * Use "Ubuntu 12.04 LTS" name instead of "Ubuntu 12.04" (LP: #987385)
  * shell-windows-tiled.page:
    - Update keyboard shortcut and comment out invalid tips about how to
      restore the window's original size (LP: #975825, LP: #975813)
  * unity-appmenu-intro.page: Mention Rhythmbox not Banshee (LP: #968153)
  * debian/control: Update Vcs-Bzr link to point to precise branch

  [ Matthew East ]
  * Update translations from Launchpad 7.5.12
 -- Matthew East <email address hidden> Mon, 07 May 2012 18:48:47 +0100

Changed in ubuntu-docs (Ubuntu Precise):
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Reopening as this bug was not actually fixed in this SRU.

Changed in ubuntu-docs (Ubuntu):
status: Fix Released → Triaged
Changed in ubuntu-docs (Ubuntu Precise):
status: Fix Released → Triaged
tags: removed: verification-failed
Changed in ubuntu-docs (Ubuntu):
status: Triaged → In Progress
Changed in ubuntu-docs (Ubuntu Precise):
status: Triaged → In Progress
Gunnar Hjalmarsson (gunnarhj) wrote :

Since the originally proposed changes of the guest session page were never uploaded, I have made two new MPs, one for quantal and one for precise-proposed, which - if approved and uploaded - will complete the fix of this bug.

Gunnar Hjalmarsson (gunnarhj) wrote :

The target branch of the quantal MP changed from lp:ubuntu/ubuntu-docs to lp:ubuntu-docs, as requested by Jeremy.

Bryce Harrington (bryce) wrote :

Hi Gunnar, thanks for this work. Could you update the SRU fields in the description with the required info?

In particular, documentation changes are often not good candidates for SRU so it would help to explain in more detail why this change would solve problems in 12.04.

Changed in ubuntu-docs (Ubuntu Precise):
status: In Progress → Incomplete
Gunnar Hjalmarsson (gunnarhj) wrote :

Bryce,
I updated the bug description as requested. Let me know if there is anything else I can do to facilitate the processing of the above MPs.

description: updated
Changed in ubuntu-docs (Ubuntu Precise):
status: Incomplete → In Progress
Jeremy Bicha (jbicha) on 2012-09-17
Changed in ubuntu-docs (Ubuntu Precise):
status: In Progress → Won't Fix
Jeremy Bicha (jbicha) wrote :

Gunnar,

Thank you for contributing to Ubuntu and helping to make our documentation better!

Unfortunately, the bar for fixing documentation in SRU's is very high as even fixing a typo can invalidate all the translations for the paragraph. This means that even though the translations may have been 100% complete before, users now would see an English paragraph in the docs. I don't believe this fix is important enough for all of the headache and work required.

For Quantal, I'll go ahead and merge the first half of your proposal. I'm reluctant to add a link to the forums. We don't have any links to the forums yet in ubuntu-docs and the scope of that forum article is at quite a bit more in-depth level than our target audience.

Gunnar Hjalmarsson (gunnarhj) wrote :

On 2012-09-17 21:52, Jeremy Bicha wrote:
> For Quantal, I'll go ahead and merge the first half of your proposal.
> I'm reluctant to add a link to the forums. We don't have any links to
> the forums yet in ubuntu-docs and the scope of that forum article is at
> quite a bit more in-depth level than our target audience.

For what it's worth, I keep being of the opinion that the guest session page in ubuntu-docs is more useful with the link than it is without it. The link is not new; we did have that particular link to the tutorial in the 11.04 and 11.10 versions of ubuntu-docs, so what I suggest is that it's simply re-added.

I think it's reasonable to assume that users beyond the target audience make use of the docs. Looking up the guest session page in the docs is a natural step if you are about to use the guest session feature irrespective of your computering/Ubuntu experience.

I ask you to please reconsider the link. Btw, personally I would like to see more links from ubuntu-docs to good community resources.

Jeremy Bicha (jbicha) on 2012-09-25
Changed in ubuntu-docs (Ubuntu):
status: In Progress → Fix Committed
Iain Lane (laney) wrote :

Unsubscribing sponsors; this is queued for the next usual upload

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-docs - 12.10.3

---------------
ubuntu-docs (12.10.3) quantal; urgency=low

  [ James Plate ]
  * Use "Super" key instead of "Windows" key on shell-window-switching.page
    (LP: #993770)

  [ Jeremy Bicha ]
  * Re-merge with gnome-user-docs
  * Add "What's new in Ubuntu 12.10?"
  * Rewrite the Unity docs, including adding pages for each of the
    default lenses
  * "Tap" instead of "type" Alt to close HUD (LP: #992683)
  * Fix instructions for changing Compose key setting (LP: #884639)
  * Provide keyboard-only instructions for turning on Mouse Keys
    (LP: #1030767)
  * Fix typos in lens pages (LP: #1058565)
  * Fix spelling of 'hierarchies' (LP: #1058658)
  * Change "Super+P" shortcut to "Super+C" (LP: #1049090)

  [ Gunnar Hjalmarsson ]
  * shell-guest-session.page:
    - Mentioning of the possibility to launch a guest session from the
      login screen
    - Link to the tutorial "Customize Guest Session" reinserted (It was
      silently removed in revision 104 of lp:ubuntu/precise/ubuntu-docs.)
      (LP: #987788)
 -- Jeremy Bicha <email address hidden> Tue, 09 Oct 2012 00:17:51 -0400

Changed in ubuntu-docs (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers