Doc page on mouse keys makes a misleading point about right-clicking

Bug #964727 reported by David Black
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ubuntu-docs (Ubuntu)
Fix Released
Low
Chris Perry

Bug Description

https://help.ubuntu.com/13.04/ubuntu-help/mouse-mousekeys.html

While it is true that "most keyboards have a special key which allows you to right-click" this is not part of mouse keys. The reader could be mislead into thinking it is impossible to do a normal right-mouse-click with mouse-keys. The procedure for doing a right click with mouse keys involves pressing a modifier key before pressing the mouse-click key. Usually this will be / for left mouse-click, * for middle mouse-click and - for right mouse-click.

Tags: doc

Related branches

John Kim (kotux)
summary: - The wiki page on mouse keys makes a misleading point about right-
- clicking
+ Doc page on mouse keys makes a misleading point about right-clicking
tags: added: doc
description: updated
John Kim (kotux)
description: updated
Revision history for this message
John Kim (kotux) wrote :

I've been testing this on my laptop, and although / somewhat works, * and - doesn't actually.

Revision history for this message
John Kim (kotux) wrote :

Not necessarily misleading, but certainly ambiguous: it doesn't reveal other options.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-docs (Ubuntu):
status: New → Confirmed
Changed in ubuntu-docs (Ubuntu):
importance: Undecided → Low
assignee: nobody → Chris Perry (clissold345)
status: Confirmed → In Progress
Revision history for this message
Chris Perry (clissold345) wrote :

I've revised the page. Mouse keys seems to be partly documented in various places on the internet but I couldn't find a full description anywhere. My main source was the wikipedia mouse keys page (link below). I've copied this page in using the terminology "mouse keys" - though perhaps it should be "Mouse Keys".

In my opinion the page (that is, mouse-mousekeys.html) is mainly about using mouse keys where the keyboard has a "real" numeric keypad. As the page mentions, I know that some laptop keyboards can simulate a numeric keypad.

I haven't checked the details of text that I haven't changed - though I did make a small correction to step 4 of the procedure.

https://en.wikipedia.org/wiki/Mouse_keys

Changed in ubuntu-docs (Ubuntu):
status: In Progress → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-docs - 17.04.1

---------------
ubuntu-docs (17.04.1) zesty; urgency=medium

  * scripts/validate.sh:
    - Modified so it can be called via a symlink from 'ubuntu-help/C'
      or 'html'.
  * power-hibernate.page:
    - Changed command due to upstart->systemd transition.
  * Bump version to 17.04 / zesty.
  * html/ubuntu.xsl:
    - Make unordered lists bulleted and not numbered (LP: #1649554).
  * keyboard-layouts.page:
    - Note about how to show rarely used xkb layout variants.
  * Updated ubuntu-help.pot.
  * debian/compat, debian/control:
    - Bump to debhelper version 9

  [ Chris Perry ]
  * tips-specialchars.page:
    - Section "Compose key" updated (LP: #1624778).
  * addremove-ppa.page:
    - Revise PPA description (LP: #1628706).
  * keyboard-layouts.page:
    - Move text of marginal note.
  * mouse-middleclick.page, mouse-touchpad-click.page:
    - Revise description of middle-click from touchpad (LP: #1617718).
  * power-lowpower.page:
    - Update since related control in "System Settings -> Power" has
      been removed (LP: #1599264, LP: #1641786).
  * accounts-add.page, net-firewall-on-off.page:
    - Minor clarifications.
  * net-wireless-*.page, net-problem.page:
    - GUI conformity modifications (LP: #1637126)
    - New shared section (LP: #977251)
  * addremove-install.page, addremove-remove.page:
    - Clearer description of Ubuntu Software's focus on applications
      (LP: #1637861).
    - Mentioning of snaps (LP: #1658785).
  * printing-setup.page:
    - Section about network printer added (LP: #1630272).
  * mouse-mousekeys.page:
    - Improved description of mouse keys (LP: #964727).
  * disk-*.page:
    - GUI conformity modifications (LP: #1651360).
  * List type explicitly stated on multiple pages.
  * addremove-creator.page:
    - New page describing Startup Disk Creator (LP: #1569532).
  * security-settings.page:
    - New page describing the Security & Privacy panel in System
      Settings (LP: #1200381).

  [ Doug Smythies ]
  * scripts/validate.sh:
    - Changed to --strict validation.
  * ubuntu-help/C/legal.xml:
    - Specify https to avoid a "permanently moved" redirection.

 -- Gunnar Hjalmarsson <email address hidden> Mon, 20 Feb 2017 15:11:00 +0100

Changed in ubuntu-docs (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers