Ubuntu

multimonitor, launcher: Provide an option to display either a single launcher or a launcher on each display in a multi-monitor environment

Reported by Stewart Wilson on 2012-03-08
86
This bug affects 29 people
Affects Status Importance Assigned to Milestone
Ayatana Design
High
Stewart Wilson
Ubuntu Translations
Undecided
Unassigned
Unity
High
Jason Smith
unity-2d
High
Albert Astals Cid
gnome-control-center (Ubuntu)
Undecided
Didier Roche
ubuntu-docs (Ubuntu)
Undecided
Unassigned
unity-2d (Ubuntu)
High
Unassigned
unity (Ubuntu)
High
Unassigned

Bug Description

Provide an option to display either a single launcher or a launcher on each display in a multi-monitor environment.

Add the option 'Launcher placement' to the Displays panel.
A drop-down list provides the following options:
Display name 1
Display name 2
...
All displays

By default, the primary display will be selected, to display just a single Launcher on the primary display.

A fallback solution is proposed where proprietary drivers report a single display in the Displays panel (where multiple displays are connected). The drop-down list options revert to:
Primary display
All displays

Please see addendum to System Settings specification: https://docs.google.com/a/canonical.com/document/d/1b3CwE3Wemr347fTxNcu7ixEQBK4YD8JF2pyv5pxiY0U/edit

This addendum also provides a solution proposal for bug 946104: 'multimonitor: Please give me a way to turn off sticky monitor edges': https://bugs.launchpad.net/ayatana-design/+bug/946104

Gerry Boland (gerboland) on 2012-03-08
Changed in unity-2d:
status: New → Confirmed
importance: Undecided → High
importance: High → Medium
milestone: none → 5.8
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Changed in unity-2d (Ubuntu):
status: New → Confirmed
John Lea (johnlea) on 2012-03-09
Changed in unity:
status: New → Confirmed
milestone: none → backlog
importance: Undecided → High
Omer Akram (om26er) on 2012-03-09
Changed in unity-2d (Ubuntu):
importance: Undecided → High
Changed in unity-2d:
importance: Medium → High
Changed in unity (Ubuntu):
importance: Undecided → High
Omer Akram (om26er) on 2012-03-13
Changed in unity:
milestone: backlog → 5.8.0
status: Confirmed → Fix Committed
assignee: nobody → Jason Smith (jassmith)
Gerry Boland (gerboland) on 2012-03-13
Changed in unity-2d:
assignee: nobody → Albert Astals Cid (aacid)
status: Confirmed → In Progress
Martin Pitt (pitti) wrote :

I remember that there recently was a similar UIFE for unity 3D, so this seems ok.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-control-center (Ubuntu):
status: New → Confirmed
Gerry Boland (gerboland) on 2012-03-15
Changed in unity-2d:
milestone: 5.8 → 5.7
Gerry Boland (gerboland) on 2012-03-15
Changed in unity-2d:
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2012-03-19
Changed in unity:
status: Fix Committed → Fix Released
Changed in unity-2d:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-2d - 5.7.0-0ubuntu1

---------------
unity-2d (5.7.0-0ubuntu1) precise; urgency=low

  * New upstream release:
    - unity-2d-panel crashed with SIGABRT in Unity2dDebug::unity2dQtHandler()
      (LP: #925457)
    - unity-2d-shell crashed with SIGSEGV in ref() (LP: #947278)
    - Launcher - Make Launcher left of screen reveal more responsive and less
      prone to false positives (LP: #765819)
    - [dash] [launcher] [panel] Tinting based on wallpaper missing
      (LP: #882101)
    - [launcher] In multimonitor setup Unity-2D only shows launcher on one
      monitor (fails MM UX spec #2.8) (LP: #780204)
    - [unity-2d] FF exception to add PointerBarrier to Unity2d (LP: #947976)
    - multimonitor, launcher: Provide an option to display either a single
      launcher or a launcher on each display in a multi-monitor environment
      (LP: #950136)
    - lens switching is not keyboard navigable (LP: #945220)
    - [panel] [multi-monitor] On secondary screen, unable to scrub from
      indicator menu to app menu (LP: #844809)
    - "Workspaces" button displays previous wallpaper (LP: #900019)
    - Dash - cursor should change when pointer is over the search field
      (LP: #849175)
    - Filter checkboxes are without margins in right to left locales
      (LP: #949319)
    - [panel] [multi-monitor] Open indicator menu on one screen causes other
      indicator to look open too (LP: #844798)
    - Dash - horizental divider line in between categories incorrectly drawn
      (LP: #841750)
    - [launcher] Tile Progress bar starting from left of launcher, not
      container (LP: #912777)
    - Dash - dash is not closed with alt+f4 (LP: #891818)
    - [dash] Rating stars in right-to-left locales behave inconsistently.
      (LP: #945719)
    - LensButton.qml:72 warning when running unity-2d (LP: #947276)
    - [dash] Multi-range filters are rendered incorrectly in right-to-left
      locales (LP: #950649)
  * debian/unity-2d.gconf-defaults:
    - removed: not used anymore and causing regression with hide-mode=2
      by default, converted to the gsettings key (LP: #942772)
  * debian/unity-2d.preinst:
    - removed, was a natty -> oneiric transition
  * debian/control, debian/unity-2d-common.install:
    - create unity-2d-common and make some packages depending on it
    - move some files from unity-2d package to unity-2d-common
      (gsettings and apport hook) to have packaging shipping their schema
      (LP: #925457)
  * debian/unity-2d-common.install.in:
    - no more gconf -> gsettings migration shipped
  * debian/unity-2d.postinst, prerm, trigger:
    - moved to unity-2d-common new package, to ensure even people uninstalling
      unity-2d got the right metacity configuration in the session
    - update the trigger to the correct directory
  * debian/control:
    - bump to latest Standards-Version
    - fix some too long description
    - put the transitional packages in the oldlibs/extra section
    - build-dep on libxtst-dev, libxfixes-dev for barrier change
    - need latest metacity for barriers to work
 -- Didier Roche <email address hidden> Mon, 19 Mar 2012 14:07:10 +0100

Changed in unity-2d (Ubuntu):
status: Confirmed → Fix Released
Didier Roche (didrocks) on 2012-03-19
Changed in gnome-control-center (Ubuntu):
assignee: nobody → Didier Roche (didrocks)
Launchpad Janitor (janitor) wrote :
Download full text (5.4 KiB)

This bug was fixed in the package unity - 5.8.0-0ubuntu1

---------------
unity (5.8.0-0ubuntu1) precise-proposed; urgency=low

  * New upstream release.
    - New "push mouse offscreen" feature really difficult to get (LP: #923749)
    - unity-2d-panel crashed with SIGSEGV in
      unity::indicator::DBusIndicators::Impl::RequestSyncAll() (LP: #864737)
    - Pressing "Alt+Enter" causes compiz to crash in CompOption::value() from
      unity::UnityScreen::showLauncherKeyTerminate (LP: #960957)
    - SEGSIGV after unplugging external monitor (LP: #962693)
    - Background colorization should use a different heuristic (LP: #865239)
    - compiz+unity3d generates > 50 wakeups a second on idle system
      (LP: #917210)
    - [FFe, UIFe] HUD - The HUD does not respect launcher autohide or icon
      size settings (LP: #921506)
    - clicking on folders in the file lens does not open nautilus
      (LP: #921665)
    - No text inside multirange filters (LP: #927710)
    - can't alt-tab restore minimized uis which have an instance on another
      workspace (LP: #933397)
    - Ubuntu Software Center Unity launcher integration is not working
      (LP: #932280)
    - The line separator between the launcher and the dash is cleared when
      selecting a category (LP: #941082)
    - unity-panel-service crashed with SIGSEGV in g_hash_table_foreach()
      (LP: #937119)
    - Alt-F10 locks up Unity (LP: #948522)
    - multimonitor, launcher: Provide an option to display either a single
      launcher or a launcher on each display in a multi-monitor environment
      (LP: #950136)
    - multimonitor: Please give me a way to turn off sticky monitor edges
      (LP: #946104)
    - Unity 5.6: key bindings (such as Super) don't work on empty workspace or
      on slow/loaded systems (LP: #953089)
    - Alt+arrows keyboard shortcuts don't invoke Back and Forward navigation
      (LP: #953783)
    - HUD is sending 2 menu signals instead of 1 (LP: #956878)
    - 6th item of HUD not fully visible (LP: #957229)
    - HUD: seems to trigger operations more than once (LP: #960503)
    - Launcher gets always desaturated when using HUD on secondary monitor
      (LP: #961169)
    - [5.8 pre staging] launcher is displayed on the left screen, not the
      primary one (LP: #961281)
    - launcher icons do not re-saturate after dash is closed (LP: #961844)
    - Launcher shows arrows for applications on all workspaces (LP: #961977)
    - Dash - Implement overlay scrollbars in Dash (LP: #608124)
    - [UIFe] Dash - No message displayed when no results are returned in the
      Dash (LP: #711199)
    - Dash - "See more..." line should be base-aligned with section header
      (LP: #748101)
    - Dash - Missing category separator line in dash (LP: #850984)
    - Dash and Launcher - As soon as a user starts dragging a file from the
      Dash, there is a 'flicker' before the Launcher icons that are valid drop
      receptacles re-saturate (LP: #863230)
    - Dash - When multiple results have equal string match relevancy ranking,
      those with equal ranking should be then sorted by frequency of use.
      (LP: #871900)
    - Keyboard shortcut - F10 shortcut is used to show m...

Read more...

Changed in unity (Ubuntu):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:3.3.92-0ubuntu3

---------------
gnome-control-center (1:3.3.92-0ubuntu3) precise-proposed; urgency=low

  * debian/patches/51_unity_options_in_display_panel.patch:
    - add the options to the display panel for unity multimonitor support.
      Choice where the launcher can be set (one monitor, all monitor) and
      sticky edges. (LP: #950136)
  * debian/patches/revert_git_keyboard_gsettings.patch:
    - refreshed
  * debian/patches/04_new_appearance_settings.patch:
    - revert the "click to get directly to a position" on the scroll bar.
      This should be done in gtk to get the same behavior everywhere. Too
      late for this cycle though.
    - fix the scrolling since gtk introduced GDK_SCROLL_SMOOTH.
 -- Didier Roche <email address hidden> Fri, 23 Mar 2012 15:42:22 +0100

Changed in gnome-control-center (Ubuntu):
status: Confirmed → Fix Released
Greg A (etulfetulf) wrote :

Unfortunately, I think that fixing this has caused another the Displays setting to be confusing: Bug #963731

Gabor Kelemen (kelemeng) on 2012-03-24
Changed in ubuntu-translations:
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-docs (Ubuntu):
status: New → Confirmed
Tim Penhey (thumper) on 2012-04-22
Changed in ayatana-design:
status: Triaged → Fix Committed
Jeremy Bicha (jbicha) on 2012-04-22
Changed in ubuntu-docs (Ubuntu):
status: Confirmed → Fix Released
Nick Tait (jnick-tait) on 2012-04-26
tags: added: reviewedbydesignp
removed: udp
Changed in ayatana-design:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers