error in moin page, action test doesn't exist

Bug #745553 reported by Giuseppe Terrasi on 2011-03-30
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ubuntu-docs (Ubuntu)
Medium
Unassigned
Nominated for Lucid by Connor Imes
Nominated for Maverick by Connor Imes
Natty
Undecided
Unassigned

Bug Description

Binary package hint: ubuntu-docs

This page:
https://help.ubuntu.com/10.10/serverguide/C/moinmoin.html
https://help.ubuntu.com/10.04/serverguide/C/moinmoin.html

1) says: "You can also run the test command by pointing your web browser to the following URL: http://localhost/mywiki?action=test". but action test doesn't exist.

Simply, is possible to write: "You can verify the Wiki application and see if it works by pointing your web browser to the following URL: http://localhost/mywiki"

Changed in ubuntu-docs (Ubuntu):
status: New → Confirmed
Connor Imes (ckimes) wrote :

Hi Giuseppe, all the other documentation I find, including on Moin's site, uses this. Is the test script for that action set with +x permissions for the user you have running Moin?

Changed in ubuntu-docs (Ubuntu):
status: Confirmed → Incomplete

Uhm... I have installed some version on moin.

1.58 from source
1.9.2 from packages
1.9.3 from source

In SystemInfo page I can't see an action named "test".
So, if I run http://localhost/mywiki?action=test he doesn't work but all other action yes.
In generally, I apply this permission:
sudo chmod -R ug+rwX mywiki
sudo chmod -R o-rwx mywiki

On moin mercurial this is the action folder: http://hg.moinmo.in/moin/1.9/file/b853ed5b9965/MoinMoin/action

As I suppose, on irc #moin says me: "iirc, that test action is long gone".

Connor Imes (ckimes) wrote :

Ok, I'll update the line then, thanks for the feedback. The user on IRC didn't suggest an alternative action did they?

Changed in ubuntu-docs (Ubuntu):
assignee: nobody → Connor Imes (rocket2dmn)
importance: Undecided → Medium
status: Incomplete → In Progress

No. But I think that the fast solution is open a browser and go to http://localhost

With step present in our page installation must be work fine...

Connor Imes (ckimes) wrote :

I think the line in question is attempting to ensure that wiki actions work, perhaps we can choose another one to use, like "?action=info". If not, we should probably just get rid of that second test option since right before it says to navigate to the wiki URL already.

Connor Imes (ckimes) wrote :

I removed the directions in Natty, Maverick, and Lucid docs.

Changed in ubuntu-docs (Ubuntu):
status: In Progress → Fix Committed

Accepted ubuntu-docs into natty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in ubuntu-docs (Ubuntu Natty):
status: New → Fix Committed
tags: added: verification-needed
Matthew East (mdke) wrote :

This is fixed on help.ubuntu.com. The serverguide isn't included in the ubuntu-docs package so I request that this be taken off the SRU subscription list.

Changed in ubuntu-docs (Ubuntu Natty):
status: Fix Committed → Fix Released
Changed in ubuntu-docs (Ubuntu):
status: Fix Committed → Fix Released

Turkish hacker attacking me 5 years until now help me plz

Changed in ubuntu-docs (Ubuntu):
assignee: Connor Imes (rocket2dmn) → Youssef Fayad (youssef-fayadsa)
Connor Imes (ckimes) on 2011-05-10
Changed in ubuntu-docs (Ubuntu):
assignee: Youssef Fayad (youssef-fayadsa) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers