Ubuntu

[Server Guide] OpenLDAP credentials issue in Ubuntu Server 10.04

Reported by Alex on 2010-05-12
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-docs (Ubuntu)
Undecided
Adam Sommer
Nominated for Maverick by HX_unbanned
Lucid
Medium
Unassigned

Bug Description

Binary package hint: ubuntu-docs

For the information in Ubuntu Documentation> Ubuntu 10.04> Ubuntu Server Guide> Network Authentication> OpenLDAP Server

                https://help.ubuntu.com/10.04/serverguide/C/openldap-server.html

I'd tried to setup a LDAP server using this guide.
I'd done all steps up to LDAP Replication and still fine. So, I'd skipped this section (Replication).
I'd tried to look down to Setting Up ACL.
I'd tried this step, but return:

                            'credentials (49)' errors.

What's problem?
I couldn't list the ACL status from LDAP DIT!!

Adam Sommer (asommer) wrote :

Thanks for reporting this and helping make Ubuntu better. The ACL section needs to be updated to
use the new:

  sudo ldapsearch -c -Y EXTERNAL -H ldapi:/// -b cn=config

format. I'll try to get that updated.

tags: added: serverguide
Changed in ubuntu-docs (Ubuntu):
status: New → Triaged
assignee: nobody → Adam Sommer (asommer)
milestone: none → lucid-updates
Alex (alexclho) wrote :

Thanks Adam,

I've tried your solution.
                 sudo ldapsearch -c -Y EXTERNAL -H ldapi:/// -b cn=config

However it may list (whole) DIT data.
It doesn't match to the server document.
Then, I tried a little modify with the original command:
                sudo ldapsearch -LLL -Y EXTERNAL -H ldapi:/// -b cn=config olcDatabase=hdb olcAccess

It may show the correct (matched output) to the server document.
Thanks anyway.

HX_unbanned (linards-liepins) wrote :

Adam, let me do it, Okay? ;)

Changed in ubuntu-docs (Ubuntu):
status: Triaged → In Progress
assignee: Adam Sommer (asommer) → HX_unbanned (linards-liepins)
tags: added: patch samba
Connor Imes (rocket2dmn) on 2010-05-15
tags: removed: patch
HX_unbanned (linards-liepins) wrote :

Changes:
- translated / updated string in ALL .po files in package.

Notes:
- translated, using: https://bugs.launchpad.net/ubuntu/+source/ubuntu-docs/+bug/575540 package.

tags: added: patch
summary: - OpenLDAP credentials issue in Ubuntu Server 10.04
+ [Server Guide] OpenLDAP credentials issue in Ubuntu Server 10.04
Adam Sommer (asommer) wrote :

Woops, sorr HX_unbanned, this patch has the same problem as bug 575540. Basically to update to the docs, or create a patch, you need to check out the source from bzr make your change then create a patch and submit it. There are better instructions here:

  https://wiki.ubuntu.com/DocumentationTeam/SystemDocumentation

Thanks again for your submission, if you have any questions please let us know. You can find members of the Doc Team on the mailing list and in #ubuntu-docs on freenode.

Adam Sommer (asommer) wrote :

I committed a fix to revision 511 on Maverick and revision 509 on Lucid.

Thanks again.

Changed in ubuntu-docs (Ubuntu):
status: In Progress → Fix Committed
assignee: HX_unbanned (linards-liepins) → Adam Sommer (asommer)
Matthew East (mdke) wrote :

Fix released in maverick.

Changed in ubuntu-docs (Ubuntu):
status: Fix Committed → Fix Released
Changed in ubuntu-docs (Ubuntu Lucid):
importance: Undecided → Medium
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers