Ubuntu

serverguide: Broken links to the installation guide

Reported by Gabor Kelemen on 2010-05-05
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
ubuntu-docs (Ubuntu)
High
Matthew East
Lucid
Undecided
Unassigned

Bug Description

Binary package hint: ubuntu-docs

There are several broken links (https://help.ubuntu.com/10.04 LTS/installation-guide/) to the installation guide in the serverguide, the version number is "10.04 LTS" instead of the working "10.04":

https://translations.launchpad.net/ubuntu/lucid/+source/ubuntu-docs/+pots/ubuntu-docs-serverguide/hu/+translate?batch=10&show=all&search=10.04+LTS%2F

Current occurrences:
Located in serverguide/C/virtualization.xml:94(para)
Located in serverguide/C/introduction.xml:19(para)
Located in serverguide/C/installation.xml:14(para)
Located in serverguide/C/installation.xml:259(para)

Connor Imes (rocket2dmn) wrote :

Currently we use the variable distro-rev both in links and in text. These links were broken when we appended "LTS" to the end. I suggest splitting into two variables, like "distro-rev-full" and "distro-rev-short", however they would be the same value except during LTS cycles. Any opinions?

Changed in ubuntu-docs (Ubuntu):
assignee: nobody → Connor Imes (rocket2dmn)
importance: Undecided → High
milestone: none → lucid-updates
status: New → In Progress
Adam Sommer (asommer) wrote :

I guess we either manually change the links, or change the distro-rev in the libs/global.ent file. My thought is that there are less links then there are strings using distro-rev outside of URLs, so I vote for a manual change. Wouldn't think that it'd take too long.

Bas Roset (broset) wrote :

"so I vote for a manual change. Wouldn't think that it'd take too long."

It does seem to be taking a while, since the 'bugs' haven't been solved... ;-)

Muhammad Asif Anwar
Cell No: +92-300-8885072
Ph No: +92-608-362928
Pakistan.

________________________________
From: Bas Roset <email address hidden>
To: <email address hidden>
Sent: Wed, June 30, 2010 12:07:57 PM
Subject: [Bug 575961] Re: serverguide: Broken links to the installation guide

"so I vote for a manual change. Wouldn't think that it'd take too long."

It does seem to be taking a while, since the 'bugs' haven't been
solved... ;-)

--
serverguide: Broken links to the installation guide
https://bugs.launchpad.net/bugs/575961
You received this bug notification because you are subscribed to ubuntu-
docs in ubuntu.

Status in “ubuntu-docs” package in Ubuntu: In Progress

Bug description:
Binary package hint: ubuntu-docs

There are several broken links (https://help.ubuntu.com/10.04 LTS/installation-guide/) to the installation guide in the serverguide, the version number is "10.04 LTS" instead of the working "10.04":

https://translations.launchpad.net/ubuntu/lucid/+source/ubuntu-docs/+pots/ubuntu-docs-serverguide/hu/+translate?batch=10&show=all&search=10.04+LTS%2F

Current occurrences:
Located in serverguide/C/virtualization.xml:94(para)
Located in serverguide/C/introduction.xml:19(para)
Located in serverguide/C/installation.xml:14(para)
Located in serverguide/C/installation.xml:259(para)

Connor Imes (rocket2dmn) wrote :

Unassigning myself, sorry I don't have time to work on this.

Changed in ubuntu-docs (Ubuntu):
assignee: Connor Imes (rocket2dmn) → nobody
status: In Progress → Confirmed
Vikram Dhillon (dhillon-v10) wrote :

On Wed, Jul 07, 2010 at 10:25:32PM -0000, Connor Imes wrote:
> Unassigning myself, sorry I don't have time to work on this.
>
> ** Changed in: ubuntu-docs (Ubuntu)
> Assignee: Connor Imes (rocket2dmn) => (unassigned)
>
> ** Changed in: ubuntu-docs (Ubuntu)
> Status: In Progress => Confirmed
>
> --
> serverguide: Broken links to the installation guide
> https://bugs.launchpad.net/bugs/575961
> You received this bug notification because you are subscribed to ubuntu-
> docs in ubuntu.
>
> Status in “ubuntu-docs” package in Ubuntu: Confirmed
>
> Bug description:
> Binary package hint: ubuntu-docs
>
> There are several broken links (https://help.ubuntu.com/10.04 LTS/installation-guide/) to the installation guide in the serverguide, the version number is "10.04 LTS" instead of the working "10.04":
>
> https://translations.launchpad.net/ubuntu/lucid/+source/ubuntu-docs/+pots/ubuntu-docs-serverguide/hu/+translate?batch=10&show=all&search=10.04+LTS%2F
>
> Current occurrences:
> Located in serverguide/C/virtualization.xml:94(para)
> Located in serverguide/C/introduction.xml:19(para)
> Located in serverguide/C/installation.xml:14(para)
> Located in serverguide/C/installation.xml:259(para)
>
>

I'll pick this one up, it seems since I ported some of Ubuntu serverguide to Kubuntu docs as well, this bug could be applicable there as well :)

 assignee dhillon-v10

--
Regards,
Vikram Dhillon

"I think, therefore I am" -- Descartes

Changed in ubuntu-docs (Ubuntu):
assignee: nobody → Vikram Dhillon (dhillon-v10)
Matthew East (mdke) wrote :

Connor's idea seems sensible to me. I've committed a fix to Lucid/Maverick.

Changed in ubuntu-docs (Ubuntu):
assignee: Vikram Dhillon (dhillon-v10) → Matthew East (mdke)
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-docs - 10.10.1

---------------
ubuntu-docs (10.10.1) maverick; urgency=low

  * First release for maverick
  * General:
    - Update copyright year, LP: #580396
    - Update version numbers for maverick, LP: #587119
    - Update pot files
  * Administrative:
    - Users and Groups app UI changed - adjusted directions,
      LP: #570429 (Connor Imes)
  * Basic-commands:
    - Removed incorrect comment about using ~ with sudo,
      LP: #570423 (Connor Imes)
  * Internet:
    - Add section on Ubuntu One, authored by Matt Griffin with
      some changes/review
    - Typos: Cicso -> Cisco. Alex Wardle, LP: #561084
  * Musicvideophotos:
    - Add material on using Ubuntu One Music Store and
      other Music Stores
      within Rhythmbox, content submitted by Matt Griffin
    - Update microphone troubleshooting, LP: #591164
  * Serverguide:
    - Removed erroneous text from vmbuilder command,
      LP: #559190
    - Typo in network-config section. Alex Wardle, LP: #550892
    - Fix typo in Kerberos section. David C. Curtis, LP: #561788
    - Replaced dkim-filter with opendkim, feedback from
      Scott Kitterman. LP: #561825
    - Changed ldapsearch command in ACL section for new authentication
      mechanism. LP: #333733
    - Adjusted certificate wording to be more concise about which
      lines to copy. LP: #575859
    - Changed samba restart command to use new upstart scripts.
      LP: #575540
    - New information about granting groups Admin rights for Samba.
      LP: #579851
    - Various typos and English fixes from Travis Nichol, Connor Imes,
      Vikram Dhillon, Dean Sas, Andrew Rowell. LP: #594913,
      LP: #572959, LP: #603947
    - New Amavisd-new and Spamassassin section which adds note about possible
      large amount of error messages sent to email. LP: #165184 (Adam Sommer)
    - Removed OpenNebula section (Adam Sommer)
    - Removed eBox section (Adam Sommer)
    - Reviewed and updated User Management and Console Security sections
      (Adam Sommer)
    - Fixed spelling typo of dyngroup.schema, fixed ldapscripts <ask> example
      explanation, and ldapscripts example template path. LP: #595001
      (Adam Sommer)
    - Updates to UEC sections (Adam Sommer)
    - New "First Boot" section covering clout-init functionality (Adam Sommer)
    - Fix broken links to installation-guide, add distro-rev-short
      entity, LP: #575961
  * Windows:
    - Change wording of windows/C/preparing.xml, LP: #483153
 -- Matthew East <email address hidden> Sat, 14 Aug 2010 22:35:52 +0100

Changed in ubuntu-docs (Ubuntu):
status: Fix Committed → Fix Released
Connor Imes (rocket2dmn) wrote :

This was fixed in Lucid as well, rev 513 and was released shortly after.

Changed in ubuntu-docs (Ubuntu Lucid):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers