Create a separate license document and include it in all documents

Bug #460365 reported by David Planella on 2009-10-25
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Translations
Low
Unassigned
ubuntu-docs (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: ubuntu-docs

From the point of view of translation, it would be quite useful to have a single document where the <legalnotice> and <copyright> material could be translated and reused. The current approach is to include this material in each document via entities, which causes the material to appear in the pot template for each document, which implies that for every document, the same strings have to be translated all over again.

I'm referring to the following strings:

"Credits and License

This document is maintained by the Ubuntu documentation team (https://wiki.ubuntu.com/DocumentationTeam). For a list of contributors, see the contributors page

This document is made available under the Creative Commons ShareAlike 2.5 License (CC-BY-SA).

You are free to modify, extend, and improve the Ubuntu documentation source code under the terms of this license. All derivative works must be released under this license.

This documentation is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE AS DESCRIBED IN THE DISCLAIMER.

A copy of the license is available here: Creative Commons ShareAlike License."

Adi Roiban (adiroiban) on 2009-10-26
Changed in ubuntu-translations:
status: New → Confirmed
importance: Undecided → Low
Vikram Dhillon (dhillon-v10) wrote :

I think one of the things that can be done is to have a line at the beginning of every documentation file, something like this: For more information on licensing, please refer to the CREDITS file. Then the CREDITS file will have the statement said above

Connor Imes (ckimes) wrote :

As far as I can tell, we do only have a single file for this, and it is referenced at the top of each file. Perhaps when we export for translations, the reference copies over the text rather than keeping the include and simply having the legalnotice.xml file be translated.

Vikram Dhillon (dhillon-v10) wrote :

Any updates on this ?

Matthew East (mdke) wrote :

The cause of this is as follows: the legalnotice text quoted in the bug report is indeed a separate file in the English version. It is included in each document by way of an entity (&legalnotice;). However, because we use xml2po with the -e flag when we create pot files, the content of entities is included in the translation pot file directly.

I can't immediately think of any obvious solution to this but will have a think about it and see how Gnome deal with it. If others have any technical solutions, please feel free to put them forward.

(NB the actual license document itself isn't included in each document, that is a separate document at /usr/share/ubuntu-docs/libs/C/ccbysa.xml. We don't offer that for translation because unauthorised translations of licenses are usually a bad idea for the reasons described here: http://www.gnu.org/licenses/translations.html.

Matthew East (mdke) on 2010-01-12
Changed in ubuntu-docs (Ubuntu):
importance: Undecided → Wishlist
status: New → Confirmed
description: updated

Is this still an issue? Please confirm if it is so.

Changed in ubuntu-docs (Ubuntu):
status: Confirmed → Incomplete
Changed in ubuntu-translations:
status: Confirmed → Incomplete
Gabor Kelemen (kelemeng) on 2010-08-25
Changed in ubuntu-docs (Ubuntu):
status: Incomplete → Confirmed
Changed in ubuntu-translations:
status: Incomplete → Confirmed
David Planella (dpm) on 2010-08-26
Changed in ubuntu-translations:
status: Confirmed → Triaged
Matthew East (mdke) wrote :

I had a go at changing the setup of ubuntu-docs so that instead of using an entity to include the legalnotice tag, each document incorporates a separate legalnotice file using xinclude. I'm attaching the (untested) patch that should do this. However the problem is that each document uses a line like this to include the separate file:

<xi:include href="../../common/C/legalnotice.xml" xmlns:xi="http://www.w3.org/2001/XInclude"/>

I have no idea how in the translated xml document, the URI path can be changed to refer to the translated xml file, so that for french it would appear like this:

<xi:include href="../../common/fr/legalnotice.xml" xmlns:xi="http://www.w3.org/2001/XInclude"/>

I've subscribed Danilo in case he has any thoughts about how xml2po could be used to solve this issue.

tags: added: patch
Matthew East (mdke) on 2010-09-12
tags: removed: patch
Gunnar Hjalmarsson (gunnarhj) wrote :

Given how it works nowadays, I close this as "Fixed Released".

Changed in ubuntu-docs (Ubuntu):
status: Confirmed → Fix Released
Changed in ubuntu-translations:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers