Documentation should include greater detail about setting up difficult network hardware

Bug #42454 reported by towsonu2003 on 2006-05-01
24
Affects Status Importance Assigned to Milestone
Ubuntu Documentation
Medium
Unassigned
Baltix
Undecided
Unassigned
kubuntu-docs (Ubuntu)
Wishlist
Unassigned
ubuntu-docs (Ubuntu)
Wishlist
Unassigned

Bug Description

The current documentation (Desktop Guide) refers to several wiki pages for help setting up wireless cards and modems, but those who have problems with these can't access the wiki. Therefore, more information about getting these working needs to be available offline.

Matthew East (mdke) wrote :

Thanks for your bug. You're right: there are lots of topics which we haven't had the opportunity to include in the documentation, and are available only on the community maintained documentation area (i.e. the wiki). This is a topic which it is particularly important to include in the offline documentation, and we'll try to include it in the next version of our documentation. Unfortunately it is too late to change the documentation for Ubuntu 6.06.

Changed in ubuntu-docs:
status: Unconfirmed → Confirmed
Matthew East (mdke) on 2006-05-02
description: updated
towsonu2003 (towsonu2003) wrote :

Thanks for the changes in this as well as in bug #42453 - perfectly conveys what I wanted :)

Jonathan Jesse (jjesse) wrote :

We need to make sure this bug gets covered in the Kubuntu Desktop Guide as well as the Ubuntu one. I'm sure the same issue exists there as well.

towsonu2003 (towsonu2003) wrote :

anyone using kubuntu, _please_ confirm that its documentation refers to wiki when the topic is networking (modems, wifi and so on) like ubuntu does.

You can always check on http://doc.ubuntu.com/kubuntu/desktopguide/C/index.html

Anyways, it is an issue in kubuntu-docs as well.

towsonu2003 (towsonu2003) wrote :

> You can always check on
> http://doc.ubuntu.com/kubuntu/desktopguide/C/index.html
Thanks --didn't know that existed :)

confirming as to http://doc.ubuntu.com/kubuntu/desktopguide/C/ch05s04.html (scroll towards the middle, it's the same as the ubuntu documentation).

Changed in kubuntu-docs:
status: Unconfirmed → Confirmed

It would be good to see this covered, but I wonder if it is within the scope of the Desktop Guide? Is there a package or packages containing various modem drivers, especially the many different winmodem drivers, in Ubuntu? Covering all the different types of winmodems may take up a disproportionate part of the guide too.

That said, for Edgy there is no reason why we couldn't plan to expand the Desktop guide even more to include this, and other such indepth-to-do-it-justice topics.

towsonu2003 (towsonu2003) wrote :

> It would be good to see this covered, but I wonder if it is within the
> scope of the Desktop Guide? Is there a package or packages
> containing various modem drivers, especially the many different
> winmodem drivers, in Ubuntu?

The desktop guide is a very valuable source of information imho. Compared to the Windows Help, it's a gold mine... But it can (should) be expanded, by adding needed sections.

ubuntu's modem support is bad (to say it kindly). There are too many specific ways to make a winmodem work (see https://wiki.ubuntu.com/DialupModemHowto ). And the available ubuntu packages (ltmodem in restricted modules and sl-modem-daemon+sl-modem-source and that's all I think) are not enough.

Without a guide on howto set up your modem (or your wifi), you cannot look at the wiki pages linked in the offline documentation.

The guides are ready to be copy-pasted to the documentation as sections (especially the winmodem wiki and the bcm43xx wiki). If only I knew how to write at least the modem part in a "Ubuntu Desktop Guide" format, I would be done with these two :)

I'm pretty sure this can be done bf the dapper release (~one month to go) if the review process is not too strict, but I'm not sure whether there is someone (with skills) willing to deal with it ;)

Jonathan Jesse (jjesse) wrote :

The problem right now with making changes to the guide is that we are well into string freeze in order for translations for the documents to happen. Making such a large change would through translations totally out of schedule.
This is a great goal though for Edgy.

Matthew East (mdke) wrote :

Adjusting the bug to reflect that it will not be address in this release, but in the future.

Changed in kubuntu-docs:
status: Confirmed → Rejected
Changed in ubuntu-docs:
status: Confirmed → Rejected
Changed in ubuntu-doc:
status: Unconfirmed → Confirmed
towsonu2003 (towsonu2003) wrote :

> translations for the documents to happen.

argh translations... my bad -sorry. I hope this is fixed in edgy...

Matthew East (mdke) wrote :

I've started working on this: I've made the section on connecting to the internet more prominent and added information on setting up wireless cards with ndiswrapper. Please review - http://doc.ubuntu.com/ubuntu/desktopguide/C/connect-to-internet.html

We still need to add more information on modems, specifically dialup and ADSL modems.

towsonu2003 (towsonu2003) wrote :

The guide (the link you sent) looks very nice. However, for the modem section, I do not think giving only the scanmodem help is enough.

is there any way to gather the info laying down in our dialup modem howto wiki page and put it in the documentation? just like the wiki does, we could make it into sections, each section describing the way to do it for one modem chipset (as identified by scanmodem).

the documentation is also lacking how to configure the adsl connection so it would be a great idea to put the online wiki guide into the offline guide you have. in other words, you could put whatever is written in this web page ( https://wiki.ubuntu.com/ADSLPPPoE ) to your offline documentation under the heading "ADSL Modems".

For a new Ubuntu / Linux user, it is extremely hard to enable networking when all the documentation is presented online, not offline...

As an endnote, would it be possible to put the Broadcom bcm43xx instructions into the offline guide as well? I would love to see as much information about networking in the offline documentation as possible... Thank you very much for your effort :)

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

* towsonu2003:
> However, for the modem
> section, I do not think giving only the scanmodem help is enough.
[...]
> the documentation is also lacking how to configure the adsl connection

Yes, as I said above, those sections still need work. That's why this
bug hasn't been closed.

> is there any way to gather the info laying down in our dialup modem
> howto wiki page and put it in the documentation? just like the wiki
> does, we could make it into sections, each section describing the way to
> do it for one modem chipset (as identified by scanmodem).

Yes, I used the wiki information to write the ndiswrapper section, and
we can do the same for the modem section. It's quite difficult because
there are so many models of modem, and really difficult to confirm
whether the instructions for each of them are accurate.

> For a new Ubuntu / Linux user, it is extremely hard to enable networking
> when all the documentation is presented online, not offline...

Yeah, that's what this bug is about.

> As an endnote, would it be possible to put the Broadcom bcm43xx
> instructions into the offline guide as well? I would love to see as much
> information about networking in the offline documentation as possible...
> Thank you very much for your effort :)

This is a wireless chip right? I'm not completely sure about whether we
can document individual wireless chips, because (a) it's quite hard for
the user to find out what chip they have (as far as I know), and (b) the
information we have available is vast and probably not particularly
accurate (https://help.ubuntu.com/community/WifiDocs). Ndiswrapper is
generally a universal fix, which is why I included that.

Matt
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2.2 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFE7rKFtSaF0w5rBv8RAgUVAJ9F8CWrdCiQtBA7PP/gsNa0vc40AQCghJqA
ZgjdlHUHfWeU2b/DF3/qE1g=
=Nhj1
-----END PGP SIGNATURE-----

______________________________________________________________________
This email has been scanned by the MessageLabs Email Security System.
For more information please visit http://www.messagelabs.com/email
______________________________________________________________________

Matthew East (mdke) wrote :

ok, added section on ADSL connections. I've included documentation about PPPOE modems (again from the wiki), and USB modems still need to be added.

As for expanding the dialup modem section, I tried to do some work on that, but found the scanModem tool didn't work on my computer, so any help with that from someone who knows about dialup modems would be appreciated.

Matt

Changed in kubuntu-docs:
status: Rejected → Confirmed
Changed in ubuntu-docs:
status: Rejected → Confirmed
towsonu2003 (towsonu2003) wrote :

> so any help with that from someone who knows about dialup modems would be
> appreciated.

only if I knew something about writing offline documentation...

Richard Johnson (nixternal) wrote :

towsonu2003, you can email <email address hidden> with a plain text attachment of your write up if you would like. Another suggestion would be the wiki, so that we could get people to test your procedures/ideas to this fix before implementing them into the documentation. All of our offline documentation is written in DocBook XML. It is rather easy to pickup truthfully, but for the time being, the wiki or plain text would be fine. Thanks!

towsonu2003 (towsonu2003) wrote :

I was hoping to do his, but nowadays, so busy... can we just add the wiki information (copy paste + format) as it is? link is https://wiki.ubuntu.com/DialupModemHowto

it has been tried and tested numerous times via the forums...

thanks :)

towsonu2003 (towsonu2003) wrote :

I tried my best to simplify the ubuntu wiki html and convert it to various formats. I'm attaching them here, and will email ubuntu-doc.

towsonu2003 (towsonu2003) wrote :
towsonu2003 (towsonu2003) wrote :

I used an online html to xml converter, which probably couldn't do it... but it's an xml nevertheless :)

towsonu2003 (towsonu2003) wrote :

emailed ubuntu-doc team a couple of times, latest here: https://lists.ubuntu.com/archives/ubuntu-doc/2006-December/007510.html

Matthew East (mdke) wrote :

I'd like to get cracking on the "dialup" part of this bug. What is support for modems likely to be like for Ubuntu 7.04?

And we need to focus on ensuring the instructions we give are correct - last thing I heard that the scanmodem tool doesn't work any more with Ubuntu, is this correct? if so, what alternatives exist?

towsonu2003 (towsonu2003) wrote :

is this forgotten now? is anyone working on this, at least to try to include the winmodem part before feisty is released? (the bad xml was attached to this bug report)

Richard Johnson (nixternal) wrote :

We are working on this and I believe the Ubuntu side has done a great deal of work, or are still in the planning phase which has consisted of a great deal of work. We still have 2 months until string freeze and we are working hard on many many things right now.

Matthew East (mdke) wrote :

I'd like to do more about this bug, but as far as I can see we haven't had any information about the use of the scanmodem tool in Feisty, except that it probably doesn't work. Modems are clearly a very difficult area and we are going to need the developers' input before we can move any further, I think.

towsonu2003 (towsonu2003) wrote :

I can't try Feisty (I've got one single production machine w. Dapper) but asked ppl to assist here: https://lists.ubuntu.com/archives/ubuntu-devel-discuss/2007-March/000434.html

Thanks a lot for your interest in this :)

I made the winmodem on my HP Compaq nc4200 laptop with today's Feisty working. scanmodem told me to modprobe the low-level driver (snd_intel8x0m) and after re-running it created a file Modem/ModemData.txt in which it was written that the high-level driver is slmodemd. With Universe and Multiverse activated I tried to find an appropriate Ubuntu package trying

sudo apt-get install slmodemd
sudo apt-get install slmodem

and the second command installed and started the desired driver. After that

sudo wvdialconf /etc/wvdial.conf

communicated with the modem and created an initial config file.

I have ASDL, but I only wanted to tell that it works for me with the mentioned laptop.

Proceeding exactly the same way as in my previous posting I got also the modem on the Samsung X10plus laptop working. It is the same modem.

Can it be that all Centrino laptops have the same modem?

towsonu2003 (towsonu2003) wrote :

great, thanks a lot :)

now that we know scanmodem is working with feisty with h.u.c./community instructions, can we put the documentation to the offline help system? the attached xml file needs to be fixed I assume (I didn't learn anything new about xml since I did that file)...

> Can it be that all Centrino laptops have the same modem?
I don't think so but you're very lucky to bump into an alsa-enabled sl-modem on two separate systems... I've got one and they're one of the easiest to make work :) Specific instructions for that are here (in case someone hits your comment via google): https://help.ubuntu.com/community/DialupModemHowto/AlsaModem
Rest of the slmodems here: https://help.ubuntu.com/community/DialupModemHowto/Smartlink

Matthew East (mdke) wrote :

Ok, I've had a go at using these instructions to setup the modem on my laptop, which is an Intel Conexant modem.

I don't think that all the instructions from the wiki are in an appropriate state to go into the system help, because there are a number of areas which address Breezy/Dapper only, and a lot of unsupported drivers are flying around.

Equally, it's clearly not going to be at all possible for a user without any kind of internet access to get it working without an alternative internet connection - the scanmodem tool itself and all the drivers need to be downloaded.

For now, I think the best we can do is provide an introduction to the topic, how to find out the required driver with scanmodem and a pointer to useful online documentation about where to find the drivers. That is already included in the current dialup section of internet.xml. (preview - http://doc.ubuntu.com/ubuntu/C/internet/connect-to-internet.html#dialup)

Any further detail is going to have to wait until drivers for modems are consistently provided with Ubuntu or at least the functionality for adding them semi-automatically is included. For now I'll close this bug.

Changed in ubuntu-doc:
status: Confirmed → Fix Released
Changed in kubuntu-docs:
status: Confirmed → Fix Released
Changed in ubuntu-docs:
status: Confirmed → Fix Released

Puppy linux has a really great wizard for detecting modems - winmodems in particular.

http://www.puppyos.com/
Specifically Puppy Unleashed is a reference to the source and directions for building a complete system.

All the source etc is available so if you need ideas about getting these nasty things to work.

The 2 main problems people (eg me) have had are - winmodem chipset detection and port detection.

Using a Thinkpad R60 - winmodem on a pcmia card. Knoppix 3.7 & 3.9 would give me grief - why I don't know. Puppy 2.14 (latest release) and earlier were pretty good about using it.

Hope this helps

tqft wrote:
> Puppy linux has a really great wizard for detecting modems - winmodems
> in particular.

do you know what the name of the tool is? thanks.

towsonu2003 (towsonu2003) wrote :

>> tqft wrote:
>>> Puppy linux has a really great wizard for detecting modems -
>>> winmodems in particular.
> --- t u <email address hidden> wrote:
>> do you know what the name of the tool is? thanks.
>>
tqft wrote:
> From
> http://puppyos.net/blog/index.php?m=06&y=06&entry=entry060630-191113
> /usr/sbin/modem-wizard
>
> Does this help?

I'm not sure, I'll look at what it does. maybe I can get someone to
upload it to ubuntu? (ie I hope so :) )

thanks a lot.

Jonathan Jesse (jjesse) wrote :

This bug is marked as fix released, can we take a look at "Baltix" which I don't know anything about, and see where this bug stands there?

Thanks,

Jonatahn

Matthew Paul Thomas (mpt) wrote :

The bug's status in Baltix is Baltix's own business.

Przemek K. (azrael) wrote :

Latest release of Baltix is based on Ubuntu Jaunty so this bug is surely fixed there too.

Changed in baltix:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers