retrieve 8.04 official doc video-editing section in current stable release official doc

Bug #367569 reported by marco.pallotta on 2009-04-26
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-docs (Ubuntu)
Wishlist
Book 'em Dano

Bug Description

Binary package hint: ubuntu-docs

Video-Editing section of the official documentation of Ubuntu 8.04 LTS (https://help.ubuntu.com/8.04/musicvideophotos/C/video.html#video-editing) was well done. In fact it included suggestion about many useful software for the most video tasks (dvd-rip, video editing, dvd authoring, ans so on) but I noticed that it was downsized either in 8.10 or in 9.04 (in vide-editing section of these distro official doc we only have two lines about some video editing software but no hint about, for example, dvd-ripping or dvd-authoring tasks)
I don't know why (I thought it should have been improved not almost dropped).
Ok. One argue that a typical user could obtain useful info on the wiki doc (I too contribute on it) but this last is not well organized and it's too dispersive for a non expert user. Moreover we have to think that no default software about, for example, dvd-ripping or dvd authoring is istalled by default and Ubuntu offers (fortunately) many software, for these task, in the repos. So I think it's useful, expecially for newbies, to have an "official" direction by Ubuntu about this.

tags: added: whishlist

Hi,

Thanks for taking the time to contact us. I tidied up a lot of this section prior to Jaunty's release, some of the information was outdated and lacking a consensus on what to offer this information was omitted.

If you have suggestions I will be happy to put them into the next release.
If you

Changed in ubuntu-docs (Ubuntu):
assignee: nobody → dougierichardson
status: New → Confirmed
description: updated
marco.pallotta (marco-pallotta) wrote :

Dougie, I think we can simply include in the section "recording and editing video", under "Movies, DVDs and videos" chapter, a list of popular video tasks with the corresponding software to use, for example

HOW TO:
make a DVD -> use DeVeDe
edit a video -> use either PiTiVi or Kino or OpenMovieEditor
rip a dvd -> use either Thoggen DVD Ripper or AcidRip
record a desktop session -> use gtk-recordMyDesktop
record a movie from webcam -> use Cheese

The listed apps are, for my experience (I tried many and many multimedia apps as I use Ubuntu as multimedia station) the best apps available that mix usability and functionality. When I list more apps for a certain "how-to" is because some tasks require the use of more apps: for example to rip a dvd Thoggen is a great software to rip into ogg but if you require to rip into other format you have to choose AcidRip (I haven't include other popular software as DVD::Rip, better than acidrip for completeness, because transcode is very buggy than mplayer/mencoder).

Removing myself from ubuntu-docs bugs.

Changed in ubuntu-docs (Ubuntu):
importance: Undecided → Wishlist
tags: added: bitesize
removed: whishlist
Changed in ubuntu-docs (Ubuntu):
assignee: Dougie Richardson (dougierichardson) → nobody
Book 'em Dano (heymrdjd) wrote :

I'd be wiling to attempt to take this on. What source xml files from which bzr need to be modified to accomplish this task?

Connor Imes (ckimes) wrote :

It sounds like the OP wants some of the documentation in the musicvideophotos section of the Hardy branch:
   https://code.launchpad.net/~ubuntu-core-doc/ubuntu-docs/ubuntu-hardy
brought into the current development branch:
   https://code.launchpad.net/~ubuntu-core-doc/ubuntu-docs/lucid

If you need help getting started, see https://wiki.ubuntu.com/DocumentationTeam/SystemDocumentation
Thanks!

Book 'em Dano (heymrdjd) wrote :

Here is my proposed modification to the documentation pertaining to recording and editing video.

Connor Imes (ckimes) wrote :

Book 'em Dano, thanks for your patch. I made a couple of adjustments to it, most importantly because it did not validate. In the future, please validate changes by running:
   scripts/validate.sh sectionname/C/sectionname.xml
The directions on the wiki are a bit confusing - even though you changed video.xml, you run the validate command against the parent xml, which is always named after the directory structure. In this case your command would be:
   scripts/validate.sh musicvideophotos/C/musicvideophotos.xml

Fix committed to Lucid dev branch, rev 482. Cheers.

Changed in ubuntu-docs (Ubuntu):
assignee: nobody → Book 'em Dano (heymrdjd)
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (5.5 KiB)

This bug was fixed in the package ubuntu-docs - 10.04.2

---------------
ubuntu-docs (10.04.2) lucid; urgency=low

  * General:
    - Fixes to scripts/fix-url.sh (including LP: #482862)
    - Fix character encoding in contributors.xml (LP: #448618)
    - Updated version in browser-startpage html files, LP: #526320
    - Refresh pot files
  * Add-applications:
    - Updates for UI changes, Phil Bull
  * Config-desktop:
    - Added topic on changing window buttons from the left, Phil Bull
  * Hardware:
    - Added mention of gsynaptics, Connor Imes, LP: #450567
  * Internet:
    - Refresh list of plugins supplied by ubuntu-restricted-extras, branch
      from Nathan Murray, LP: #504981
    - Updates to reflect that Ekiga no longer installed by default, Connor Imes,
      LP: #508572
    - Grammar fix from Alex Wardle, LP: #517776
    - Order adjustment for shares-admin usage, Alex Wardle, LP: #518119
    - Button name change for shares-admin app, Alex Wardle, LP: #518170
    - Use unlock icon in networking section, Alex Wardle, LP: #518117
    - Updated directions on changing text size and page zooming in firefox,
      Alison Rowland, LP: #512556
    - Fixed guilabel usage in modem section. Alex Wardle, LP: #521243
    - Updated button and tab names in Static Connections section,
      Alex Wardle, LP: #521508
    - Typo fix in adsl section. Alex Wardle, LP: #525349
    - Removed unused and empty basics.xml, LP: #525431
    - Minor wording update to directions for sharing folders via nautilus,
      Connor Imes, LP: #518175
    - Use 'NetworkManager' not 'Network Manager' for consistency, Connor Imes
      LP: #518107
    - Update to troubleshooting mobile devices, Connor Imes, LP: #453459
    - Adjusted description of NetworkManager applet icons, Connor Imes
      LP: #440826
    - Additions to VPN section of connecting guide, Alex Wardle, LP: #452647
    - Expanded on using config files for vpn connections, Connor Imes
    - Command line substitution for Services utility which is not in Karmic or
      Lucid, Connor Imes, LP: #518460
    - Structural and language changes + updates for UI changes, Phil Bull
  * Musicvideophotos:
    - Added section for recording and editing video, Book 'em Dano, LP: #367569
  * Newtoubuntu:
    - Complete rewrite, Matthew East
  * Printing:
    - Simple Scan replaced xsane for scanning documents, Alex Wardle, LP: #546193
  * Serverguide:
    - Rename link to serverguide in advanced-topics.xml, Gilbert
      Mendoza, LP: #505708
    - Use distro-short-codename variable for vmbuilder documentation in
      serverguide rather than static version example, Connor Imes,. LP: #509653
    - Small fixes to security chapter, Connor Imes, LP: #510703
    - Small fixes from Nathan Handler, LP: #507624
    - Configuration change for OpenLDAP, Connor Imes, LP: #511090
    - Refresh of network-config section, Gilbert Mendoza, LP: #506800
    - Update manpage links to use distro-short-codename, Connor Imes
    - Changed OpenLDAP replication to use single Provider/Consumer configuration,
      Adam Sommer
    - Removed grub-password-security section - it does not apply to Grub2,
      Gilbert Mendoza, LP: #384148
    - Refere...

Read more...

Changed in ubuntu-docs (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers