SRU: Bridging documentation in the JeOS VMBuilder documentation is wrong

Bug #307582 reported by Nick Barcet
14
Affects Status Importance Assigned to Milestone
ubuntu-docs (Ubuntu)
Fix Released
Undecided
Ubuntu Documentation Committers
Intrepid
Won't Fix
Undecided
Unassigned

Bug Description

Binary package hint: ubuntu-docs

Hello, I think an SRU is badly needed in the sevrer guide at https://help.ubuntu.com/8.10/serverguide/C/jeos-and-vmbuilder.html where

     <interface type='bridge'>
       <source network='br0'/>
     </interface>

Should be replaced by

    <interface type='bridge'>
      <source bridge='br0'/>
    </interface>

Related branches

Revision history for this message
Duane Hinnen (duanedesign) wrote :

assigned to ubuntu websites.

Changed in ubuntu-docs:
assignee: nobody → ubuntu-websites
Changed in ubuntu-docs:
assignee: ubuntu-websites → nobody
Revision history for this message
Jonathan Jesse (jjesse) wrote : Re: [Bug 307582] Re: SRU: Bridging documentation in the JeOS VMBuilder documentation is wrong

Do we do SRU's for the server guide? If this is fixed how do we go about
doing SRUs for this as it is/shold be translated?

jOnahan

On 12/12/08, duanedesign <email address hidden> wrote:
>
> ** Changed in: ubuntu-docs (Ubuntu)
> Assignee: Jamie (ubuntu-websites) => (unassigned)
>
> --
> SRU: Bridging documentation in the JeOS VMBuilder documentation is wrong
> https://bugs.launchpad.net/bugs/307582
> You received this bug notification because you are a member of Ubuntu
> Documentation Committers, which is subscribed to ubuntu-docs in ubuntu.
>

Revision history for this message
Adam Sommer (asommer) wrote :

I think we can do SRUs for the server guide, but I can't remember ever actually doing one :-). Anyway, following the SRU wiki page:

1) The impact of the bug is that the instructions in the Server Guide won't work, causing confusion and wasted time for the user.

2) A fix has been committed to revision 132 of the lp:ubuntu-doc branch.

3) A patch for the ubuntu-serverguide package is attached.

4) To reproduce the bug follow the current instructions, and your VM won't be able to connect to the network using a bridge interface. Change the XML in VMBuilder/plugins/libvirt/templates/libvirtxml.tmpl and the VM should connect fine.

5) There should be no regression potential, and since the fix is an XML configuration file there should be no need to re-translate the package. At least as I understand what is and what is not translated.

I don't think I can upload a fixed package to release-proposed, or at least I have never done so. If someone else can help with the step 4 of the SRU process it would be appreciated.

Thanks,
Adam

Revision history for this message
Martin Pitt (pitti) wrote :

It feels a bit weird to go through a full SRU sponsoring/testing/verification cycle just for this. Maybe there are more similar fixes which should be backported, too? If not, I'm okay with the debdiff, if anyone wants to sponsor it.

Changed in ubuntu-docs:
status: New → Fix Committed
Martin Pitt (pitti)
Changed in ubuntu-docs:
assignee: nobody → ubuntu-core-doc
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-docs - 9.04.2

---------------
ubuntu-docs (9.04.2) jaunty; urgency=low

  * Various serverguide fixes:
    - Grammar error (LP: #203829) - Dean Sas
    - Fix mailman dependencies (LP: #291772) - Morten Siebuhr
    - CVS installation error (LP: #298605) - Thomas M
    - Postfox installation error (LP: #306289) - Adam Sommer
    - SSH update (LP: #311900) - Dean Sas
    - unzoo replaced by zoo (LP: #312506)
    - Samba instructions update (LP: #313232) - Adam Sommer
    - Clearer SSL instructions (LP: #314951) - Adam Sommer
    - LDAP error (LP: #319179) - Adam Sommer
    - MoinMoin installation fix (LP: #320840) - Adam Sommer
    - Postfix ssl improvements (LP: #323203) - Adam Sommer
    - Ebox instructions error (LP: #324399) - Dean Sas
    - Typo in openssh section (LP: #325828) - Dean Sas
    - Typo in samba section (LP: #285484) - Nick Ellery
    - SSHD fix (LP: #295279) - Adam Sommer
    - Jeos fix (LP: #307582) - Adam Sommer
    - Remove reference to ebox-all package (LP: #322367) - Adam Sommer

  * Typo in "switching from windows" (LP: #309735)
  * Broken link in "programming" (LP: #310081) - Jonathan Jesse
  * lsb_release issue in "basic commands" (LP: #310713) - Thomas M
  * Updating logout instructions (LP: #327060) - Dean Sas
  * Updating all documents to use apt-url for installation instructions
  * Refreshing pot files for Rosetta
  * Recompress *.png files with 'advpng -z -4 file.png' to save space - Sahak Petrosyan
  * Improve instructions on pasting commands (LP: #185892) - Martin Mai
  * Rewrite of networking instructions (LP: #298513, LP: #321308, LP: #314680, LP: #321179) - Dougie Richardson
  * Amend punctuation of about-ubuntu (LP: #275592) - Dougie Richardson
  * Documentation for automatic login (LP: #290467) - Dougie Richardson

 -- Matthew East <email address hidden> Sun, 15 Feb 2009 11:50:28 +0000

Changed in ubuntu-docs:
status: Fix Committed → Fix Released
Martin Pitt (pitti)
Changed in ubuntu-docs (Ubuntu Intrepid):
status: New → Won't Fix
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers