Permissions: read-only gives write access to shared directory

Bug #281702 reported by ZhongHan Cai on 2008-10-11
4
Affects Status Importance Assigned to Milestone
ubuntu-docs (Ubuntu)
Low
Connor Imes

Bug Description

Binary package hint: ubuntu-docs

 Located in serverguide/C/windows-networking.xml:179(para)

<emphasis>read only:</emphasis> gives write access to the shared directory.

Self-conflicting permission description.

Jiri Bajer (sarimak) wrote :

I wasn't able to reproduce this on Ubuntu 8.04.1:

$ cat /usr/share/gnome/help/serverguide/C/windows-networking.xml | grep "read-only"
to give <emphasis role="italic">read-only</emphasis> permissions to the group of users known as <emphasis role="italic">planning</emphasis>,

$ uname -a
Linux sarim-eee 2.6.24-21-eeepc #1 SMP Thu Aug 7 22:18:05 MDT 2008 i686 GNU/Linux

$ dpkg -l ubuntu-docs | grep ii
ii ubuntu-docs 8.04.2~hardy The Ubuntu Documentation Project

Could you please add more background?
# cat /etc/issue
# dpkg -l ubuntu-docs | grep ii
# cat -n /usr/share/gnome/help/serverguide/C/windows-networking.xml | grep "read-only"

This would help us to streamline why I'm not able to reproduce the issue you are hitting. Thanks!

Changed in ubuntu-docs:
status: New → Incomplete
ZhongHan Cai (caizhonghan) wrote :

Refer to highlighted portion in screenshot.

Connor Imes (ckimes) wrote :

If you look above in the example it has "read only = no" which is where the confusion comes from. Let's re-word that a bit.

Changed in ubuntu-docs (Ubuntu):
assignee: nobody → rocket2dmn
importance: Undecided → Low
status: Incomplete → In Progress
Connor Imes (ckimes) wrote :

Attached is a proposed diff for ubuntu-doc/serverguide/C/windows-networking.xml
This is for the development version (Karmic) since Jaunty is now in String Freeze.

Changed in ubuntu-docs (Ubuntu):
status: In Progress → Triaged
Matthew East (mdke) on 2009-04-18
tags: added: patch
Matthew East (mdke) wrote :

Fix pushed to ubuntu-doc/karmic branch, many thanks Connor.

Changed in ubuntu-docs (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-docs - 9.10.2

---------------
ubuntu-docs (9.10.2) karmic; urgency=low

  * General:
    - fix menu entry for gparted; patch from Artur Szymanski, LP: #371851
    - a few corrections to use US not UK spelling, patch from Nathan Handler
    - remove unnecessary use of alt+f2 to start apps available from the menu, Dean Sas
  * Hardware:
    - fix instructions to lock screen with new FUSA applet, patch from Artur Szymanski, LP: #371930
  * Add-applications:
    - new section on PPA, patch from Nathan Handler
  * Musicvideophotos:
    - generalise photo import instructions, from Stephanie Mardell
    - update section on listening to online audio streams is outdated, patch from Shane Fagan
    - Rhythmbox has a tag editor, patch from Shane Fagan
  * Keeping-safe:
    - fix link to removing programs, patch from Artur Szymanski
  * Internet:
    - document easiest way to change preferred email client, Dougie Richardson, LP: #356894
    - java is no longer installed by ubuntu-restricted-extras, Dean Sas, LP: #366039
  * Serverguide:
    - Clarify read only explanation in samba section, patch from Connor Imes, LP: #281702
    - Patch by Joel Goguen adding note about restarting after joining a domain, LP: #352934.
    - Patch by Nathan Handler to remove information about dhcdbd that is no longer needed, LP: #373867.
    - Merge from Connor Imes: 2009-05-06 Fix bad flag in useradd command, LP: #371730
  * Games:
    - remove confusing lines from supertux instructions, patch from Shane Fagan, LP: #346892

 -- Matthew East <email address hidden> Sun, 17 May 2009 09:45:19 +0100

Changed in ubuntu-docs (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers