In Yelp links dead

Bug #231367 reported by ptitange131 on 2008-05-17
24
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-docs (Ubuntu)
Medium
Unassigned
Nominated for Karmic by smo
Hardy
Undecided
Unassigned

Bug Description

Binary package hint: yelp

In Yelp (Aide)

Link from <developpement>(Développement) to <learn programing>(Apprendre à Programmer) not work ;
Link from <learn programing>(Apprendre à Programmer) to <learn programing>(Apprendre à Programmer) not work ;

Uname :
Linux ptitange131-desktop 2.6.24-16-generic #1 SMP Thu Apr 10 12:47:45 UTC 2008 x86_64 GNU/Linux

 lsb_release :
Distributor ID: Ubuntu
Description: Ubuntu 8.04
Release: 8.04
Codename: hardy

Sorry for english translation ...
A french user !!!
thanks

ProblemType: Bug
Architecture: amd64
Date: Sat May 17 14:15:50 2008
DistroRelease: Ubuntu 8.04
ExecutablePath: /usr/bin/yelp
NonfreeKernelModules: nvidia
Package: yelp 2.22.1-0ubuntu2
PackageArchitecture: amd64
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
SourcePackage: yelp
Uname: Linux 2.6.24-16-generic x86_64

ptitange131 (ptitange13-1) wrote :
Nick Ellery (nick.ellery) wrote :

Is this also a duplicate of Bug 231228?

Phil Bull (philbull) wrote :

Confirmed, ubuntu-docs 8.04.2~hardy.

Here are the steps to reproduce (it's not a duplicate of 231228, it seems):

 1. Click System -> Help and Support
 1. Click Advanced Topics -> Writing Your Own Programs
 1. Click "Learning how to program" (either on the page itself or in the sidebar)

The title of the Yelp window changes to "Loading...", but the page never loads. If you then click on "C and C++", Yelp crashes with the following error:

    **
    ** Yelp:ERROR:(yelp-document.c:275):yelp_document_cancel_page: assertion failed: (document != NULL && YELP_IS_DOCUMENT (document))
    Aborted

You can get to the "Learning how to program" page by first clicking "C and C++", and then clicking "Learning how to program" in the sidebar.

Two other links exhibit the same behaviour:

 * Other programming languages
 * Development Tools

Changed in ubuntu-docs:
importance: Undecided → Medium
status: New → Confirmed
Phil Bull (philbull) wrote :

The problem was that the sections I mentioned above didn't have "id" attributes, so Yelp trips up on them.

Fix committed to hardy branch, rev. 3805.

Changed in ubuntu-docs:
status: Confirmed → Fix Committed
Matthew East (mdke) wrote :

This is fixed in intrepid.

Changed in ubuntu-docs:
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Accepted into hardy-proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in ubuntu-docs:
status: New → Fix Committed
Tormod Volden (tormodvolden) wrote :

I can confirm that ubuntu-docs 8.06.1 (from hardy-proposed) works - the link "Learning how to program" works fine, and it doesn't crash on "C and C++".

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-docs - 8.06.1

---------------
ubuntu-docs (8.06.1) hardy-proposed; urgency=low

  * Updates to Firefox homepage for Catalan, Korean (LP: #153124, LP: #220889)
  * Text and link fixes from Phil Bull (LP: #222987, LP: #231367)
  * SRU bug: (LP: #243823)

 -- Matthew East <email address hidden> Sun, 22 Jun 2008 11:10:57 +0100

Changed in ubuntu-docs:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers