Ubuntu

Package internet in ubuntu-docs: "press return" instead of "press enter"

Reported by Balaam's Miracle on 2008-04-06
6
Affects Status Importance Assigned to Milestone
ubuntu-docs (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: ubuntu-docs

In several places in the package "internet", part of ubuntu-docs, the documentation directs people to press the Return key.
However, most PC keyboards have no key called Return, which can be confusing for many people. Instead, the documentation should mention "Enter" rather than "Return".

Here is one instance:
https://translations.launchpad.net/ubuntu/hardy/+source/ubuntu-docs/+pots/internet/nl/289/+translate

Related branches

Changed in ubuntu-docs:
assignee: nobody → ubuntu-doc

Please don't assign the whole Documentation Team to a bug. If you are working of fixing it, then assign it to yourself - otherwise assign the person working on it.

Changed in ubuntu-docs:
assignee: ubuntu-doc → nobody
Phil Bull (philbull) wrote :

Thanks for reporting this bug. "Return" seems to be the standard name for this key - not all keyboards have an "Enter" key (the one on the numeric keypad), but many do call the Return key "Enter". As such, I don't think that the term should be changed.

See here for more information:

http://en.wikipedia.org/wiki/Return_key

Changed in ubuntu-docs:
status: New → Incomplete

Being a pack-rat, i have several keyboards at home, both working as well as broken.
I just did a count and i have ten keyboards at home, including the two that are currently in use, but not counting the Mac keyboards.
On all of the Mac keyboards that i have (from Mac128+ and up) and on most of the (8-bit) home computers, that key *is* called Return.
However, on nine out of my ten PC keyboards, the big key (to call it that) has "Enter" printed on it, but never "Return". One of the keyboards just has an arrow printed on the key.

Therefore i submit that calling a key "Return" when it usually has "Enter" printed on it, is confusing for users. Especially to new users who may never have heard of such a thing as a "Return" key.

Actually of the 20+ machines in this office, there are none with words and all with a symbol that coannot be replicated in unicode. Actually, historically return (as in carriage return) is as acceptable.

I say this is a really unneccesary change as there is no other key that it could be confused with.

Sense Egbert Hofstede (sense) wrote :

I've seen several keyboards in my life, but never with return on it. Always with Enter. So I suggest to keep it this way. If you're really think this can make things hard to understand for people you could always make the word enter a tooltip. ;)

Phil Bull (philbull) wrote :

I think this issue is significant enough to merit an entry in the Style Guide. I'll open this up to the ubuntu-docs mailing list and report back.

A question to Phil Bull:
I saw there was a bit of a discussion on the ML after your initial post and it looks like most respondents would prefer "Enter" over "Return".
Would this suffice to justify a change in the docs?

Phil Bull (philbull) wrote :

Hi,

Yep, it looks like people would prefer to move over to "Enter", so I've confirmed the bug.

Changed in ubuntu-docs:
importance: Undecided → Wishlist
status: Incomplete → Confirmed
Matthew East (mdke) wrote :

Phil - what was Gnome's view on this?

Phil Bull (philbull) wrote :

The last I heard, Milo had spoken to Shaun over at GNOME and it was planned as a topic for word-a-day.

Phil Bull (philbull) wrote :

I just checked the GNOME mailing list archives, and there's no sign of it in there. They must never have gotten around to it.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-docs - 9.04.1

---------------
ubuntu-docs (9.04.1) jaunty; urgency=low

  * Images should not be executable (LP: #206371) - Sahak Petrosyan
  * Couple of typos (LP: #282358, LP: #266997) - Sahak Petrosyan
  * ubuntu-restricted-extras has java6 (LP: #288623) - Dean Sas
  * Permit building html for other languages in Makefile - Mitsuya Shibata
  * Use the same background image as Ubuntu website (LP: #305760)
  * Make search available for users without javascript - Dustin Kirkland
  * Various content improvements - Phil Bull
  * Use "Enter", not "Return" - Joel Goguen (LP: #213104)

 -- Matthew East <email address hidden> Thu, 11 Dec 2008 12:47:51 +0000

Changed in ubuntu-docs:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers