New icon still not present on Ubuntu Desktop Guide

Bug #1968757 reported by Marcos Alano
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Online publishing of the Ubuntu documentation
Fix Released
Medium
Doug Smythies
ubuntu-docs (Ubuntu)
Fix Released
Medium
Gunnar Hjalmarsson
Jammy
Fix Released
Medium
Gunnar Hjalmarsson

Bug Description

[Impact]

Late (very late) in the jammy cycle I uploaded a new version of ubuntu-logo.png, but overlooked the need to use transparency to make it look good if a dark theme is enabled when browsing the desktop guide using yelp.

This proposed upload includes an improved ubuntu-logo.png. There is also a new header_logo.png file, but the latter is for help.ubuntu.com only and not included in the .deb file. Both the new .png files are already in use at <https://help.ubuntu.com/stable/ubuntu-help>, so with this package tweak we become in sync again.

[Test Plan]

On an updated Ubuntu 22.04:

 * Install ubuntu-docs from jammy-proposed.

 * Select dark style in Settings -> Appearance.

 * Open yelp, and confirm that the logo to the left of the title does not
   have any white vertical bars.

[Where problems could occur]

Can't really come up with anything. The new .png files look good on the web site. As regards the regression risk, the files are not used by any other package but ubuntu-docs.

[Other Info]

As regards the coming development release, the same changes have been pushed to the git repo:
https://git.launchpad.net/~ubuntu-core-doc/ubuntu/+source/ubuntu-docs/log/?h=master

[Original description]

When I press F1 to open Yelp and get help I still see the old Ubuntu icon, not the new one as the rest of the system

Revision history for this message
Marcos Alano (mhalano) wrote :

I attached a screenshot with the old icon

Revision history for this message
Gunnar Hjalmarsson (gunnarhj) wrote :

Thanks for your report!

Unfortunately the new rectangular logo won't fit in all places where the icon is used in the Ubuntu Desktop Guide. So we need to figure out a way to handle that, but it will happen only for the 22.10 release.

Changed in ubuntu-docs (Ubuntu):
importance: Undecided → Medium
milestone: none → later
status: New → Confirmed
Revision history for this message
Doug Smythies (dsmythies) wrote (last edit ):

Just for clarity, is the attached a representative example of what is being talked about?

Revision history for this message
Marcos Alano (mhalano) wrote :

@dsmythies Sorry, bad English. It should be an example of what I'm talking about, not asking for. :)

Revision history for this message
Gunnar Hjalmarsson (gunnarhj) wrote :

Hmm.. Doug's example is not the new one AFAICT. The attached one, which is located at /usr/share/pixmaps on the hard disk, is.

See also https://ubuntu.com/blog/a-new-look-for-the-circle-of-friends

Revision history for this message
Gunnar Hjalmarsson (gunnarhj) wrote :
Revision history for this message
Doug Smythies (dsmythies) wrote :

Okay, thanks Gunnar for pointing me in the right direction. I did not know. Something like the attached would be all we could do quickly. While not of the proper rectangle dimensions, it is a square (and probably a few pixels too big), it at least would have the new look for the circle of friends part with the asymmetric spacing.

Revision history for this message
Gunnar Hjalmarsson (gunnarhj) wrote :

Right, something like that is what I have in mind too. But I think we should first ask if that way to use it is allowed.

And note that the current logo is used both when browsing the guide through yelp and on the web version. We need to make sure it looks ok on both places.

Revision history for this message
Doug Smythies (dsmythies) wrote :

I observe that even at ubuntu.com the favicon.ico has not changed. What we use is based on the favicon.ico.

Revision history for this message
Doug Smythies (dsmythies) wrote :

Just as a test, I created a 32X32 pixel rectangle logo example. This screen shot is rather zoomed in. It doesn't look very good on a normal screen.

Regardless, we would need master files to replace what we are using now. That would be a 32X32 pixel PNG file and a favicon.ico file for the HTML publications.

I do not know if other files are needed for the yelp version.

Revision history for this message
Gunnar Hjalmarsson (gunnarhj) wrote :

Hi Doug!

I'm tempted to ask for ubuntu-logo.png to be changed before release, even if it's too late (we are in Final Freeze).

As regards the web site, we should also change the logo in the header of all the pages. But that, and favicon.ico, are not technically tied to the release, and thus not as urgent.

Only ubuntu-logo.png affects the yelp version.

description: updated
summary: - New icon still not present on Ubuntu Desktop Guide
+ [UIFe] New icon still not present on Ubuntu Desktop Guide
Changed in ubuntu-docs (Ubuntu):
milestone: later → none
assignee: nobody → Gunnar Hjalmarsson (gunnarhj)
Revision history for this message
Launchpad Janitor (janitor) wrote : Re: [UIFe] New icon still not present on Ubuntu Desktop Guide

This bug was fixed in the package ubuntu-docs - 22.04.4

---------------
ubuntu-docs (22.04.4) jammy; urgency=medium

  * ubuntu-help/C/figures/ubuntu-logo.png:
    - Update to the new Circle of Friends logo (LP: #1968757). Thanks
      to Doug Smythies!

 -- Gunnar Hjalmarsson <email address hidden> Sat, 16 Apr 2022 02:26:21 +0200

Changed in ubuntu-docs (Ubuntu):
status: Confirmed → Fix Released
Revision history for this message
Marcos Alano (mhalano) wrote :

Wouldn't be better to use transparency for the lateral bars instead of white?

Revision history for this message
Gunnar Hjalmarsson (gunnarhj) wrote :

Ouch! Yes, indeed it would. I didn't think of dark themes.

We'll change that as an update soon after the release. (I'm disinclined to ask for yet another freeze exception.)

Changed in ubuntu-docs (Ubuntu):
status: Fix Released → Triaged
assignee: Gunnar Hjalmarsson (gunnarhj) → nobody
Revision history for this message
Doug Smythies (dsmythies) wrote :

Hi Gunnar,

For the HTML banner part: Yes, and I hadn't even noticed that it would need updating also. So we would also need an official version of it.

For the 32X32 PNG file: So sorry. The one I created was just for a test, and never intended to be the official version. I actually thought/hoped it would convince people that the rectangle is not a good idea at these resolutions. One can even observe the white bars against the faint background texture (RGB: 244,244,244) on the html pages.

Revision history for this message
Gunnar Hjalmarsson (gunnarhj) wrote (last edit ):

@Doug: Don't apologize. It's my fault, of course. I shouldn't have rushed.

But with that said, I think the image is useful. Any chance you can add transparency to it as Marcos suggested?

Or would you prefer to ask for permission to change it to a square?

Revision history for this message
Marcos Alano (mhalano) wrote :

I did the transparency myself in GIMP. I don't have for sure the proportion is correct, but the apparence is pretty cool.

Revision history for this message
Marcos Alano (mhalano) wrote :

I attached the icon I made. Someone could check if I didn't cut too much? There was a light orange bar between the white and the orange I made transparent, but I don't know if I should

Revision history for this message
Doug Smythies (dsmythies) wrote (last edit ):

O.K. I am attaching another 32X32 logo with transparent side bands.
This is not official and for test purposes only.

Yes, Marcos, I believe your version ended up too narrow. The issue is that the earlier one I created was re-sampled from a 793X514 pixel original, and: 1, the bicubic filter introduced "ringing" artifacts; 2, it really needed to be 21.5 pixels wide X 32 high.

I made this one centered with 5 pixels on each side band and manually eliminated the edge "ringing". There might still be filter artifacts, I don't know. The active area is 32X22.

Note: I did not attempt to minimize the file size. That would be the next step.

Revision history for this message
Doug Smythies (dsmythies) wrote (last edit ):

Changing the html pages header logo is going to be a little more work. It'll have to have more pixels vertical so as to include the rectangle. But then perhaps not because the background is RBG: 221.72.20 anyway, so nobody will be able to see its borders. The word "documentation" is truncated slightly at the bottom.

References: The master .css file and
https://help.ubuntu.com/img/header_logo.png

The PNG file is global, so we will need to use a new name to distinguish 22.04 from previous releases.

Revision history for this message
Doug Smythies (dsmythies) wrote :

I did a hack job to make a new header_logo.png file. I used the same foot print of 292X27 pixels, which doesn't fit the entire string, so it'll have to be bigger. The background has some texture, so one can see the outline of the circle of friends part.

The png file isn't global, after all. I was mistaken.

Revision history for this message
Gunnar Hjalmarsson (gunnarhj) wrote :

I found this:

/usr/share/icons/Humanity/places/48/start-here.svg

Resized it to 32x32 and exported as .png (attached).

The circle itself is slightly larger, which I think makes it look better. And we wouldn't need to worry about doing anything which is not allowed.

Revision history for this message
Doug Smythies (dsmythies) wrote :

This is the hack job PNG file I created for the test. Obviously the box will have to be more X direction pixels, which shouldn't be an issue.

Revision history for this message
Doug Smythies (dsmythies) wrote :

An issue with the various reddish background banners is that everyone seems to use something a little different for RGB. Examples: 233/84/20; 220/70/29; 208/86/48; 221/72/20 and so any logo that has a visible red area around the white circle of friends part has a visible transition against such a background. What is needed is a master 32X32 new circle of friends part, with transparent background for these applications (help.ubuntu.com, ubuntu forums, ask ubuntu, ...)

Anyway, I think we have a good enough solution for now. It should go live on help.ubuntu.com in about 9 hours.

We'll wait for favicon.ico until the main site changes it, and then just steal it.

Revision history for this message
Doug Smythies (dsmythies) wrote :
Changed in help.ubuntu.com:
status: New → In Progress
Changed in help.ubuntu.com:
importance: Undecided → Medium
assignee: nobody → Doug Smythies (dsmythies)
Changed in help.ubuntu.com:
status: In Progress → Fix Committed
Revision history for this message
Gunnar Hjalmarsson (gunnarhj) wrote :

Thanks Doug, that's a minor improvement. I followed up in the ubuntu-docs and helpwiki-light-moin-theme repos.

Changed in help.ubuntu.com:
status: Fix Committed → Fix Released
Revision history for this message
Adolfo Jayme Barrientos (fitojb) wrote (last edit ):

Please refrain from creating brand extension logos (e.g. “Ubuntu Documentation”) until guidance is published on design.ubuntu.com. https://github.com/canonical-web-and-design/design.ubuntu.com/issues/228

Revision history for this message
Gunnar Hjalmarsson (gunnarhj) wrote :

@Adolfo: We used the previous logo in the same way for 10+ years, so we did not invent anything new.

With that said, it's good that you asked for guidelines.

description: updated
summary: - [UIFe] New icon still not present on Ubuntu Desktop Guide
+ New icon still not present on Ubuntu Desktop Guide
Changed in ubuntu-docs (Ubuntu Jammy):
assignee: nobody → Gunnar Hjalmarsson (gunnarhj)
status: Triaged → In Progress
Revision history for this message
Steve Langasek (vorlon) wrote : Please test proposed package

Hello Marcos, or anyone else affected,

Accepted ubuntu-docs into jammy-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ubuntu-docs/22.04.5 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-jammy to verification-done-jammy. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-jammy. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in ubuntu-docs (Ubuntu Jammy):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-jammy
Revision history for this message
Marcos Alano (mhalano) wrote :

I tested with 22.04.5 and works flawlessly.

tags: added: verification-done-jammy
removed: verification-needed-jammy
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-docs - 22.04.5

---------------
ubuntu-docs (22.04.5) jammy; urgency=medium

  * html/img/header_logo.png, html/ubuntu.xsl:
    - Update to new logo in the header of the HTML pages
  * ubuntu-help/C/figures/ubuntu-logo.png:
    - Improvements, e.g. use transparency for dark themes (LP: #1968757)

 -- Gunnar Hjalmarsson <email address hidden> Fri, 22 Apr 2022 11:36:24 +0200

Changed in ubuntu-docs (Ubuntu):
status: Fix Committed → Fix Released
Changed in ubuntu-docs (Ubuntu Jammy):
status: Fix Committed → Fix Released
Revision history for this message
Brian Murray (brian-murray) wrote : Update Released

The verification of the Stable Release Update for ubuntu-docs has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.