Report a problem in Ubuntu page: Step 1: "nameofprogram" unclear

Bug #1952538 reported by Zian
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-docs (Ubuntu)
Fix Released
Medium
Gunnar Hjalmarsson

Bug Description

OS Name: Ubuntu 20.04.3 LTS

Steps to Reproduce:
1. Experience a problem with the Software Updater.
2. Go to the "Report a problem in Ubuntu" page using the Ubuntu Desktop Guide.
3. Read step 1 ("Type Alt+F2 and type ubuntu-bug nameofprogram")
4. Type ALT+F2 and "ubuntu-bug Software Updater" and press Enter.

Expected Result:
A way to provide feedback about the Software Updater.

Actual Result:
The little dialog goes away and nothing else happens.

Revision history for this message
Zian (zian-choy) wrote :

Screenshot of Software Updater that shows the program's name.

description: updated
Revision history for this message
Zian (zian-choy) wrote :

apport.log

ERROR: apport (pid 3992) Sat Nov 27 13:20:49 2021: called for pid 3988, signal 5, core limit 0, dump mode 1
ERROR: apport (pid 3992) Sat Nov 27 13:20:49 2021: executable: /usr/libexec/gnome-control-center-print-renderer (command line "/usr/libexec/gnome-control-center-print-renderer")
ERROR: apport (pid 3992) Sat Nov 27 13:20:49 2021: debug: session gdbus call: (true,)

ERROR: apport (pid 3992) Sat Nov 27 13:20:50 2021: wrote report /var/crash/_usr_libexec_gnome-control-center-print-renderer.1000.crash

Revision history for this message
Zian (zian-choy) wrote :

ls

total 3436
drwxrwsrwt 2 root whoopsie 4096 Nov 27 13:21 .
drwxr-xr-x 14 root root 4096 Feb 3 2020 ..
-rw-r----- 1 zian whoopsie 3502467 Nov 27 13:21 _usr_libexec_gnome-control-center-print-renderer.1000.crash
-rw-r--r-- 1 zian whoopsie 0 Nov 27 13:21 _usr_libexec_gnome-control-center-print-renderer.1000.upload
-rw------- 1 whoopsie whoopsie 37 Nov 27 13:21 _usr_libexec_gnome-control-center-print-renderer.1000.uploaded

description: updated
description: updated
Revision history for this message
Gunnar Hjalmarsson (gunnarhj) wrote :

Thanks for your report.

I agree that "nameofprogram" is ambiguous. Would "PACKAGENAME" be better? I.e. in your case:

ubuntu-bug update-manager

Changed in ubuntu-docs (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
Revision history for this message
Gunnar Hjalmarsson (gunnarhj) wrote :
Revision history for this message
Gunnar Hjalmarsson (gunnarhj) wrote :
Changed in ubuntu-docs (Ubuntu):
assignee: nobody → Gunnar Hjalmarsson (gunnarhj)
status: Triaged → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-docs - 22.04.1

---------------
ubuntu-docs (22.04.1) jammy; urgency=medium

  * Bump version to 22.04 / jammy
  * report-ubuntu-bug.page:
    - Replace "nameofprogram" with "<package name>" (LP: #1952538)
  * Updated ubuntu-help.pot
  * ubuntu-help/Makefile.am, html/Makefile:
    - Build Korean - present in gnome-user-docs 41.1

 -- Gunnar Hjalmarsson <email address hidden> Sun, 05 Dec 2021 15:56:43 +0100

Changed in ubuntu-docs (Ubuntu):
status: Fix Committed → Fix Released
Revision history for this message
Zian (zian-choy) wrote :

Thanks for tweaking the language to reflect how ubuntu-bug works today.

I think "program" is a better word because my hunch is that if you asked a random set of people who use PCs what a "program" is and then repeated the experiment with the word "package", you'll get more puzzled looks the second time around.

The Table of Contents at https://help.ubuntu.com/community/ReportingBugs uses the two words almost interchangeably. The following phrases are used:
- desktop application (once)
- package (thrice)
- program (twice)

How difficult would it be for the Ubuntu bug reporter (client-side application) to do the steps in section 6 of the ReportingBugs wiki page? If the computer can figure out the right package name to use from the user input whether the user types the package name or program name, then there will be one less obstacle to learning about a problem.

Can the Apport backend do the tedious work in section 6 of the wiki article? If possible, then the enhancement would fit right in with their goal of making "the user side ... be extremely simple and as unannoying as possible."

The documentation already tells people that when all else fails, they should just type "ubuntu-bug". Seems that if we could include only that phrase in the documentation instead of both "ubuntu-bug packagename" and "ubuntu-bug", then it'd be an improvement for normal users.

Revision history for this message
Gunnar Hjalmarsson (gunnarhj) wrote :

Thanks for your extended thoughts, Zian. However, that's a discussion far beyond the wording of the Ubuntu Desktop Guide and hence off topic on this bug report.

I'm not quite sure, but I think the ubuntu-quality mailing list may be a proper place to raise that discussion.

https://lists.ubuntu.com/mailman/listinfo/ubuntu-quality

If that proves to not be the best place either, they will hopefully point you in the right direction.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers