Add #ubuntu as 'get more help' resource in the docs

Bug #1827788 reported by lotuspsychje
46
This bug affects 10 people
Affects Status Importance Assigned to Milestone
ubuntu-docs (Ubuntu)
Fix Released
Wishlist
Gunnar Hjalmarsson

Bug Description

Please add a link in the ubuntu-docs to get more help on #ubuntu irc on freenode
as resource to get more help, by webchat or hexchat (installed by default instead of now optional)
so users get a direct way to join to #ubuntu.

This will have multiple benefits:

-get a more active support on #ubuntu
-lighter the work for developers as users will get live help and not forced to file a new bug
when its not really needed
-a more active way to build up communication on the ubuntu community

Thank you

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: ubuntu-docs 18.04.4
ProcVersionSignature: Ubuntu 4.15.0-48.51-generic 4.15.18
Uname: Linux 4.15.0-48-generic x86_64
ApportVersion: 2.20.9-0ubuntu7.6
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Sun May 5 16:48:20 2019
InstallationDate: Installed on 2018-08-17 (261 days ago)
InstallationMedia: Ubuntu 18.04 LTS "Bionic Beaver" - Release amd64 (20180426)
PackageArchitecture: all
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=nl_BE.UTF-8
 SHELL=/bin/bash
SourcePackage: ubuntu-docs
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Revision history for this message
lotuspsychje (lotuspsychje) wrote :
Revision history for this message
C de-Avillez (hggdh2) wrote :

Marking as confirmed/wishlist. The #ubuntu channel in Freenode (and the #lubuntu, #kubuntu, #xubuntu, #ubuntu-mate, #ubuntustudio channels -- there are probably others as well) are quite known as support channels.

Changed in ubuntu-docs (Ubuntu):
importance: Undecided → Wishlist
status: New → Confirmed
Revision history for this message
lotuspsychje (lotuspsychje) wrote :

Confirmed the Xubuntu-docs have the irc support as resource, see screenshot

Revision history for this message
lotuspsychje (lotuspsychje) wrote :

Confirmed the ubuntu mate docs have irc support as resource, see the screenshot

Revision history for this message
lotuspsychje (lotuspsychje) wrote :

Ubuntu-budgie has the same ubuntu-docs as ubuntu-desktop no irc support, see screenshot

Revision history for this message
lotuspsychje (lotuspsychje) wrote :

Confirmed ubuntu-studio help docs have irc support as resource the help icon opens a browser to the manuals, see screenshot

Revision history for this message
lotuspsychje (lotuspsychje) wrote :

Confirmed kubuntu opens a browser from online help and howto irc, see screenshot

Revision history for this message
Gunnar Hjalmarsson (gunnarhj) wrote :

Thanks for your report!

To a very large extent the Ubuntu Desktop Guide consists of pages from GNOME Help. However, as regards the section "Get more help", the GNOME pages are basically replaced with pages which apply better to Ubuntu.

https://help.gnome.org/users/gnome-help/stable/more-help.html

https://help.ubuntu.com/stable/ubuntu-help/more-help.html

I see now that GNOME Help includes a help-irc.html without an equivalent in Ubuntu.

So why is that? Well, there are several support resources available to Ubuntu users, not only #ubuntu. The most important (including IRC/#ubuntu) are mentioned here:

https://www.ubuntu.com/support/community-support

(There is a tiny link to that very page at the top of every https://help.ubuntu.com page, btw.)

So in my opinion, if we are going to address this bug report, we should create a new page which covers all those resources. Maybe a new page with basically just a link to the "Community support" page would suffice.

What do you think?

Revision history for this message
Erich Eickmeyer  (eeickmeyer) wrote :

RE: Comment #6, Ubuntu Studio also has the website with an IRC link.

Revision history for this message
Erich Eickmeyer  (eeickmeyer) wrote :

RE: Comment #6, Ubuntu Studio also has a direct link to IRC in the menu.

Revision history for this message
lotuspsychje (lotuspsychje) wrote :

@8 Gunnar its a great idea to forward that community page, as long as its linked from the ubuntu-docs
so users can find this easy

Revision history for this message
Gunnar Hjalmarsson (gunnarhj) wrote :

I have committed a tiny "Community support" page, which I think can be considered to address this bug:

https://bazaar.launchpad.net/~ubuntu-core-doc/ubuntu-docs/trunk/revision/72/ubuntu-help/C/community-support.page

The page will be added to the "Get more help" section of the desktop guide.

Changed in ubuntu-docs (Ubuntu):
assignee: nobody → Gunnar Hjalmarsson (gunnarhj)
status: Confirmed → Fix Committed
Revision history for this message
lotuspsychje (lotuspsychje) wrote :

@gunnarhj will the fix enter 19.10 or be backported to older ubuntu releases aswell?
just to know what to look for

Revision history for this message
Gunnar Hjalmarsson (gunnarhj) wrote :

It will enter 19.10. Not important enough to struggle with translations to make a backport possible.

But once 19.10 has been released, the URL https://help.ubuntu.com/stable/ubuntu-help/more-help.html will point to a page which includes a link to the new page.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-docs - 19.10.1

---------------
ubuntu-docs (19.10.1) eoan; urgency=medium

  * Bump version to 19.10 / eoan
  * community-support.page:
    - New page to point to support resources (LP: #1827788).
  * debian/control.in, debian/control:
    - Bumped debhelper version to >= 11
    - Corrected Vcs-Bzr URL
    - Bumped Standards-Version to 4.3.0
    - Dropped Breaks/Replaces for gnome-user-guide (added before 18.04
      LTS)
    - Improved the package description
  * debian/rules:
    - Don't run dh_translations
  * html/Makefile:
    - Minor tweaks
  * html/ubuntu.xsl:
    - Adjustments due to upgraded yelp-xsl
  * Updated ubuntu-help.pot
  * net-install-flash.page:
    - Added section for Firefox or Chromium as snap
  * Translations from Launchpad

 -- Gunnar Hjalmarsson <email address hidden> Fri, 28 Jun 2019 17:16:00 +0200

Changed in ubuntu-docs (Ubuntu):
status: Fix Committed → Fix Released
Revision history for this message
lotuspsychje (lotuspsychje) wrote :

Thank you very much for all your work!!
here a screenshot of 19.10 ubuntu-docs patched

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers