DVD instructions are incorrect

Bug #181236 reported by Phil Bull on 2008-01-08
14
Affects Status Importance Assigned to Milestone
ubuntu-docs (Ubuntu)
High
Matthew East

Bug Description

Binary package hint: ubuntu-docs

The instructions for enabling DVD playback in Gutsy are incorrect.

Press System -> Help and Support -> Music, Videos and Photos -> Movies, DVDs and Videos -> Playing DVDs to view the documentation.

 * There is no libdvdplay0 package in the repositories
 * libxine-ffmpeg is required (see bug 128864)

Related branches

Hi,

On Jan 8, 2008 1:21 PM, Phil Bull <email address hidden> wrote:
> * There is no libdvdplay0 package in the repositories
> * libxine-ffmpeg is required (see bug 128864)

Is correct technology at a stage yet where we can recommend totem for
playing dvds?

--
Matthew East
http://www.mdke.org
gnupg pub 1024D/0E6B06FF

Phil Bull (philbull) wrote :

I don't think so - I'm not able to play DVDs through totem on Gutsy, and I can't find anything on the web that says otherwise.

On Jan 9, 2008 12:49 PM, Phil Bull <email address hidden> wrote:
> I don't think so - I'm not able to play DVDs through totem on Gutsy, and
> I can't find anything on the web that says otherwise.

If you have the dvdcss then it has been possible to play DVDs with
gstreamer for several releases - you may be missing the gstreamer
plugins. The problem was that menus are unsupported, I'm not sure
whether that's improved now or not.

http://gstreamer.freedesktop.org/documentation/plugins.html

--
Matthew East
http://www.mdke.org
gnupg pub 1024D/0E6B06FF

Phil Bull (philbull) wrote :

Hmm, I seem to have all the gstreamer plugins (even the multiverse ones) and dvdcss has been installed. When I try to play a DVD in totem-gstreamer, I either get "Totem cannot play this type of media (DVD) because it does not have the appropriate plugins to be able to read from the disc." or, if I use the command "totem dvd://" I just get a blank screen (though playback does seem to commence according to the timeline at the bottom).

What behaviour do you have with your copy of totem?

Qing Gan (qing) on 2008-01-10
Changed in ubuntu-docs:
assignee: nobody → qing
status: New → In Progress
Qing Gan (qing) wrote :

So ... how can I fix it? I have never used the totem before, after I have the gstreamer plugin for mp3, mpeg..., the totem can play the mp3 files, but I can't test if it can play DVDs.

Matthew East (mdke) wrote :

On Jan 9, 2008 6:22 PM, Phil Bull <email address hidden> wrote:
> What behaviour do you have with your copy of totem?

I don't have a working dvd player at the moment so can't test, but my
experience in previous releases has always been the same as that
described on https://help.ubuntu.com/community/RestrictedFormats/PlayingDVDs

--
Matthew East
http://www.mdke.org
gnupg pub 1024D/0E6B06FF

Phil Bull (philbull) wrote :

I've spent a while testing this, and I just can't get totem-gstreamer to play DVDs in a user-friendly way. As such, I'd recommend that we stick with using the gxine method for now - at least users will be able to watch DVDs and get menus/subtitles in a reasonably painless way.

Matthew East (mdke) wrote :

On Jan 11, 2008 6:59 PM, Phil Bull <email address hidden> wrote:
> I've spent a while testing this, and I just can't get totem-gstreamer to
> play DVDs in a user-friendly way. As such, I'd recommend that we stick
> with using the gxine method for now - at least users will be able to
> watch DVDs and get menus/subtitles in a reasonably painless way.

Thanks for your work on that! Sounds totally reasonable.

--
Matthew East
http://www.mdke.org
gnupg pub 1024D/0E6B06FF

Matthew East (mdke) wrote :

Qing - are you still working on this?

Changed in ubuntu-docs:
importance: Undecided → High
milestone: none → ubuntu-8.04-beta
status: In Progress → Confirmed
milestone: ubuntu-8.04-beta → none
Stuart Guest (sguest) wrote :

Hi,

Just wanted to give my feedback on this.

I've got DVDs playing just fine on my Gutsy setup, without installing gxine, libdvdplay0, or libdvdnav4.

I installed libdvdread, and executed the "sudo /usr/share/doc/libdvdread3/install-css.sh" command.

Instead of changing anything in the "Removable drives and Media" section, though, I simply swapped totem-gstreamer with totem-xine, and everything worked just fine, including the use of DVD menus.

Matthew East (mdke) wrote :

I tend to agree with Phil that in general we shouldn't encourage replacing default programs in Ubuntu unless absolutely necessary... but we really need someone with a hardy system and a dvd player who can do a bit of testing and advise us on the simplest way to get DVD support... If "install libdvdread ; sudo /usr/share/doc/libdvdread3/install-css.sh ; install gxine" works, then we should go with it.

Can anyone help?

Ryan Giobbi (ryan-tgbemail) wrote :

On Fri, Mar 14, 2008 at 4:27 AM, Matthew East <email address hidden> wrote:
> I tend to agree with Phil that in general we shouldn't encourage
> replacing default programs in Ubuntu unless absolutely necessary... but
> we really need someone with a hardy system and a dvd player who can do a
> bit of testing and advise us on the simplest way to get DVD support...
> If "install libdvdread ; sudo /usr/share/doc/libdvdread3/install-css.sh
> ; install gxine" works, then we should go with it.
>
> Can anyone help?
>

How does Dell enable DVD playback on their Ubuntu systems?

Dariel Dato-on (odd-rationale) wrote :

Which is the recommended procedure? Install libdvdread3 and "sudo /usr/share/doc/libdvdread3/install-css.sh" or simply install libdvdcss2 from the medibuntu repo?

Or are they the same?

All I needed for DVD play back was xine (totem-xine, kaffeine, etc) and libdvdcss2 from the medibuntu repo.

Phil Bull (philbull) wrote :

I'd tend to avoid totem-xine for the reasons stated above, and it would also be sensible to avoid recommending third-party repositories. I'll look into this later today.

Phil Bull (philbull) wrote :

This is proving annoying to test (gxine has some problem where it crashes X in my vm). I'll do a fresh install of Hardy tonight.

Matthew East (mdke) wrote :

Hi

On Wed, Mar 19, 2008 at 9:15 AM, Phil Bull <email address hidden> wrote:
> This is proving annoying to test (gxine has some problem where it
> crashes X in my vm). I'll do a fresh install of Hardy tonight.

I'm also going to be testing this in the next day or two.

--
Matthew East
http://www.mdke.org
gnupg pub 1024D/0E6B06FF

Matthew East (mdke) wrote :

Ok, I've tested this - the instructions seem to work fine on current hardy (except for the "There is no libdvdplay0 package in the repositories" bit, but that package doesn't seem to be needed).

I'll commit a fix to remove the reference to the missing package shortly.

Changed in ubuntu-docs:
assignee: qing → mdke
status: Confirmed → In Progress
Matthew East (mdke) on 2008-03-20
Changed in ubuntu-docs:
status: In Progress → Fix Committed
Stuart Guest (sguest) wrote :

How did you get gxine to play automatically in Hardy?

Every time I tried, totem-gstreamer wanted to play the DVD instead. The only way I could get gxine to play a DVD was to specifically select gxine from the "Sound and Video" menu.

Matthew East (mdke) wrote :

To be honest, I didn't try to get gxine to play the DVD automatically. I can't see any obvious way to do that - with the previous instructions the System->Preferences->Removable Drives and Media tool was used, but this tool doesn't appear to have a Multimedia tab anymore...

Matthew East (mdke) wrote :

I've chatted to the Ubuntu Gnome maintainer today about this. The way to get gxine to load DVDs automatically is to adjust the settings in Places->Home->Edit->Preferences->Media. It requires a fix for gxine so that it appears in the drop down menu, which should be done soon. I'll document that asap today given the importance of DVD support.

Changed in ubuntu-docs:
status: Fix Committed → Confirmed
Matthew East (mdke) wrote :

I've now reworded the section - http://mdke.org/tmp/DVD.png

Changed in ubuntu-docs:
status: Confirmed → Fix Committed
Stuart Guest (sguest) wrote :

It's great that you've managed to find a way to integrate gxine -- my only real reason for pushing totem-xine over gxine was the integration issue!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-docs - 8.03.3

---------------
ubuntu-docs (8.03.3) hardy; urgency=low

  * New bzr checkout (LP: #181236, LP: #203198, LP: #204163, LP: #204666)
  * String freeze now in effect
  * Refresh pot files

 -- Matthew East <email address hidden> Fri, 21 Mar 2008 14:34:49 +0000

Changed in ubuntu-docs:
status: Fix Committed → Fix Released
Daniel Ellis (danellisuk) wrote :

I have installed Ubuntu 8.04 Beta 1 (plus updates). My system has ubuntu-docs (8.03.4) but it still states to install libdvdplay0.

Matthew East (mdke) wrote :

Daniel - I imagine your system has English (GB) or English (AU) set. We haven't yet refreshed our translations. If you try in the original "C" locale, then you'll see the new instructions.

$ LANG=C yelp

Daniel Ellis (danellisuk) wrote :

Yes, my system is English (GB). Having tried that it does now show correctly. Thank you for pointing that out.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments