Startup page for firefox states "Welcome to Ubuntu 7.10!" when it should say "Welcome to Ubuntu 8.04 (alpha 1)!"

Bug #176678 reported by Hazim Gazov on 2007-12-16
12
Affects Status Importance Assigned to Milestone
ubuntu-docs (Ubuntu)
High
David Futcher

Bug Description

Binary package hint: firefox

Steps to reproduce:

open firefox on Hardy Herron
go to file:///usr/share/ubuntu-artwork/home/index.html (default homepage)

Related branches

Hazim Gazov (hazim-gazov) wrote :

Correct firefox-index.html

Dean Sas (dsas) wrote :

A potential problem with that, is that it's something that needs updating on every alpha release.

Alexander Sack (asac) on 2007-12-29
Changed in firefox:
assignee: nobody → asac
importance: Undecided → High
milestone: none → hardy-alpha-4
Colin Watson (cjwatson) wrote :

This should say "Hardy Heron" until just before the beta.

Changed in firefox:
status: New → Confirmed
Steve Langasek (vorlon) wrote :

this file is provided by ubuntu-docs, reassigning to that package.

Changed in firefox:
status: Confirmed → New
David Futcher (bobbo) wrote :

This is fixed along with Bug #185867 in this debdiff.

ubuntu-docs (7.10.5) gutsy; urgency=low

  * Update version in firefox start page for Hardy (LP: #176678)
  * Fix incorrect description for 'Neverball' (LP: #185867)

 -- David Futcher <email address hidden> Thu, 31 Jan 2008 19:50:56 +0000

Changed in ubuntu-docs:
assignee: asac → bobbo
status: New → In Progress
Daniel Holbach (dholbach) wrote :

Matthew: can this be merged into the ubuntu-docs branch?

Steve Langasek (vorlon) on 2008-02-15
Changed in ubuntu-docs:
milestone: hardy-alpha-4 → hardy-alpha-5
Matthew East (mdke) wrote :

Sorry for the delay.

David - thanks for the patch, but I haven't committed it, because it didn't fix all the translations of the index page. I've run sed over the files to update the text to "8.04" and committed the change to the ubuntu-docs branch. The next upload will fix the issue.

Changed in ubuntu-docs:
status: In Progress → Fix Committed
Matthew East (mdke) wrote :

Based on Colin's comment, I've changed this to "Hardy Heron", although this means that we should try and remember to change this to "8.04 LTS" before the release.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-docs - 8.02.1

---------------
ubuntu-docs (8.02.1) hardy; urgency=low

  * New bzr checkout - loads of text fixes and improvements (LP: #183148,
    LP: #183025, LP: #178064, LP: #160435, LP: #158016, LP: #146794,
    LP: #144795, LP: #185867, LP: #163188, LP: #150167, LP: #148372,
    LP: #144928, LP: #141491, LP: #141444, LP: #138891, LP: #172565,
    LP: #144285, LP: #150641, LP: #176678)
  * First release for hardy

 -- Matthew East <email address hidden> Sat, 16 Feb 2008 18:31:20 +0000

Changed in ubuntu-docs:
status: Fix Committed → Fix Released
Matthew East (mdke) wrote :

Now amended in the hardy branch to say "8.04 LTS". This will be included in the next ubuntu-docs upload.

Changed in ubuntu-docs:
status: Fix Released → Fix Committed
Steve Langasek (vorlon) wrote :

Hi Matthew,

It's been decided that Ubuntu 8.04 will not be deemed an LTS release until the first point release, to allow additional time for bugfixing and polish. Can this please be changed to say "8.04" instead for now?

Changed in ubuntu-docs:
milestone: hardy-alpha-5 → ubuntu-8.04-beta
status: Fix Committed → In Progress
Matthew East (mdke) wrote :

Committed. I'm surprised not to have seen any public discussion of that though - was this in a TB meeting that I didn't spot?

Changed in ubuntu-docs:
status: In Progress → Fix Committed
Matthew East (mdke) wrote :

Via private mail I've established that the correct string should indeed by "Ubuntu 8.04 LTS". This has been committed - it would be good to get this in for the beta release: can someone please sponsor an upload from https://code.launchpad.net/~ubuntu-core-doc/ubuntu-doc/ubuntu-hardy?

We've also shaved a couple of MB off the size of the package by fixing the translator filter script in debian/rules.

ubuntu-main-sponsor subscribed.

Thanks

On Mon, Mar 17, 2008 at 09:26:58PM -0000, Matthew East wrote:
> Via private mail I've established that the correct string should indeed
> by "Ubuntu 8.04 LTS". This has been committed - it would be good to get
> this in for the beta release: can someone please sponsor an upload from
> https://code.launchpad.net/~ubuntu-core-doc/ubuntu-doc/ubuntu-hardy?

> We've also shaved a couple of MB off the size of the package by fixing
> the translator filter script in debian/rules.

> ubuntu-main-sponsor subscribed.

Uploading, thanks!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-docs - 8.03.2

---------------
ubuntu-docs (8.03.2) hardy; urgency=low

  * New bzr checkout (LP: #176678, LP: #118963, LP: #108083, LP: #202312)
  * Replacing "server" document with "serverguide"
  * Refresh pot files
  * Fixing debian/rules to filter translations less than 40%

 -- Matthew East <email address hidden> Sun, 16 Mar 2008 22:16:42 +0000

Changed in ubuntu-docs:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers