The "Official Documentation" for Ubuntu 16.04 does not include correct instructions on installing Printers.

Bug #1630272 reported by Pete
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-docs (Ubuntu)
Fix Released
Wishlist
Chris Perry

Bug Description

The "Official Documentation" for Ubuntu 16.04 does not include correct instructions on installing Printers.

Following the Official Documentation guides for Ubuntu 16.04 (see below)

Ubuntu 16.04 Official Printing Documentation
https://help.ubuntu.com/lts/ubuntu-help/printing.html

Ubuntu 16.04 Official Documentation:
https://help.ubuntu.com/lts/ubuntu-help/index.html

There is no Network Printer installation guide, but there should be. MOST desktop users now use network printers at home, small offices, and companies. Most printing in my experience is networked, not local. Most network printing is IP based printing, and users in Windows and Mac can easily install a network printer by providing its IP address and selecting the printer. Or installing the driver, then selecting the printer when adding the network printer by IP.

Note: Many companies (and most home networks) use direct IP printing from the client, and do not forward print jobs to a print server.

The Official Guide should include steps to clearly install a network printer for Ubuntu Desktop via IP address.

I am reporting this here as the Official Doco pages state "To report errors in this documentation, file a bug."

Thanks!

Revision history for this message
Gunnar Hjalmarsson (gunnarhj) wrote :

Thanks for your report!

There is quite some stuff about networking in other sections of the desktop guide:

https://help.ubuntu.com/lts/ubuntu-help/net-wireless.html

For instance this:

https://help.ubuntu.com/lts/ubuntu-help/net-wireless-adhoc.html

Possibly the printing section could be improved with a couple of links. However, personally I'm not tech savvy at all on networking.

What do you think, Pete? Is something in the net-wireless section helpful in this respect?

Changed in ubuntu-docs (Ubuntu):
importance: Undecided → Wishlist
status: New → Confirmed
Revision history for this message
Doug Smythies (dsmythies) wrote :

I don't think it should go in the wireless section.
All we need is something that says "open settings" - "printers" - click on "ADD" - open the "network printer" pull down menu - follow the prompts.

Revision history for this message
Doug Smythies (dsmythies) wrote :

My suggestion is that we change the title of "Set up a local printer" to "Set up a printer" and then make the changes to cover both networked and local therein. Why not a separate page? Because the steps are largely the same.

Some new doc contributors are looking for relatively easy bug reports to tackle. Any takers? If not, I'll assign myself this one in a few weeks.

Revision history for this message
Pete (lance321) wrote :

One suggestion would be to change the link name in the page below from "Set up a local printer" to "Set up a printer" (as you stated) in the page below.

Ubuntu 16.04 Official Printing Documentation
https://help.ubuntu.com/lts/ubuntu-help/printing.html

And then in the subsequent page (for Setup a Printer) add different sections. One for setting up a local printer (which you have already) and another section for "Adding a Network Printer", and you can include instructions to connect to a printer via IP address here (or CUPS, or Windows printer server - SMB).

On this page:
https://help.ubuntu.com/lts/ubuntu-help/printing-setup.html

However please note, you may want to try these steps yourself first. I have tried adding a network printer on three machines running 16.04 (fresh installs) and all were confusing to me via the Add Printer GUI wizard.

Once I selected "Printers" > Add > Network Printer. It found my Brother Printer, and I thought it installed fine. I went to print and it said my printer could not be found. If found it when installing, but I think the IP address was not specified, so it would not print to it later. I think this is because the installation process the user follows needs changed *(hence updated documentation).

I assume users are supposed to select "Printers" > Add > Network Printer > "Find Network Printer" and in the "HOST" field enter the IP address of your printer to get it to work. Is this correct? I have no idea because the HOST name to me refers to the name on a network.

Since the GUI wizard is not clear on how to install a network printer perhaps the Official documentation can but updated to compensate for this.

I eventually got the printer installed on a couple machines, but I tried a few things to get printer to point to the IP address.

Revision history for this message
Doug Smythies (dsmythies) wrote :

> I assume users are supposed to select
> "Printers" > Add > Network Printer > "Find Network Printer"
> and in the "HOST" field enter the IP address of your printer
> to get it to work. Is this correct?

These days the printer should be found automatically. But yes, specifying an IP address does work.

> I have no idea because the HOST name to me refers to the name on a network.

I tried both methods, and they both found the printer. On my LAN my Epson workforce pro 4530 is "epson-wp" at 192.168.111.110. However with both methods it seemed to find and list it about 70 times.

Things do seem somewhat messed up with this process, and I have yet to successfully install my network printer on my Yakkety test LapTop computer.

Revision history for this message
Pete (lance321) wrote :

> I tried both methods, and they both found the printer. On my LAN my Epson workforce pro 4530 is "epson-wp" at 192.168.111.110. However with both methods it seemed to find and list it about 70 times.

Yes I have had similar issues when installing a network printer. I feel installing the Network Printer in Ubuntu is rather 'messed up' as you said. That is pretty accurate.

I wish there was a straight forward process of selecting a printer via HOST, and pointing to a driver if needed (if your printer is not listed), and then your done.

-------

A few weeks ago I setup a Brother DCPL2540DW network printer (static IP 192.168.1.15), but the model was not listed in Ubuntu's Add-Printer. I downloaded the print driver from Brothers website for Linux (they provide Deb & RPM formats.

The Brother Driver Install Tool works beautifully. Its a small Bash script you run, and it downloads & installed the print drivers (via deb) for you. "The tool will install LPR, CUPSwrapper driver and scanner driver (for scanner models)."

http://support.brother.com/g/b/downloadlist.aspx?c=us&lang=en&prod=dcpl2540dw_us_as&os=128

Following Brothers simple instructions on the download screen, you select "Yes" for "Device URI" and you can specify the IP address *(See below).

Note this installs the printer & scanner completely in Linux, and you don't need to use the Add Printer option in Ubuntu at all. But this only works if your printer vendors provides instructions to install their own printer installation software.

It would be better though to simply install the printer using the Ubuntu GUI as its designed.

Will you specify the Device URI? [y/N] ->Y

0: ipp
1: ipps
2: lpd
3: socket
4: beh
5: hp
6: https
7: ipp14
8: smb
9: http
10: hpfax
11 (I): Specify IP address.
select the number of destination Device URI. ->6

Changed in ubuntu-docs (Ubuntu):
assignee: nobody → Chris Perry (clissold345)
status: Confirmed → In Progress
Revision history for this message
Chris Perry (clissold345) wrote :

I've written a draft and asked for comments on it on the ubuntu-doc mailing list (link below). If anyone subscribed to this bug (Pete?) wants to comment too that would be very good. There's no need to post on the mailing list, just add a comment to this bug and I'll see it. Regards, Chris.

https://lists.ubuntu.com/archives/ubuntu-doc/2016-October/020232.html

Revision history for this message
Pete (lance321) wrote :

Sure will test the procedure out on the network printers / computers on our network with Ubuntu and reply back. Thanks!

Revision history for this message
Pete (lance321) wrote :
Download full text (3.6 KiB)

I apologize in my delay in replying. I tested the printer instructions you provided under Ubuntu 16.04.

In the beginning of the instructions for 16.04 it says:

“You do not need to select whether you want to install network or local printer now. They are listed in one window.”

I actually have to choose “Network” to proceed. I think the instructions for 17.04 are better, and work for 16.04 as well, but neither instructions work without a few changes in the process. See process below.

Using your instructions as a base, here is what I had to do. I confirmed this process on three machines running Ubuntu 16.04, using the same network printer. Perhaps others can confirm.

Below are my instructions, note: step 4 is edited, and step 5 is an additional step.

----------

To set up a network printer:

1. It's assumed that the printer is connected to your network. Click the icon at the far right of the menu bar and select System Settings.
2. Open Printers.
3. Click Add.
4. Click “Network”. If your printer is listed in the Devices list, select it; otherwise if you know the printer's IP address, select Find Network Printer, enter the IP address in the Host field, and click Find.
5. Once you select your printer the HOST field may be auto-populated with information based on your selected printer (example: “BRN30055C829554”). Delete this and enter your printers IP Address.
6. Click Forward and wait while the system searches for drivers.
7. You can customize the printer's name, description, and location if you like. When finished, click Apply.
8. You can now print a test page or click Cancel to skip that step.

----------

Explanation:

If I accept all defaults when installing the network printer via the GUI, the GUI auto populates my HOST field with “BRN30055C829554” (for my Brother network printer). It then appears to grab an acceptable driver and install the printer successfully. The printer appears in the printers section but no jobs print.

Note: I noticed the wizard automatically assigns the Device URI: "lpd://BRN30055C829554/BINARY_P1".

When I manually changed the "Device URI" to "http://192.168.1.20/" the printer printed successfully. However I could not just enter the IP address (192.168.1.20) directly, I had to enter in the "htt://<IP ADDRESS>/"

Alternately I could also select the printer properties (*after installation), and in the GUI next to "Device URI" select "Change". Here I have to wait a second, then I get the option to change the "HOST" field. If I enter the printer IP "192.168.1.20" and save settings, the device ID field changes to "lpd://192.168.1.20/BINARY_P1". I can then successfully print a test page.

Basically it appears when letting the Ubuntu printer wizard GUI select the printer port/Device-UI it doesn't do it correctly (*non IP). Printing fails. You must manually enter the devices IP address. I have found no other way to get this to work. I confirmed this behavior on several machines. Perhaps others here can test and confirm this.

For users who know their printers IP address (and its set to STATIC) this method should work always. It appears though that printing to the printer MAC or Device URI it auto detects and populate...

Read more...

Revision history for this message
Gunnar Hjalmarsson (gunnarhj) wrote :

Thank you very much for your input, Pete. Leaving to Chris to consider it further.

The issue with the automatically assigned device URI reminds me of bug #1320381 which I filed a couple of years ago. That was also a Brother printer, but connected via an USB port. Can't help wondering if Brother printers are harder to install on Ubuntu than other printers.

Revision history for this message
Chris Perry (clissold345) wrote :

Hi Pete, yes many thanks for reviewing the first procedure on the page. Here's a new draft. Is that OK now?

http://people.ubuntu.com/~gunnarhj/printing-setup.html

Revision history for this message
Doug Smythies (dsmythies) wrote :

I've been trying to follow and test this stuff. It turns out that Epson does not provide drivers for linux, so I am trying to install an OpenPrinting.org driver that I found. It depends on the lsb package, which refuses to install on my 16.10 test LapTop due to dependency issues, which make no sense to me because it is pretty much just a basic installation. I don't have time for a saga at the moment.

Revision history for this message
Pete (lance321) wrote :

Hi Chris,

I just tested the updated instructions tonight on another Ubuntu 16.04 system.

Your instructions on 17.04 appear correct and work for 16.04. But this is assuming the printer Device URI is created correctly. If it doesn't though (as in my case) the user may have to manually change that to the IP address. So it may be worth adding this into the instructions. Something to the effect "If the printer fails to print, and you know your Printers IP address change your Device URI / Host Name" (Printer > Right-click > Properties > Device URI, click "Change"). This will save users a lot of time looking online on a work around.

Don't honestly know how the auto-assigned Device URI is supposed to work. I assume its based on a broadcast name of the printer.

However, if its useful to you, I have attached a PDF of my installation, including screenshots as an example.

Also Gunnar is probably correct in this is similar to this bug #1320381 (linked above). So I am going to try these instructions with some other printer models and post back if the printer Device URI is correctly identified. It may be a few days before I have access to addition printers however.

Thanks!

Revision history for this message
Pete (lance321) wrote :

Here is my example installing a network printer: Brother DCP-L2540DW (Static IP: 192.168.1.20), on Ubuntu 16.04 machine.

Revision history for this message
Chris Perry (clissold345) wrote :

Hi Pete, thanks for testing the updated instructions and thanks for the pdf file. I find it useful to see the screenshots (I'm not able to try the instructions out myself). I'll have a think about what to do and get back to you (probably later this week). Regards, Chris.

Revision history for this message
Chris Perry (clissold345) wrote :

Hi Pete, I've done a new draft (link below). Could you check the draft again?

I added a step (step 8) about choosing a driver and installing it. I also added a brief note/warning about the "Device URI" problem. I think the warning applies to people who haven't followed the procedure, since anyone who followed the procedure won't have the problem?

It sounds to me as if the "Device URI" problem is a software bug. Would you be willing to file another bug (a non-documentation bug) for it?

Regards,

Chris.

http://people.ubuntu.com/~gunnarhj/printing-setup.html

Revision history for this message
Pete (lance321) wrote :

Hi Chris,

I went through your updated instructions. I deleted and reinstalled printers on Ubuntu 16.04 system.

The updated instructions work fine, thanks! Following the procedure the printer still has the Device URI error issue (character string). But following your last bit below a user will quickly be able to now resolve the issue.

Note: "If you've set up a network printer and it won't print, check the Device URI field in the printer settings. It should display the printer's IP address. If it doesn't then correct it."

I update my Device URI to the IP and print jobs now print successfully.

I will submit a new bug report for the printer installation wizard creating the incorrect Device URI.

Thanks again!

Pete

Revision history for this message
Chris Perry (clissold345) wrote :

@Gunnar. In the desktop help we now cover adding a network printer (the update planned for 17.04) but we don't cover the seven options below "Find Network Printer" in the New Printer dialog box. I don't understand what they do so I can't write them up. Can we mark this bug FIX COMMITTED and work out how to cover the seven options if/when someone files a bug about them not being documented?

Revision history for this message
Gunnar Hjalmarsson (gunnarhj) wrote :

Yes, agreed. The desktop guide will never cover everything.

Changed in ubuntu-docs (Ubuntu):
status: In Progress → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-docs - 17.04.1

---------------
ubuntu-docs (17.04.1) zesty; urgency=medium

  * scripts/validate.sh:
    - Modified so it can be called via a symlink from 'ubuntu-help/C'
      or 'html'.
  * power-hibernate.page:
    - Changed command due to upstart->systemd transition.
  * Bump version to 17.04 / zesty.
  * html/ubuntu.xsl:
    - Make unordered lists bulleted and not numbered (LP: #1649554).
  * keyboard-layouts.page:
    - Note about how to show rarely used xkb layout variants.
  * Updated ubuntu-help.pot.
  * debian/compat, debian/control:
    - Bump to debhelper version 9

  [ Chris Perry ]
  * tips-specialchars.page:
    - Section "Compose key" updated (LP: #1624778).
  * addremove-ppa.page:
    - Revise PPA description (LP: #1628706).
  * keyboard-layouts.page:
    - Move text of marginal note.
  * mouse-middleclick.page, mouse-touchpad-click.page:
    - Revise description of middle-click from touchpad (LP: #1617718).
  * power-lowpower.page:
    - Update since related control in "System Settings -> Power" has
      been removed (LP: #1599264, LP: #1641786).
  * accounts-add.page, net-firewall-on-off.page:
    - Minor clarifications.
  * net-wireless-*.page, net-problem.page:
    - GUI conformity modifications (LP: #1637126)
    - New shared section (LP: #977251)
  * addremove-install.page, addremove-remove.page:
    - Clearer description of Ubuntu Software's focus on applications
      (LP: #1637861).
    - Mentioning of snaps (LP: #1658785).
  * printing-setup.page:
    - Section about network printer added (LP: #1630272).
  * mouse-mousekeys.page:
    - Improved description of mouse keys (LP: #964727).
  * disk-*.page:
    - GUI conformity modifications (LP: #1651360).
  * List type explicitly stated on multiple pages.
  * addremove-creator.page:
    - New page describing Startup Disk Creator (LP: #1569532).
  * security-settings.page:
    - New page describing the Security & Privacy panel in System
      Settings (LP: #1200381).

  [ Doug Smythies ]
  * scripts/validate.sh:
    - Changed to --strict validation.
  * ubuntu-help/C/legal.xml:
    - Specify https to avoid a "permanently moved" redirection.

 -- Gunnar Hjalmarsson <email address hidden> Mon, 20 Feb 2017 15:11:00 +0100

Changed in ubuntu-docs (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers