Translation update + extras

Bug #1592162 reported by Gunnar Hjalmarsson on 2016-06-13
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-docs (Ubuntu)
Medium
Gunnar Hjalmarsson
Xenial
Medium
Gunnar Hjalmarsson

Bug Description

[Impact]

This upload combines a regular translation update of the 16.04 desktop guide with changes of 30+ translatable strings.

Normally we don't do SRUs of translatable strings in ubuntu-docs, but there was a late name change of the new software management application from just "Software" to "Ubuntu Software", which was not reflected in the desktop guide at release time. The relative importance of Ubuntu Software, and its mentioning in the desktop guide in several places, justifies this exception.

We have taken this 'opportunity' to SRU a few other bug fixes; please see the changelog.

The translators have been notified:

https://lists.ubuntu.com/archives/ubuntu-translators/2016-May/007174.html

and reminded:

https://lists.ubuntu.com/archives/ubuntu-translators/2016-June/007178.html

[Test Case]

As an example, this page:

https://help.ubuntu.com/16.04/ubuntu-help/addremove-install.html

refers to "Software" only. With the update it's changed to "Ubuntu Software".

[Regression Potential]

For some languages, some strings, which were translated at release time, may be untranslated after this update. That's unfortunate, but these changes of original strings carry greater weight. It's also possible to improve this through translation updates later on.

Otherwise the regression risk is low. This is only documentation, which does not affect other parts of the system.

Changed in ubuntu-docs (Ubuntu Xenial):
assignee: nobody → Gunnar Hjalmarsson (gunnarhj)
importance: Undecided → Medium
milestone: none → ubuntu-16.04.1
status: New → Triaged
Changed in ubuntu-docs (Ubuntu):
status: Triaged → Fix Committed
Changed in ubuntu-docs (Ubuntu Xenial):
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-docs - 16.10.1

---------------
ubuntu-docs (16.10.1) yakkety; urgency=medium

  * scripts/translation-test-build.sh:
    - Check that required packages are installed.
  * Updates due to switch from "Software" to "Ubuntu Software"
    (LP: #1570479).
  * nautilus-list.page:
    - Less specific description of column "Modified" (LP: #1572304).
  * Extra update of ubuntu-help.pot (LP: #1573249, LP: #1573251).
  * video-dvd-restricted.page:
    - Updated suggested packages (LP: #1201904).
    - New guidance on how to install libdvdcss2 (LP: #1571208).
  * power-hibernate.page:
    - Code for re-enabling hibernate corrected (LP: #1575466).
  * mouse-disabletouchpad.page:
    - Deleted, since the feature is enabled by default now, and the
      GUI control has been dropped (LP: #1575911).
  * disk-check.page:
    - Updated to correspond to gnome-disk-utility 3.18 (LP: #1573025).
  * net-chat-empathy.page:
    - Updated since Empathy is no longer installed by default
      (LP: #1579394).
  * files-disc-write.page:
    - Updated since Brasero is no longer installed by default.
  * numeric-keypad.page, shell-guest-session.page:
    - Suggest lightdm configuration in /etc instead of /usr/share.
  * net-wireless-troubleshooting-initial-check.page:
    - Replace nm-tool (no longer available) with nmcli (LP: #1581846).
  * Updated ubuntu-help.pot.
  * New Kabyle (kab) translation.
  * The latest translations exported from Launchpad (LP: #1592162).
  * debian/control: Bump Standards-Version to 3.9.8.
  * Bump version to 16.10 / yakkety.

  [ Milo Casagrande ]
  * Make Italian screenshots 250x200.

  [ Doug Smythies ]
  * unity.png, unity-windows.png, unity-overview.png:
    - Updated again due to new yet old Ubuntu Software icon
      (LP: #1570479).

 -- Gunnar Hjalmarsson <email address hidden> Fri, 17 Jun 2016 00:11:00 +0200

Changed in ubuntu-docs (Ubuntu):
status: Fix Committed → Fix Released

Hello Gunnar, or anyone else affected,

Accepted ubuntu-docs into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ubuntu-docs/16.04.4 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in ubuntu-docs (Ubuntu Xenial):
status: In Progress → Fix Committed
tags: added: verification-needed
Gunnar Hjalmarsson (gunnarhj) wrote :

I have installed ubuntu-docs 16.04.4 from xenial-proposed. Started yelp with LANGUAGE=en_US, and can confirm that the new and changed English strings (including "Ubuntu Software") show up as expected.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-docs - 16.04.4

---------------
ubuntu-docs (16.04.4) xenial; urgency=medium

  * Umbrella bug report for this upload: LP: #1592162 (see the bug
    description). All the below items consist of backported fixes from
    the upload to yakkety of version 16.10.1, except that the bug
    references have been excluded to make the SRU verification easier.
  * scripts/translation-test-build.sh:
    - Check that required packages are installed.
  * Updates due to switch from "Software" to "Ubuntu Software".
  * nautilus-list.page:
    - Less specific description of column "Modified".
  * Extra update of ubuntu-help.pot.
  * video-dvd-restricted.page:
    - Updated suggested packages.
    - New guidance on how to install libdvdcss2.
  * power-hibernate.page:
    - Code for re-enabling hibernate corrected.
  * mouse-disabletouchpad.page:
    - Deleted, since the feature is enabled by default now, and the
      GUI control has been dropped.
  * disk-check.page:
    - Updated to correspond to gnome-disk-utility 3.18.
  * net-chat-empathy.page:
    - Updated since Empathy is no longer installed by default.
  * files-disc-write.page:
    - Updated since Brasero is no longer installed by default.
  * numeric-keypad.page, shell-guest-session.page:
    - Suggest lightdm configuration in /etc instead of /usr/share.
  * net-wireless-troubleshooting-initial-check.page:
    - Replace nm-tool (no longer available) with nmcli.
  * Updated ubuntu-help.pot.
  * New Kabyle (kab) translation.
  * The latest translations exported from Launchpad.

  [ Milo Casagrande ]
  * Make Italian screenshots 250x200.

  [ Doug Smythies ]
  * unity.png, unity-windows.png, unity-overview.png:
    - Updated again due to new yet old Ubuntu Software icon.

 -- Gunnar Hjalmarsson <email address hidden> Fri, 17 Jun 2016 15:08:00 +0200

Changed in ubuntu-docs (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for ubuntu-docs has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers