In the Ubuntu desktop guide The URI ‘help:empathy/index’ does not point to a valid page.

Bug #1591474 reported by Daniel Brownridge
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-docs (Ubuntu)
Fix Released
Medium
Unassigned

Bug Description

Description: Ubuntu 16.04 LTS
Release: 16.04

ubuntu-docs:
  Installed: 16.04.3
  Candidate: 16.04.3
  Version table:
 *** 16.04.3 500
        500 http://gb.archive.ubuntu.com/ubuntu xenial/main amd64 Packages
        500 http://gb.archive.ubuntu.com/ubuntu xenial/main i386 Packages
        100 /var/lib/dpkg/status

This bug relates to the following section of the Ubuntu help.

Ubuntu Desktop Guide » Networking, web, e-mail & chat » Chat & Social Networking » Instant messaging on Ubuntu

In this section the third paragraph (excluding the information box) contains the text:

"For help with using Empathy, read the Empathy manual." where the words "Empathy manual" are a link.

The expected action is that following this link would take you to a manual of the Empathy program.

Instead following the link results in this error message:

Document Not Found
The URI ‘help:empathy/index’ does not point to a valid page.

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: ubuntu-docs 16.04.3
ProcVersionSignature: Ubuntu 4.4.0-24.43-generic 4.4.10
Uname: Linux 4.4.0-24-generic x86_64
ApportVersion: 2.20.1-0ubuntu2.1
Architecture: amd64
CurrentDesktop: Unity
Date: Sat Jun 11 09:46:31 2016
InstallationDate: Installed on 2016-06-06 (4 days ago)
InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Release amd64 (20160420.1)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_GB:en
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: ubuntu-docs
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Daniel Brownridge (freshnewpage) wrote :
Revision history for this message
Gunnar Hjalmarsson (gunnarhj) wrote :

Thanks for your report, Daniel.

The link works if empathy is installed, otherwise not. Previously the program was installed in Ubuntu by default, but that's not the case any longer.

We'd better reconsider that link somehow.

Changed in ubuntu-docs (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Revision history for this message
Daniel Brownridge (freshnewpage) wrote :

Hi Gunnar,

That makes sense. After filing the bug I then discovered that Empathy is no longer part of the default installation. So this bug highlights the slightly bigger issue of that whole section of the documentation being written from the perspective that Empathy is installed by default.

Revision history for this message
Gunnar Hjalmarsson (gunnarhj) wrote :

Actually it's not just about Empathy, but there are quite a few similar links to help documents of other applications which are not installed by default either. Not sure right now how it should best be dealt with.

Revision history for this message
Doug Smythies (dsmythies) wrote :

There are 10 such links. Internally, and as you already know, they point to the specific pages that are part of the package. For the external web based version of the docs they point to the web based counterpart, i.e. https://help.gnome.org/users/empathy/stable/ for this case. This is intentional, and myself I don't see a problem here.

Revision history for this message
Gunnar Hjalmarsson (gunnarhj) wrote :

Right, Doug, the problem isn't the web version, where the links are always valid. But the approach in the yelp version creates an expectation gap, since the users don't know why they fail and how to make them work. An explanatory comment (which could be dropped in the web version) might help.

Revision history for this message
Gunnar Hjalmarsson (gunnarhj) wrote :

On 2016-06-11 14:52, Daniel Brownridge wrote:
> So this bug highlights the slightly bigger issue of that whole
> section of the documentation being written from the perspective that
> Empathy is installed by default.

Only now I realize what you wrote in that sentence. That detail is about to be taken care of. In a few weeks an update will come, where it says that Empathy is not installed by default.

Revision history for this message
Chris Perry (clissold345) wrote :

This problem seems to have been fixed in the 16.10 help (see link below). Shouldn't the status of this bug report be "FIX COMMITTED" or "FIX RELEASED"? Or is the status being kept at "TRIAGED" to remind us that there may be other similar link errors (not yet fixed)?

https://help.ubuntu.com/16.10/ubuntu-help/net-chat-empathy.html

Revision history for this message
Gunnar Hjalmarsson (gunnarhj) wrote :

Well, let's decide that since it (now) says that the program isn't installed by default, it implies that installing the program is needed to view the local help.

Changed in ubuntu-docs (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers