Outdated documentation

Bug #1581846 reported by Dave Harper
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-docs (Ubuntu)
Fix Released
Medium
Gunnar Hjalmarsson

Bug Description

On the page help.ubuntu.com/16.04/ubuntu-help/net-wireless-troubleshooting-initial-check.html, Step 5 refers to using nm-tool. This utility is no longer available and apparently has been replaced with nmcli.

Revision history for this message
Gunnar Hjalmarsson (gunnarhj) wrote :

Thanks for reporting this, Dave.

nmcli seems to be a more sophisticated tool. Do you have any idea of what would be a proper command to suggest instead of nm-tool? Would

nmcli -p dev wifi

serve the purpose?

Changed in ubuntu-docs (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed
Revision history for this message
Dave Harper (4-dave-s) wrote : Re: [Bug 1581846] Re: Outdated documentation

Hi Gunnar,

Since I don't know what output was produced by the nm-tool, I'm not sure
what the equivalent nmcli parameters would be. I should also point out
that I am essentially a newbie with Linux (I haven't really used it much
in the last 20 years or so and things have changed a bit since then). I
came across this issue in trying to troubleshoot a wireless connection
problem I'm having after installing the latest Ubuntu on a laptop a
couple of days ago. I should also point out that is a really low
priority issue (IMHO) - anyone following the documentation will quickly
find (as I did) that nm-tool is no longer available and the substitute
is nmcli.

For what it's worth, I ran the command on my laptop using the parameters
you show below and it listed all local wireless networks, their signal
strengths and authentication methods. Since my problem has more to do
with authentication rather than actual connection I have not pursued the
nmcli tool much further.

Regards,
Dave

On 5/14/2016 3:59 PM, Gunnar Hjalmarsson wrote:
> Thanks for reporting this, Dave.
>
> nmcli seems to be a more sophisticated tool. Do you have any idea of
> what would be a proper command to suggest instead of nm-tool? Would
>
> nmcli -p dev wifi
>
> serve the purpose?
>
> ** Changed in: ubuntu-docs (Ubuntu)
> Importance: Undecided => Medium
>
> ** Changed in: ubuntu-docs (Ubuntu)
> Status: New => Confirmed
>

Revision history for this message
Gunnar Hjalmarsson (gunnarhj) wrote :

I asked because I know very little about this topic. :-/ The attached file is what my own machine outputted when I ran the "nm-tool" command.

I now think that the "nmcli dev" command would be a better replacement:

$ nmcli dev
DEVICE TYPE STATE CONNECTION
wlan0 wifi connected GuestWNET
eth0 ethernet disconnected --
ttyUSB0 gsm unavailable --
lo loopback unmanaged --

It shows the state of each device.

On 2016-05-14 23:21, Dave Harper wrote:
> I should also point out that is a really low priority issue (IMHO)
> - anyone following the documentation will quickly find (as I did)
> that nm-tool is no longer available and the substitute is nmcli.

Well, it's a docs bug, and now when you have pointed it out, we'd better change it somehow.

> Since my problem has more to do with authentication rather than
> actual connection I have not pursued the nmcli tool much further.

I see.

Changed in ubuntu-docs (Ubuntu):
assignee: nobody → Gunnar Hjalmarsson (gunnarhj)
status: Confirmed → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-docs - 16.10.1

---------------
ubuntu-docs (16.10.1) yakkety; urgency=medium

  * scripts/translation-test-build.sh:
    - Check that required packages are installed.
  * Updates due to switch from "Software" to "Ubuntu Software"
    (LP: #1570479).
  * nautilus-list.page:
    - Less specific description of column "Modified" (LP: #1572304).
  * Extra update of ubuntu-help.pot (LP: #1573249, LP: #1573251).
  * video-dvd-restricted.page:
    - Updated suggested packages (LP: #1201904).
    - New guidance on how to install libdvdcss2 (LP: #1571208).
  * power-hibernate.page:
    - Code for re-enabling hibernate corrected (LP: #1575466).
  * mouse-disabletouchpad.page:
    - Deleted, since the feature is enabled by default now, and the
      GUI control has been dropped (LP: #1575911).
  * disk-check.page:
    - Updated to correspond to gnome-disk-utility 3.18 (LP: #1573025).
  * net-chat-empathy.page:
    - Updated since Empathy is no longer installed by default
      (LP: #1579394).
  * files-disc-write.page:
    - Updated since Brasero is no longer installed by default.
  * numeric-keypad.page, shell-guest-session.page:
    - Suggest lightdm configuration in /etc instead of /usr/share.
  * net-wireless-troubleshooting-initial-check.page:
    - Replace nm-tool (no longer available) with nmcli (LP: #1581846).
  * Updated ubuntu-help.pot.
  * New Kabyle (kab) translation.
  * The latest translations exported from Launchpad (LP: #1592162).
  * debian/control: Bump Standards-Version to 3.9.8.
  * Bump version to 16.10 / yakkety.

  [ Milo Casagrande ]
  * Make Italian screenshots 250x200.

  [ Doug Smythies ]
  * unity.png, unity-windows.png, unity-overview.png:
    - Updated again due to new yet old Ubuntu Software icon
      (LP: #1570479).

 -- Gunnar Hjalmarsson <email address hidden> Fri, 17 Jun 2016 00:11:00 +0200

Changed in ubuntu-docs (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers