Page on disabling touchpad while typing is erroneous

Bug #1575911 reported by Doug McMahon
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-docs (Ubuntu)
Fix Released
Medium
Gunnar Hjalmarsson
Revision history for this message
Gunnar Hjalmarsson (gunnarhj) wrote :

Well, there is an ON/OFF switch instead. The page should be reworded accordingly. Thanks!

Changed in ubuntu-docs (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Revision history for this message
Joel Gallun (joel-gallun) wrote :

Gunnar, are you serious? the ON/OFF switch disables the touchpad entirely, which is not what the OP is talking about at all.

The documentation says there is a setting to disable the touchpad while typing, which is a feature of MacOS, and possibly Windows. Its a very useful feature and Ubuntu should have it.

The Wiki is wrong, and the OS is deficient WRT to using the GUI to configure the touchpad. Its as bad as WIndows 10 in that respect.

Revision history for this message
Joel Gallun (joel-gallun) wrote :

edit to previous comment:

I did some more research on this. Disable while typing is controlled by syndaemon. Disable while typing defaults to on and there is no way to change it through the GUI. The Wiki is wrong and system should support configuring all features of the touchpad through the GUI

joel@joel-UX303UA:~$ ps aux|grep syndae
joel 1665 0.0 0.0 22504 1244 ? S Apr28 0:03 syndaemon -i 1.0 -t -K -R

-i enables "disable while typing" and 1.0 the length of time to disable it for. Man syndaemon for details

Revision history for this message
Gunnar Hjalmarsson (gunnarhj) wrote :

I may have misunderstood it. Looks like <https://launchpad.net/bugs/1570339> is related, then.

Revision history for this message
Gunnar Hjalmarsson (gunnarhj) wrote :

Checked on a 14.04 installation, and there the "Disable while typing" checkbox is present. Can't tell when or why it was dropped. So that page has been correct previously.

Revision history for this message
Doug McMahon (mc3man) wrote :

Hi guys -
this bug was/is really only about to documentation.
As far as the touchpad not being disabled while typing by default & no option to do so that's in this bug here.
It's a regression from past Releases where it was disabled & an option exposed in the Touchpad panel

https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-input-synaptics/+bug/1576685

Revision history for this message
Gunnar Hjalmarsson (gunnarhj) wrote :

Understand now. Just committed a deletion of the page.

Changed in ubuntu-docs (Ubuntu):
assignee: nobody → Gunnar Hjalmarsson (gunnarhj)
status: Triaged → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-docs - 16.10.1

---------------
ubuntu-docs (16.10.1) yakkety; urgency=medium

  * scripts/translation-test-build.sh:
    - Check that required packages are installed.
  * Updates due to switch from "Software" to "Ubuntu Software"
    (LP: #1570479).
  * nautilus-list.page:
    - Less specific description of column "Modified" (LP: #1572304).
  * Extra update of ubuntu-help.pot (LP: #1573249, LP: #1573251).
  * video-dvd-restricted.page:
    - Updated suggested packages (LP: #1201904).
    - New guidance on how to install libdvdcss2 (LP: #1571208).
  * power-hibernate.page:
    - Code for re-enabling hibernate corrected (LP: #1575466).
  * mouse-disabletouchpad.page:
    - Deleted, since the feature is enabled by default now, and the
      GUI control has been dropped (LP: #1575911).
  * disk-check.page:
    - Updated to correspond to gnome-disk-utility 3.18 (LP: #1573025).
  * net-chat-empathy.page:
    - Updated since Empathy is no longer installed by default
      (LP: #1579394).
  * files-disc-write.page:
    - Updated since Brasero is no longer installed by default.
  * numeric-keypad.page, shell-guest-session.page:
    - Suggest lightdm configuration in /etc instead of /usr/share.
  * net-wireless-troubleshooting-initial-check.page:
    - Replace nm-tool (no longer available) with nmcli (LP: #1581846).
  * Updated ubuntu-help.pot.
  * New Kabyle (kab) translation.
  * The latest translations exported from Launchpad (LP: #1592162).
  * debian/control: Bump Standards-Version to 3.9.8.
  * Bump version to 16.10 / yakkety.

  [ Milo Casagrande ]
  * Make Italian screenshots 250x200.

  [ Doug Smythies ]
  * unity.png, unity-windows.png, unity-overview.png:
    - Updated again due to new yet old Ubuntu Software icon
      (LP: #1570479).

 -- Gunnar Hjalmarsson <email address hidden> Fri, 17 Jun 2016 00:11:00 +0200

Changed in ubuntu-docs (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers