Remote Desktop Help File Outdated

Bug #1351403 reported by Svetlana Belkin on 2014-08-01
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-docs (Ubuntu)
Undecided
Doug Smythies

Bug Description

This help file is https://help.ubuntu.com/stable/ubuntu-help/sharing-remote-login.html

I think it is outdated because Ubuntu One doesn't exist any more and I think it's referring to Ubuntu One not Ubuntu SSO. I think this page needs to be removed or edited to only talk about Vino and the other program.

description: updated
description: updated
description: updated
description: updated
Changed in ubuntu-docs (Ubuntu):
status: New → Confirmed
Doug Smythies (dsmythies) wrote :

For reasons yet to be determined, the link to the obsolete page is there for every language (I think) except US english.

For example:

https://help.ubuntu.com/stable/ubuntu-help/sharing.html.en-CA

has the obsolete link.

but

https://help.ubuntu.com/stable/ubuntu-help/sharing.html.en

does not.

Similarly for the page itself, it isn't even there for US english, but is there for all other languages.

Doug Smythies (dsmythies) wrote :

What I think happened is:

When doing the html build for publishing on help.ubuntu.com. I forgot to empty the various language build directories, and so the file was still there. I still show (in en_CA, for example):
-rw-rw-r-- 1 doug doug 1722 Mar 27 20:25 sharing-remote-login.page

whereas the build was actual done on April 6th, and all other files have that date.

There is some cool automatic linking back to parent pages stuff that just goes merrily along, and I was none the wiser.

The master directory (US english) does not have that file.

I suspect the issue of this bug report will self correct with the pending point release of help.ubuntu.com, as long we start with fresh and empty build directories.

Thanks Svetlana!

Gunnar Hjalmarsson (gunnarhj) wrote :

The page was removed from the branch in connection with removal of Ubuntu One related stuff.

http://bazaar.launchpad.net/~ubuntu-core-doc/ubuntu-docs/trusty/revision/404

Doug, this seems to be something for you to look into.

Changed in ubuntu-docs (Ubuntu):
assignee: nobody → Doug Smythies (dsmythies)
status: Confirmed → Triaged
Doug Smythies (dsmythies) wrote :

Gunnar,

Yes, I had just gotten to rev 404, and everything makes sense now. My mistake, I'll fix it.

Changed in ubuntu-docs (Ubuntu):
status: Triaged → In Progress
Gunnar Hjalmarsson (gunnarhj) wrote :

On 2014-08-02 00:02, Doug Smythies wrote:
> What I think happened is:
>
> When doing the html build for publishing on help.ubuntu.com. I forgot
> to empty the various language build directories, and so the file was
> still there. I still show (in en_CA, for example):
> -rw-rw-r-- 1 doug doug 1722 Mar 27 20:25 sharing-remote-login.page
>
> whereas the build was actual done on April 6th, and all other files
> have that date.

I understand that explanation for the sharing-remote-login page, but not for the sharing page.

http://bazaar.launchpad.net/~ubuntu-core-doc/ubuntu-docs/help.ubuntu.com/view/head:/14.04/ubuntu-help/sharing.html.en-CA

Why does that page include the link? What am I missing?

(I'm sure you're going to fix it; just curious.)

Gunnar Hjalmarsson (gunnarhj) wrote :

Aha, you mean the page was still there on your computer when you built? Think I understand now.

Doug Smythies (dsmythies) wrote :

I'll open a new bug report, but it seems "make clean" only deletes stuff in each language directory that it knows about. Since it no longer knows about "sharing-remote-login.page", it leaves it there. Seems really stunned to me.

example, after "make clean":

doug@s15:~/docs-1404/tt_01$ ls -l ubuntu-help/en_CA
total 1356
-rw-r--r-- 1 doug doug 689118 Jul 10 21:31 en_CA.po
-rw-r--r-- 1 doug doug 689118 Apr 6 11:55 en_CA.po.~1~
-rw-rw-r-- 1 doug doug 1722 Mar 27 20:25 sharing-remote-login.page

Gunnar Hjalmarsson (gunnarhj) wrote :

Yeah, a separate bug report seems to make sense.

Talking about languages, I recently added zh_HK. I updated ubuntu-help/Makefile.am, but not html/Makefile. Are those two lists maintained separately? Maybe you should update html/Makefile before building.

Doug Smythies (dsmythies) wrote :

The two language lists were out of sync, not just zh_HK (but that is why I checked it).
Anyway, see revision 417 pushed a few minutes ago.

Gunnar Hjalmarsson (gunnarhj) wrote :

Great, thanks!

(I copied it to the utopic branch.)

Doug Smythies (dsmythies) wrote :

This bug report is being expanded to include this:

https://help.ubuntu.com/14.04/ubuntu-help/a11y-icon.html

which is also there for languages other than US english, including messing up the parent page.

Changed in ubuntu-docs (Ubuntu):
status: In Progress → Fix Committed
Changed in ubuntu-docs (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers