Re-enabling Hibernate for multiple users on Ubuntu 14.04

Bug #1328227 reported by Cruz Fernandez on 2014-06-09
30
This bug affects 5 people
Affects Status Importance Assigned to Milestone
ubuntu-docs (Ubuntu)
Low
Gunnar Hjalmarsson
Trusty
Low
Gunnar Hjalmarsson

Bug Description

trusty SRU request
==================

[Impact]
The main reason for this SRU request is to build ubuntu-docs in trusty with updated translations, in order to prepare for a scheduled update of the trusty language packs.

https://wiki.ubuntu.com/Translations/TrustyTahr/ReleaseSchedule

The fact that the fix of this bug report gets backported is a bonus. ;)

[Test Case]
Start yelp, browse to the power-hibernate page and find that the updated package includes a multiple-sessions action item.

[Regression Potential]
Can't think of anything.

[Original description]
For enabling the Hibernate function the documentation is outdated (it doesn´t mention for multiple users setups how to enable the hibernate option)

On this page https://help.ubuntu.com/14.04/ubuntu-help/power-hibernate.html it should be added the following tag:

[Re-enable hibernate for multiple users by default in logind]
Identity=unix-user:*
Action=org.freedesktop.login1.hibernate-multiple-sessions
ResultActive=yes

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-docs (Ubuntu):
status: New → Confirmed
Gunnar Hjalmarsson (gunnarhj) wrote :

Thanks for your report, Cruz! This is about to be fixed.

Changed in ubuntu-docs (Ubuntu):
assignee: nobody → Gunnar Hjalmarsson (gunnarhj)
importance: Undecided → Low
status: Confirmed → In Progress
Changed in ubuntu-docs (Ubuntu):
status: In Progress → Fix Committed
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-docs - 14.10.1

---------------
ubuntu-docs (14.10.1) utopic; urgency=low

  * html/ubuntu.xsl: Contribute link added.
  * power-hibernate.page:
    - Enabling Hibernate for multiple sessions (LP: #1328227).
  * ubuntu-help/Makefile.am: New zh_HK translation.
  * The latest translations exported from Launchpad.
 -- Gunnar Hjalmarsson <email address hidden> Mon, 23 Jun 2014 23:22:00 +0200

Changed in ubuntu-docs (Ubuntu):
status: Fix Committed → Fix Released
Gunnar Hjalmarsson (gunnarhj) wrote :

Uploaded to trusty-proposed; now in the upload queue.

Changed in ubuntu-docs (Ubuntu Trusty):
assignee: nobody → Gunnar Hjalmarsson (gunnarhj)
importance: Undecided → Low
status: New → In Progress

Hello Cruz, or anyone else affected,

Accepted ubuntu-docs into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/ubuntu-docs/14.04.4 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in ubuntu-docs (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed
Gunnar Hjalmarsson (gunnarhj) wrote :

I have successfully installed and run ubuntu-docs 14.04.4 from trusty-proposed. An action item for multiple-sessions is now included on the power-hibernate page.

tags: added: verification-done
removed: verification-needed

The verification of the Stable Release Update for ubuntu-docs has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-docs - 14.04.4

---------------
ubuntu-docs (14.04.4) trusty-proposed; urgency=low

  * html/ubuntu.xsl: Contribute link added.
  * power-hibernate.page:
    - Enabling Hibernate for multiple sessions (LP: #1328227).
  * ubuntu-help/Makefile.am: New zh_HK translation.
  * The latest translations exported from Launchpad.
 -- Gunnar Hjalmarsson <email address hidden> Mon, 23 Jun 2014 23:38:00 +0200

Changed in ubuntu-docs (Ubuntu Trusty):
status: Fix Committed → Fix Released

Latest tag in documentation with the following "multiple" action is not working on my machine:

"Action=org.freedesktop.login1.hibernate; org.freedesktop.login1.hibernate-multiple-sessions"

If I split it into two tags, works like a charm.

<code>
[Re-enable hibernate by default in logind]
Identity=unix-user:*
Action=org.freedesktop.login1.hibernate
ResultActive=yes

[Re-enable hibernate by default in logind for multiple]
Identity=unix-user:*
Action=org.freedesktop.login1.hibernate-multiple-sessions
ResultActive=yes
</code>

Maybe I'm testing it wrong? Sorry for not testing it *before* making the modification on the documentation :(

Gunnar Hjalmarsson (gunnarhj) wrote :

Hi Cruz,

Unfortunately I'm not able to test it myself, since hibernation doesn't work at all on my machine.

I got the idea with merging them into one entry from an experienced developer. According to "man pklocalauthority" the value of an "Action" key should consist of "a semi-colon separated list of globs to match action identifiers". However, given your latest comment, I now fear that the space character after the semi-colon should not be there.

Can you please test with one entry again, but without that space?

Changed in ubuntu-docs (Ubuntu):
status: Fix Released → Incomplete

Hi Gunnar,

Looks like the space is the culprit!! Thanks a lot for your time on this
issue.

Cruz

El miércoles, 20 de agosto de 2014, Gunnar Hjalmarsson <
<email address hidden>> escribió:

> Hi Cruz,
>
> Unfortunately I'm not able to test it myself, since hibernation doesn't
> work at all on my machine.
>
> I got the idea with merging them into one entry from an experienced
> developer. According to "man pklocalauthority" the value of an "Action"
> key should consist of "a semi-colon separated list of globs to match
> action identifiers". However, given your latest comment, I now fear that
> the space character after the semi-colon should not be there.
>
> Can you please test with one entry again, but without that space?
>
> ** Changed in: ubuntu-docs (Ubuntu)
> Status: Fix Released => Incomplete
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1328227
>
> Title:
> Re-enabling Hibernate for multiple users on Ubuntu 14.04
>
> Status in “ubuntu-docs” package in Ubuntu:
> Incomplete
> Status in “ubuntu-docs” source package in Trusty:
> Fix Released
>
> Bug description:
> trusty SRU request
> ==================
>
> [Impact]
> The main reason for this SRU request is to build ubuntu-docs in trusty
> with updated translations, in order to prepare for a scheduled update of
> the trusty language packs.
>
> https://wiki.ubuntu.com/Translations/TrustyTahr/ReleaseSchedule
>
> The fact that the fix of this bug report gets backported is a bonus.
> ;)
>
> [Test Case]
> Start yelp, browse to the power-hibernate page and find that the updated
> package includes a multiple-sessions action item.
>
> [Regression Potential]
> Can't think of anything.
>
> [Original description]
> For enabling the Hibernate function the documentation is outdated (it
> doesn´t mention for multiple users setups how to enable the hibernate
> option)
>
> On this page https://help.ubuntu.com/14.04/ubuntu-help/power-
> hibernate.html it should be added the following tag:
>
> [Re-enable hibernate for multiple users by default in logind]
> Identity=unix-user:*
> Action=org.freedesktop.login1.hibernate-multiple-sessions
> ResultActive=yes
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/ubuntu-docs/+bug/1328227/+subscriptions
>

--
X

Gunnar Hjalmarsson (gunnarhj) wrote :

Thanks for confirming that, Cruz. I filed bug #1360657 about it.

https://help.ubuntu.com/14.04/ubuntu-help/power-hibernate.html should be updated with the correction tomorrow. However, the ubuntu-docs package for trusty will be updated only in a few months.

Changed in ubuntu-docs (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers