In Power Part : Wrong Help Doc at Hibernate

Bug #1279349 reported by Kamin Punpipat on 2014-02-12
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-docs (Ubuntu)
Undecided
Unassigned

Bug Description

This is old Help Documents that work only old version :
{Enable hibernate
If the hibernate test works, you can continue to use the pm-hibernate command when you want to hibernate.
You can also enable the hibernate option in the menus. To do that, use your favorite text editor to create /etc/polkit-1/localauthority/50-local.d/com.ubuntu.enable-hibernate.pkla. Add the following to the file and save:
[Re-enable hibernate by default]
Identity=unix-user:*
Action=org.freedesktop.upower.hibernate
ResultActive=yes

End}

But I do this I did't see Hibernate menu. When I use pm-hibernate command that work for me.
This is work for me also :
    [Re-enable hibernate by default in upower]
    Identity=unix-user:*
    Action=org.freedesktop.upower.hibernate
    ResultActive=yes

    [Re-enable hibernate by default in logind]
    Identity=unix-user:*
    Action=org.freedesktop.login1.hibernate
    ResultActive=yes

For I try search solutions on web there tell... :
{Re-enabling the hibernation option in the menu

To re-enable the hibernation option in the menu, your /etc/polkit-1/localauthority/50-local.d/com.ubuntu.enable-hibernate.pkla should be modified to look like the following in saucy (13.10):

[Re-enable hibernate by default in upower]
Identity=unix-user:*
Action=org.freedesktop.upower.hibernate
ResultActive=yes

[Re-enable hibernate by default in logind]
Identity=unix-user:*
Action=org.freedesktop.login1.hibernate
ResultActive=yes

Then reboot or run killall indicator-session-service in your session and you should have your hibernate functionality/menu option back.
Investigation from bug report

Citation from Jeffery To's post on Launchpad Bug Report #1232814:

    For Saucy, indicator-session was updated to use logind (org.freedesktop.login1) instead of upower.

    If you check /var/lib/polkit-1/localauthority/10-vendor.d/com.ubuntu.desktop.pkla, you'll see that hibernate is disabled by default in both upower and logind.

    So the first step to re-enable the Hibernate option is to edit /etc/polkit-1/localauthority/50-local.d/com.ubuntu.enable-hibernate.pkla to something like:

    [Re-enable hibernate by default in upower]
    Identity=unix-user:*
    Action=org.freedesktop.upower.hibernate
    ResultActive=yes

    [Re-enable hibernate by default in logind]
    Identity=unix-user:*
    Action=org.freedesktop.login1.hibernate
    ResultActive=yes

    After rebooting, the login screen session menu should have a Hibernate option.

    [...]

All thanks and credit go to Jeffery!
Why was hibernation disabled?

There exists a bug report on launchpad that suggests disabling suspend/hibernate instead of tracking which hardware "certifies" for which power modes. It's claimed to be a more scalable approach.

However, please understand that this is not a place to complain and please be nice.
End}

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: ubuntu-docs 13.10.2
ProcVersionSignature: Ubuntu 3.11.0-17.31-generic 3.11.10.3
Uname: Linux 3.11.0-17-generic x86_64
ApportVersion: 2.12.5-0ubuntu2.2
Architecture: amd64
Date: Wed Feb 12 20:39:16 2014
InstallationDate: Installed on 2014-01-08 (34 days ago)
InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Release amd64 (20131016.1)
MarkForUpload: True
PackageArchitecture: all
SourcePackage: ubuntu-docs
UpgradeStatus: No upgrade log present (probably fresh install)

Changed in ubuntu-docs (Ubuntu):
status: New → Confirmed
Gunnar Hjalmarsson (gunnarhj) wrote :

Thanks for your effort to improve Ubuntu by submitting this bug report! The issue you bring up has been reported previously, and is about to be fixed, so I mark this bug as a duplicate.

Cruz Fernandez (cruz-fernandez) wrote :

Don't we need on a multiple setup machine to add also this:

[Re-enable hibernate multiple by default in logind]
Identity=unix-user:*
Action=org.freedesktop.login1.hibernate-multiple-sessions
ResultActive=yes

(At least on my machine I couldn't make it work until that option was added)

I cannot change Status to Fix Released because it duplicated with some bug.
But just remember that this is Fix Released.
If can change status PLS change it to Fix Released.

Gunnar Hjalmarsson (gunnarhj) wrote :

Hi Kamin,

Don't worry. Once a bug has been marked as a duplicate of some other bug, we don't keep updating the status of the former. In this case bug #1232814 is "Fix Released", so all is well.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers