Ubuntu

Ubuntu 7.04 and 7.10 documentation updates have not been done

Reported by Timo Jyrinki on 2007-07-04
12
Affects Status Importance Assigned to Milestone
ubuntu-docs (Ubuntu)
High
Matthew East
Declined for Feisty by Matthew East
Gutsy
Low
Matthew East

Bug Description

We have not yet updated the translations of the ubuntu-docs package in the stable release. Doing so is important because the translators put in plenty of hard work after the release is done and to improve the quality of the localisation of the Help Center. Software localisations are updated regularly through the language-packs, we should also update localisation of documentation.

Impact of the update on users should be minimal: all translations are tested to ensure the docbook xml validates and any errors are fixed.

Matthew East (mdke) wrote :

Thanks for your bug. I'll work on this.

Changed in ubuntu-docs:
assignee: nobody → mdke
importance: Undecided → High
status: New → Confirmed
Matthew East (mdke) on 2007-10-08
Changed in ubuntu-docs:
status: Confirmed → In Progress
description: updated
Matthew East (mdke) wrote :

Currently working on importing and validating gutsy translations.

Matthew East (mdke) wrote :

Translations updated and validated in the gutsy branch, package built and tested. I'll prepare a debdiff.

Changed in ubuntu-docs:
importance: Undecided → Low
status: New → In Progress
Matthew East (mdke) wrote :

Starting the SRU process. ubuntu-sru subscribed.

Debdiff is http://doc.ubuntu.com/~mdke/ubuntu-docs.debdiff

description: updated
Matthew East (mdke) wrote :

Description updated.

I will also need a sponsor to upload the package, which can be got from https://code.edge.launchpad.net/~ubuntu-core-doc/ubuntu-doc/gutsy

Can the SRU team please advise if this upload needs to go into -proposed? If so I will amend the changelog.

Matthew East (mdke) wrote :

Anticipating the answer to my question above, I've amended the changelog entry to refer to gutsy-proposed. Please let me know if everything is ok!

Martin Pitt (pitti) wrote :

The attached debdiff is quite broken (DOS line endings, and fromdos does not appear to fix it). For sponsoring, what do I need to do to get the uploadable source package? just check out the branch and debuild -S?

Right, the package needs to go through -proposed first. Updating the documentation is appropriate for SRU.

Matthew East (mdke) wrote :

Yes, "bzr checkout lp:ubuntu-doc/gutsy" then debuild should do the trick.

I'm subscribing ubuntu-main-sponsors too.

Martin Pitt (pitti) wrote :

Taking for sponsoring.

Changed in ubuntu-docs:
assignee: nobody → pitti
Martin Pitt (pitti) wrote :

Sponsored and accepted into gutsy-proposed. Please collect some testing feedback for various languages for verification.

Changed in ubuntu-docs:
assignee: pitti → mdke
status: In Progress → Fix Committed
Timo Jyrinki (timo-jyrinki) wrote :

ubuntu-docs 7.10.5 on gutsy seems to be very good in Finnish (fi). I went quickly through all the chapters, and happily noticed all the improvements made after gutsy's release / freeze.

Matthew East (mdke) wrote :

I've tested it with Italian, Chinese, German and English and all seems to be in good shape.

I've tested that the translations appear using the command "LANG=xx yelp". I've also done a "sudo scrollkeeper-rebbuilddb" to check for any validity errors, none appear.

Given that I don't think this update can really depend on different hardware or configurations, I'll assume this is suitable testing and am substituting the verification-needed tag with verification-done. please let me know if more testing is required.

Tested it in Russian. Looks better then in used to be. The only thing which puzzled me is the completely untranslated "Assistive Tools" section (intenal link: file:///usr/share/gnome/help/gnome-access-guide/C/gnome-access-guide.xml) and I was not able to find a corresponding template for translations in https://translations.launchpad.net/ubuntu/gutsy/+source/ubuntu-docs/

Tested in Danish - though the Danish Translators Team (mainly me) have only translated two sections of the docs, they look nice.

Alexey,

On Thu, Mar 6, 2008 at 1:18 PM, Alexey Balmashnov
<email address hidden> wrote:
> Tested it in Russian. Looks better then in used to be.

Thanks. I think this fix has now been sufficiently tested and proved valid.

> The only thing
> which puzzled me is the completely untranslated "Assistive Tools"
> section

That's not related to this bug. See this post for an explanation:
https://lists.ubuntu.com/archives/ubuntu-translators/2007-October/001333.html

--
Matthew East
http://www.mdke.org
gnupg pub 1024D/0E6B06FF

Matthew East [2008-03-06 14:33 -0000]:
> Thanks. I think this fix has now been sufficiently tested and proved
> valid.

I agree, thanks to everyone. I'll move it to updates after the 7 day
maturing period is over.

Matthew East (mdke) wrote :

Martin, has this been done yet?

Martin Pitt (pitti) wrote :

Copied to gutsy-updates.

Changed in ubuntu-docs:
status: Fix Committed → Fix Released
Matthew East (mdke) wrote :

Marking as fix released - we won't fix this in Feisty I think, as it is already nearly a year old.

Changed in ubuntu-docs:
status: In Progress → Fix Released
Timo Jyrinki (timo-jyrinki) wrote :

I agree. Let's just have better updates from now on, and it was great to have the gutsy update done. Thank you.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers