addremove-sources.page needs to say saucy

Bug #1225247 reported by John Kim on 2013-09-14
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-docs (Ubuntu)
Undecided
Doug Smythies

Bug Description

s/precise/saucy

Please see the file contents. The repository codes are talking about precise when they should be talking about saucy.

John Kim (kotux) on 2013-09-14
tags: added: bitesize saucy
description: updated
Doug Smythies (dsmythies) wrote :

Do the desktop help docs not have any automatic entity substitution? In the serverguide all distro specific edits are handled automatically, so there is no need to edit them for each cycle.

If not then, in my option it makes sense to leave it at least as an LTS name, and add some text saying to make the entry as required for your specific distro.

Little Girl (littlergirl) wrote :

I looked through the files and don't see a script that does entity substitution. From what I can see, not every reference to an outdated release is inside of a specific kind of entity, and not all uses of the release names have anything to do with the releases (for instance, one could use the word "precise" or "Precise" when referring to aiming at something with the mouse, and it would have nothing to do with the Precise release).

Since that means updating release references probably have to be done manually, I wrote a script. It checks for the names of all releases and displays a list of page names for each one that it finds. The array it uses contains each release name in lower case and also in upper and lower case. This way it won't miss any, and you'll know exactly what to search for inside each file when updating them.

I haven't pushed it onto the server because I don't know whether it would be welcome. You can push it if it is, or let me know and I'll do it. (:

Little Girl (littlergirl) wrote :

The script should be attached to this comment.

John Kim (kotux) wrote :

Wow, thanks for the script! This is really nice.

Running the script, there aren't many pages with the release names:

--------------------------------------------------------------------------------------------------
john@sparrow:~/ubuntu-docs/ubuntu-help/C$ ~/check_releases.sh

== These pages contain Precise ==
unity-scrollbars-intro.page

== These pages contain precise ==
addremove-sources.page
power-batteryestimate.page
unity-hud-intro.page

== These pages contain quantal ==
index.page
--------------------------------------------------------------------------------------------------

But I will check 'em out.

---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Little Girl (littlergirl) wrote :

I'm glad you like it. Let me know if I should push it onto the server to add to the others that are already there. I can fix those few pages before Thursday's freeze - I figured I'd leave them that way so you could see what the script does. Otherwise you'd have had to edit it and add to the array to get it to give you results. (:

Doug Smythies (dsmythies) wrote :

Thanks for your work on this one. Yes, you should push your script.

Little Girl (littlergirl) wrote :

You're welcome, and it's pushed. (:

Doug Smythies (dsmythies) wrote :

making originally suggested changes.

Changed in ubuntu-docs (Ubuntu):
status: New → Confirmed
assignee: nobody → Doug Smythies (dsmythies)
status: Confirmed → In Progress
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-docs - 13.10

---------------
ubuntu-docs (13.10) saucy; urgency=low

  [Kevin Godby]
  * Improved wording of 'report a bug' footer text.
  * Added missing word (LP: #1170491)
  * Updated 'Google Docs' to 'Google Drive (LP: #1059554)
  * Various String Fixes and Validation Error Fixes
  * collect-screenshots.sh:
    - Fix Various Bugs
  * configure.in:
    - Bump version to 13.10
  * Update Add Accounts Instructions (LP: #1220968)
  * Merge updates from GNOME Upstream

  [John Kim]
  * String Fix (LP: #1189280)

  [Doug Smythies]
  * Add Colors (LP: #1173426)
  * fix-urls.sed:
  - Update Gnome Link
  * Update Screenshots
  * Update Time Instructions (LP: #1225251)
  * Replace Gwibber Page with Friends Page
  * Change references to Saucy (LP: #1225247)

  [Stephen Webb]
  * Update What's New for 13.10

  [Little Girl]
  * Improve Page Verbiage (LP: #1225829, LP: 1221452, LP: 1221456, LP: 1225842, LP: 1225842)
  * Added check_releases.sh to check for release versions in .page files

  [Benjamin Kerensa]
  * debian/control: Update Vcs-Bzr Field
  * debian/copyright: Update Copyright Year
 -- Benjamin Kerensa <email address hidden> Tue, 17 Sep 2013 01:04:05 -0700

Changed in ubuntu-docs (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers