"Compiz documentation website" link does not open properly in Firefox

Bug #109041 reported by Sandy Armstrong
32
Affects Status Importance Assigned to Milestone
ubuntu-docs (Ubuntu)
Fix Released
Undecided
Phil Bull

Bug Description

Binary package hint: ubuntu-docs

In help section 3.1 (Advanced configuration), there is a link to "Compiz documentation website". If I copy/paste the link I get this:

http://www.go-compiz.org/index.php?title=Gconf-Editor

But if I just click on it, Firefox tries to open this URL, which does not work:

http://compiz.orgindex.php/?title=Gconf-Editor

Revision history for this message
Sandy Armstrong (sanfordarmstrong) wrote :

I'm sorry, I obviously meant section 3.1 of the "Desktop Effects" help.

Revision history for this message
Phil Bull (philbull) wrote :

I can confirm this. It seems that a '/' has gotten misplaced in that URL.

Changed in ubuntu-docs:
assignee: nobody → philbull
status: Unconfirmed → Confirmed
Revision history for this message
Phil Bull (philbull) wrote :

After further investigation, it seems that the problem is actually caused by a broken redirect on the Compiz website. The URLs in the documentation are all well-formed and it's not Firefox-specific either (the same happens in the links browser). For an example of the problem:

'http://www.go-compiz.org' redirects to 'http://compiz.org/'
'http://www.go-compiz.org/index.php?title=Gconf-Editor' redirects to 'http://compiz.orgindex.php/?title=Gconf-Editor'
'http://www.go-compiz.org/anything' redirects to 'http://www.compiz.organything/'

I'll email their webmaster to see if this can be sorted out.

Changed in ubuntu-docs:
status: Confirmed → Needs Info
Revision history for this message
John-Scott Atlakson (john-scott-atlakson) wrote :

The correct URL appears to be: http://compiz.org/Gconf-Editor

Revision history for this message
Phil Bull (philbull) wrote :

I've changed and tested the URLs (thanks John-Scott) and uploaded the fix to SVN trunk. This won't affect Feisty, though.

I've also emailed the compiz.org webmaster.

Revision history for this message
Phil Bull (philbull) wrote :

I emailed <email address hidden> on the 22nd of April and <email address hidden> on the 13th of May. No reply from either so far (I think I'm in the moderation queue for the second).

Revision history for this message
Phil Bull (philbull) wrote :

No reply. It's not even showed up on their list archives, so I assume they either don't check their moderation queue or just deleted it. Any ideas?

Revision history for this message
Rob Tirrell (r-tirrell) wrote : Re: [Bug 109041] Re: "Compiz documentation website" link does not open properly in Firefox

Hey - it looks like someone got to it... but I'm not totally sure if your
mail came before or after that!

On 6/19/07, Phil Bull <email address hidden> wrote:
>
> No reply. It's not even showed up on their list archives, so I assume
> they either don't check their moderation queue or just deleted it. Any
> ideas?
>
> --
> "Compiz documentation website" link does not open properly in Firefox
> https://bugs.launchpad.net/bugs/109041
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

--
Regards, Rob Tirrell

Revision history for this message
Phil Bull (philbull) wrote :

Hi Rob,
I still get the problem (Feisty), and haven't seen my mail turn up on Compiz list. What do you mean by 'someone got to it'? Are you running Gutsy?
Thanks

Revision history for this message
Phil Bull (philbull) wrote :

Marking as 'Fix Committed' for Gutsy. There's not really anything more I can do for Feisty.

Changed in ubuntu-docs:
status: Incomplete → Fix Committed
Revision history for this message
Duncan Lithgow (duncan-lithgow) wrote :

This bug can be avoided in future by fixing Bug #118741

Revision history for this message
Rob Tirrell (r-tirrell) wrote :

Good to hear! Hope it's working well for you.

On 8/5/07, Phil Bull <email address hidden> wrote:
>
> Marking as 'Fix Committed' for Gutsy. There's not really anything more I
> can do for Feisty.
>
> ** Changed in: ubuntu-docs (Ubuntu)
> Status: Incomplete => Fix Committed
>
> --
> "Compiz documentation website" link does not open properly in Firefox
> https://bugs.launchpad.net/bugs/109041
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

--
Regards, Rob Tirrell

Phil Bull (philbull)
Changed in ubuntu-docs:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers