Ubuntu

New /media/$user mounting in 12.10 is poorly documented

Reported by snori on 2012-10-18
68
This bug affects 13 people
Affects Status Importance Assigned to Milestone
ubuntu-docs (Ubuntu)
Undecided
John Kim

Bug Description

( lsb_release -rd = Description: Ubuntu 12.10 Release: 12.10)

The past behavior was for a USB drive "mystick" to mount under /media/mystick.

With 12.10, this behavior has changed, so that it now mounts to /media/<username>/mystick - where <username> is the name of the user.

The documentation at https://help.ubuntu.com/community/Mount/USB needs changing to:

(a) Reflect this change - ie read "By default, storage devices that are plugged into the system mount automatically in the /media/<username> directory..."

(b) Provide a note like this "(This is a slight change from the behavior in previous versions - the rationale is explainn at http://???)

Logan Rosen (logan) on 2012-10-18
affects: udisks2 (Ubuntu) → ubuntu-docs (Ubuntu)
Distant Thunder (temptempor) wrote :

Yes, I also find this very annoying that they changed this feature without any warning, resulting that all programs that needed absolute paths like music player in order to find your library on another partition that you might be sharing with Windows or some other OS, are all broken since mounting path changed.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-docs (Ubuntu):
status: New → Confirmed
Nithin C (nithin-aneesh) wrote :

This breaks programs using absolute paths, like music players (Rhythmbox), photo library management (Shotwell) and Safely Remove from the unity launcher (the quicklist item does not appear on partitions of an USB HDD). So I have reverted back to Ubuntu 12.04 which doesn't have this problem.

This bollocksed all the symbolic links on an external HDD.

Workaround at:

https://answers.launchpad.net/ubuntu/+source/util-linux/+question/210769 Post #6

Worked for me.

Constantine (theaspect) wrote :

It would be great if we have symlink in home directory ~/Media to /media/UserName

John Kim (kotux) on 2013-06-09
tags: added: wiki
removed: documentation
summary: - New /media/$user mounting in 12.10 is poorly dcumented
+ New /media/$user mounting in 12.10 is poorly documented
John Kim (kotux) on 2013-06-09
Changed in ubuntu-docs (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → John Kim (thinkndev)
John Kim (kotux) wrote :

I'll be working on this.

John Kim (kotux) on 2013-06-09
Changed in ubuntu-docs (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers