Broken links to page "Manage apps & settings with the menu bar" in ubuntu-help 12.10.3

Bug #1064559 reported by Vassili Platonov on 2012-10-09
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Ubuntu Translations
Undecided
Unassigned
ubuntu-docs (Ubuntu)
Undecided
Unassigned

Bug Description

Ubuntu-docs in Ubuntu Quantal template ubuntu-help (rev. 12.10.3)

The page "unity-appmenu-intro" is missing in 12.10.3. It seems it was renamed into "unity-menubar-intro".
~$ dpkg -L ubuntu-docs | grep unity-appmenu-intro.page -- displays nothing.

Therefore xref links were broken in some strings:

#1501 Empathy is installed by default in Ubuntu. Start <app>Empathy Instant Messaging</app> from the <link xref="unity-dash-intro">dash</link>, the <link xref="unity-launcher-intro">launcher</link> or choose <gui>Chat</gui> from the <link xref="unity-appmenu-intro">Messaging menu</link>.

It should be "Empathy is installed by default in Ubuntu. Start <app>Empathy Instant Messaging</app> from the <link xref="unity-dash-intro">dash</link>, the <link xref="unity-launcher-intro">launcher</link> or choose <gui>Chat</gui> from the <link xref="unity-menubar-intro">Messaging menu</link>."

#1502 You can change your instant messaging status (Available, Away, Busy etc) from the <link xref="unity-appmenu-intro">Messaging menu</link>.

It shoul be "You can change your instant messaging status (Available, Away, Busy etc) from the <link xref="unity-menubar-intro">Messaging menu</link>."

#1519 Click the <link xref="unity-appmenu-intro">Messaging menu</link> on the right hand side of the menu bar.

It shoul be "Click the <link xref="unity-menubar-intro">Messaging menu</link> on the right hand side of the menu bar."

#1523 You can now view your social networking messages from the <link xref="unity-appmenu-intro"> Messaging menu</link> on the right hand side of the menu bar, in the <gui>Broadcast</gui> section. Click on any of the items in that section to open <gui>Gwibber</gui> and to read or post messages to your social network.

It shoul be "You can now view your social networking messages from the <link xref="unity-menubar-intro"> Messaging menu</link> on the right hand side of the menu bar, in the <gui>Broadcast</gui> section. Click on any of the items in that section to open <gui>Gwibber</gui> and to read or post messages to your social network."

#1663 Click the <link xref="unity-appmenu-intro">network menu</link> in the menu bar and select <gui>Edit Connections...</gui>

It shoul be "Click the <link xref="unity-menubar-intro">network menu</link> in the menu bar and select <gui>Edit Connections...</gui>"

#2322 To log out or switch users, click the <link xref="unity-appmenu-intro">system menu</link> at the very right of the menu bar and select the appropriate option.

It shoul be "To log out or switch users, click the <link xref="unity-menubar-intro">system menu</link> at the very right of the menu bar and select the appropriate option."

#2973 Get work done in style with LibreOffice 3.6, now with new, modern presentation templates and built-in support for Ubuntu's integrated <link xref="unity-appmenu-intro#app-menus">menu bar</link>.

It shoul be "Get work done in style with LibreOffice 3.6, now with new, modern presentation templates and built-in support for Ubuntu's integrated <link xref="unity-menubar-intro#app-menus">menu bar</link>."

Thanks.

summary: - Page "unity-appmenu-intro" is missing in 12.10.3
+ Broken links to page "Manage apps & settings with indicator status
+ menus" in ubuntu-help 12.10.3
description: updated
tags: added: quantal
summary: - Broken links to page "Manage apps & settings with indicator status
- menus" in ubuntu-help 12.10.3
+ Broken links to page "Manage apps & settings with the menu bar" in
+ ubuntu-help 12.10.3
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-docs (Ubuntu):
status: New → Confirmed
Jeremy Bicha (jbicha) wrote :

I have now fixed this in the ubuntu-docs bzr branch and updated the translations also. To keep ubuntu-docs in sync with the language packs, I don't think I should upload this fix into quantal until just before we build the next language pack.

Changed in ubuntu-docs (Ubuntu):
status: Confirmed → Fix Committed
Vassili Platonov (vassilip) wrote :

@Jeremy Bicha
Thanks, nice and urgent job!
But #1523 & #2322 still remain unrevised.

Jeremy Bicha (jbicha) wrote :

Ah, the translations were split across two lines. Ok I just pushed another correction.

By the way, those numbers (1523, 2322, etc) don't mean anything to me. Below the string on translations.launchpad.net, there is a "Located in C/legal.xml:3(license/p)" line; mentioning that the problem is in legal.xml is helpful. Otherwise, I can just use grep to find the string.

Vassili Platonov (vassilip) wrote :

Don't be angry, Jeremy, I'm just a translator and use rosetta ;-)
For the future, I'll attend more to these things, I promise. Sorry once more.

Vassili Platonov (vassilip) wrote :

Please last effort:
C/net-chat-social.page:51(page/p)
You can now view your social networking messages from the <link xref="unity-menubar-intro"> Messaging menu</link> on the right hand side of the menu bar, in the <gui>Broadcast</gui> section. Click on any of the items in that section to open <gui>Gwibber</gui> and to read or post messages to your social network.

Vassili Platonov (vassilip) wrote :

This bug is reproduced in raring:

C/net-chat-empathy.page:29
C/net-chat-empathy.page:37
C/net-chat-social.page:32
C/net-chat-social.page:51
C/net-mobile.page:71
C/shell-exit.page:46
C/whats-new.page:47

All of this strings refer to C/unity-appmenu-intro.page not to C/unity-menubar-intro.page.

Vassili Platonov (vassilip) wrote :

Reproduces in raring

Changed in ubuntu-docs (Ubuntu):
status: Fix Committed → Incomplete
tags: added: raring
Changed in ubuntu-docs (Ubuntu):
status: Incomplete → Fix Committed
Vassili Platonov (vassilip) wrote :

False alarm :) Jeremy fixed it all a few minutes ago.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-docs - 13.04.1

---------------
ubuntu-docs (13.04.1) raring; urgency=low

  [ Jeremy Bicha ]
  * Correct links to renamed menu bar page (LP: #1064559)
  * Fix "valuable" typo (LP: #1061512)
  * Add missing breadcrumbs to lens pages (LP: #1066482)

  [ Benjamin Kerensa ]
  * Merged updated gnome-docs
  *Bumped version numbers on the "What's new in Ubuntu 13.04?" page

  [Kevin Godby]
  * Capitalized Dash and Launcher consistently
 -- Benjamin Kerensa <email address hidden> Mon, 15 Apr 2013 19:33:07 -0700

Changed in ubuntu-docs (Ubuntu):
status: Fix Committed → Fix Released
Changed in ubuntu-translations:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers