Help pages all in Chinese with no Accept-Language

Bug #1000049 reported by Tim Starling on 2012-05-16
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ubuntu-docs (Ubuntu)
High
Unassigned

Bug Description

If you go to any help page on help.ubuntu.com, for example:

https://help.ubuntu.com/12.04/ubuntu-help/index.html

And you happen to be using a browser which does not send an Accept-Language header, the page will be shown in Chinese. No option or link is visible allowing the page to be shown in another language. Confirmed using source IP addresses from 3 countries, none of them China, so it doesn't seem to be geolocated.

Adolfo Jayme (fitojb) wrote :

Impractical workaround: append a dot and the language code to the URL. Example: https://help.ubuntu.com/12.04/ubuntu-help/index.html.es

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-docs (Ubuntu):
status: New → Confirmed
no longer affects: ubuntu-website
John Kim (kotux) on 2013-06-11
tags: added: website
Gunnar Hjalmarsson (gunnarhj) wrote :

This bug should be about to be fixed. Via revision 142 and 144 in the linked branch the previous

ForceLanguagePriority Fallback

in the .htaccess file has been replaced with

LanguagePriority en
ForceLanguagePriority Prefer Fallback

We will see tomorrow if it changes the behavior as expected.

Changed in ubuntu-docs (Ubuntu):
importance: Undecided → High
status: Confirmed → Fix Committed
Doug Smythies (dsmythies) wrote :
Download full text (3.5 KiB)

Note that the directives do not work as the apache documentation says they should.

Test results that lead to Gunnar's change above:

Server = 12.04 (Apache 2.2):

Browswer = no language preference list:

1.) No .htaccess file at all: Result: English
2.) .htaccess with only "LanguagePriority en". Result: English
3.) .htaccess with only "LanguagePriority zh-CN". Result: Chinese
4.) .htaccess with "LanguagePriority zh-CN" and "ForceLanguagePriority Fallback". Result: Chinese
5.) .htaccess with "LanguagePriority en" and "ForceLanguagePriority Fallback". Result: Chinese
6.) .htaccess with only "ForceLanguagePriority Fallback". Result: Chinese
7.) No .htaccess file at all: Result: English (Sanity check)
8.) .htaccess with only "LanguagePriority en". Result: English
9.) .htaccess with only "LanguagePriority zh-CN". Result: Chinese
10.) .htaccess with only "LanguagePriority en". Result: English

11.) .htaccess with only "LanguagePriority de". Result: German
12.) .htaccess with "LanguagePriority de" and "ForceLanguagePriority Fallback". Result: Chinese
13.) .htaccess with "LanguagePriority de" and "ForceLanguagePriority Prefer Fallback". Result: German
14.) .htaccess with "LanguagePriority zz" and "ForceLanguagePriority Prefer Fallback". Result: Chinese
15.) .htaccess with only "ForceLanguagePriority Prefer Fallback". Result: English

Now, .htaccess with "LanguagePriority de" and "ForceLanguagePriority Prefer Fallback":

16.) Language preference French. Result: French
17.) Language preference Afrikaans. Result: German (Note: we do not have this language).
18.) Language preferences en then en-US (my original settings). Result: English

19.) No .htaccess at all and Language preference Afrikaans. Result: English
20.) .htaccess with only "LanguagePriority de" and Language preference Afrikaans. Result: German
21.) .htaccess with "LanguagePriority de" and "ForceLanguagePriority Prefer" and Language preference Afrikaans. Result: Firefox doesn't know what to do and asks me. Click O.K. to open with firefox and get a mess, albeit an English mess.
22.) .htaccess with "LanguagePriority de" and "ForceLanguagePriority Prefer Fallback" and Language preference Afrikaans. Result: German

Server = 14.04 (Apache 2.4):

Browswer = no language preference list:

1.) No .htaccess file at all: Result: English
2.) .htaccess with only "LanguagePriority de". Result: German
3.) .htaccess with "LanguagePriority de" and "ForceLanguagePriority Fallback". Result: Chinese
4.) .htaccess with only "ForceLanguagePriority Fallback". Result: Chinese
5.) .htaccess with "LanguagePriority zz" and "ForceLanguagePriority Fallback". Result: Chinese
6.) .htaccess with "LanguagePriority zz" and "ForceLanguagePriority Prefer Fallback". Result: Chinese
7.) .htaccess with only "ForceLanguagePriority Prefer Fallback". Result: English

Now, .htaccess with "LanguagePriority de" and "ForceLanguagePriority Prefer Fallback":

8.) Language preference French. Result: French
9.) Language preference Afrikaans. Result: German (Note: we do not have this language).
10.) No .htaccess at all and Language preference Afrikaans. Result: English
11.) .htaccess with only "LanguagePriority de" and Language preference ...

Read more...

Gunnar Hjalmarsson (gunnarhj) wrote :

Right, Doug, without those tests it would have been difficult to figure out a working configuration. Thanks!

For the record it's worth mentioning that the crawlers of the search engines don't send Accept-Language headers. Hence the most serious consequence of this bug has been that titles and descriptions in search results at Google and friends have been displayed in random languages; in Google that language has usually been Chinese.

https://www.google.com/?#q=site:help.ubuntu.com/lts/ubuntu-help

This is the reason why I set the importance of this bug to high.

Changed in ubuntu-docs (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers